Jump to content

Photo
- - - - -

CTD: OA has stopped working


  • Please log in to reply
11 replies to this topic
Thread Starter
Zorg_DK
Zorg_DK

    Gunnery Sergeant

  • Members
  • 491 posts

#1

Posted 29 June 2010 - 19:22

Hi all,

I get CTD in OA every time I play. It's different how quickly it happens. It happens both in the campaign and in training. I installed the Win 7 GPU stress MS hotfix posted on this forum in a sticky. No difference. Old Arma 2 and other games runs good with no CTD. When it crashes it says OA has stopped working.

I'm running with no mods (ACE 1.2 is installed though.).

Here's my target line:

"D:\Games\ArmA 2\arma2OA.exe" -nosplash -cpuCount=4 -exThreads=7


Things I will try:

-delete -exThreads=7.

-sound is set to 128 in OA. I'll try decrease that.


System:

i7 930 @ 4.2
6 GB ram
5870 with Catalyst 10.6, Cat. AI set to advanced
2x SSD
Xonar Essence ST
Win 7 x64

Another bug: In options it seems that object and terrain quality reverts to normal each time game starts.

OA is awesome otherwise! If I don't sort out the CTD I sure hope BIS finds a fix.

Killerwatt
Killerwatt

    Gunnery Sergeant

  • Members
  • 405 posts

#2

Posted 29 June 2010 - 19:54

I've noticed that if you set your options and the game subsequently crashes then the options you set will not be saved. So its always better to set your options, quit the game and restart, then your options should be safe.
Cheers,
Stewart.
__________________

And do not you realize we are very community oriented company, we support modding as much as we can and that we are not going change in this approach as this is what we like the most about our work?
Marek Spanel - CEO www.bistudio.com

Thread Starter
Zorg_DK
Zorg_DK

    Gunnery Sergeant

  • Members
  • 491 posts

#3

Posted 29 June 2010 - 20:39

I've noticed that if you set your options and the game subsequently crashes then the options you set will not be saved. So its always better to set your options, quit the game and restart, then your options should be safe.


Yes I'm aware of that. Options revert to normal when restarting after a normal shutdown.

Thread Starter
Zorg_DK
Zorg_DK

    Gunnery Sergeant

  • Members
  • 491 posts

#4

Posted 29 June 2010 - 22:54

Update: I lowered terrain and objects to normal and removed-exThreads=7. It seems to have helped.

WTE_Grendal
WTE_Grendal

    Lance Corporal

  • Members
  • 49 posts

#5

Posted 29 June 2010 - 23:07

I have the same problem. I believe for me the CTD is a memory issue as the first CTD had a out of memory message.
Similar setup to Zorg except Nvidia cards (2 x gtx295).
I'm running OA with the same settings as I run ArmA II and even with the 1.07 update I am not seeing this issue with ArmA II.
Posted Image

Thread Starter
Zorg_DK
Zorg_DK

    Gunnery Sergeant

  • Members
  • 491 posts

#6

Posted 30 June 2010 - 13:49

OA keeps crashing randomly for me. Still the message: OA has stopped working. I'm at mission 3 in the campaign.

=WFL= Sgt Bilko
=WFL= Sgt Bilko

    Staff Sergeant

  • Members
  • 328 posts

#7

Posted 30 June 2010 - 13:55

i7 930 @ 4.2 - have you tried running lower or at normal specs? Maybe OA is pushing your OC over the edge.
Posted Image
~~ He flung himself upon his camel and rode madly off in all directions ~~

bobdihi
bobdihi

    Suspended Member

  • Banned
  • 5 posts

#8

Posted 02 July 2010 - 17:43

Same problem here. Random crashes to desktop. Sometimes in menu sometimes during play. Cant play longer than 1min. Eish.

Win 7, 4870, 2gb ram, q6600

Thank you Bis. Next time im getting the game from torrents. What a waste of money for unfinished product.

EDcase
EDcase

    Sergeant Major

  • Members
  • 1595 posts

#9

Posted 02 July 2010 - 17:53

Same problem here. Random crashes to desktop. Sometimes in menu sometimes during play. Cant play longer than 1min. Eish.

Win 7, 4870, 2gb ram, q6600

Thank you Bis. Next time im getting the game from torrents. What a waste of money for unfinished product.


With 2gb ram I'm surprised you can do anything in Win7

I think you are going to need more ram whatever the problem is.

-------------------------
For CTD:
Try the latest Beta.
Set texture memory to NORMAL

Edited by EDcase, 16 July 2010 - 15:01.


jblackrupert
jblackrupert

    Sergeant Major

  • Members
  • 1965 posts

#10

Posted 16 July 2010 - 03:40

This random crashing thing is popping up a lot.

Everthing is fine for awhile and then OA just crashes constantly
and there is no pattern to it.

I haven't got it yet but a bunch of people I've talked to who do have it can't play
for more then a couple minutes without crashing.

Saint7
Saint7

    Private First Class

  • Members
  • 11 posts

#11

Posted 01 December 2010 - 09:07

For me my Arma2 OA crashes before it even starts.
Is there a solution to this?

EDIT: I have solved the problem by using "Troubleshoot compatibility" in Windows 7.
I hope this helps someone else!

Edited by Saint7, 01 December 2010 - 09:16.

Elton "Saint" Craig

"Anyone can do the job when things are going right. In flying we play for keeps!!"

verde13
verde13

    Staff Sergeant

  • Members
  • 206 posts

#12

Posted 01 December 2010 - 12:04

I too have constant CTDs with "Out of memory" error. I never had any problems before 1.55 and 1.56 hasn't fixed it.

Intel E8400
Nvidia GTS 250
Win XP 32 bit