Jump to content

Photo
- - - - -

help! arma 2 wont start


  • Please log in to reply
5 replies to this topic
Thread Starter
james (J)
james (J)

    Lance Corporal

  • Members
  • 47 posts

#1

Posted 15 March 2010 - 22:41

hi

iv just installed arma 2 and as soon as i click the start up icon arma2 stops working and needs to be closed. i tryed updating arma2 with the latest pach but the pach broke too.

can anyone hellp?

i did try serching the fourm for somthing to help but found nothink

my pc specs meet the reqiaments:
Intel® Core™2 CPU 6400 @ 2.13GHz
2.0 GB ram
Vista
GeForce 9600 GT

thank you

james

Bulldogs
Bulldogs

    Warrant Officer

  • Members
  • 2031 posts

#2

Posted 15 March 2010 - 23:25

Try updating all your drivers (video card, motherboard, etc)

Try updating Directx9 (search Microsoft website for it)

Try unplugging any device from your computer that you're not using at the time (joysticks, printers, etc)

If that still doesn't work, try uninstalling, then delete anything left in the installation directory (delete the Arma 2 directory), then goto my documents\Arma 2 and delete everything in that directory. Then copy the contents of your DVD onto a directory on your computer and install the game from there. When you install it, make sure you do it by right clicking the setup file and selecting "run as administrator"
"Once that first bullet goes past your head, Politics and all that {stuff} goes right out the window. Once the 100th bullet go's no where near you, well.... maybe it's time to get some better AI"

Thread Starter
james (J)
james (J)

    Lance Corporal

  • Members
  • 47 posts

#3

Posted 16 March 2010 - 09:35

im a bit of a noob when it comes to computers. i fouund this page on direct x (http://www.microsoft...7D-85FC422D1388)
but i dont know which one to download. i do know that my pc dus not suport directx 10 or 11. Im confused because there are 2 types of direct x 9 on that page.

Placebo
Placebo

    Retired Über Verwalter

  • BI Forum Team
  • 21317 posts
  • LocationVisby, Gotland, Sweden

#4

Posted 16 March 2010 - 09:51

Get this one: http://www.microsoft...57-5ab8109cb4f5 the difference between the two is purely in how the files are downloaded/installed onto your PC. The DirectX End-User Runtime version first downloads a small application, this runs, checks your PC and decides which other files it needs to download, which it then downloads and installs, the DirectX Redist (February 2010) version simply downloads everything in one file then installs what's required.

Fully retired from all forum/community related aspects so please don't contact me unless it's an emergency and nobody else will talk to you :)


JAG_ACE
JAG_ACE

    Rookie

  • Members
  • 7 posts

#5

Posted 18 March 2010 - 05:09

Hi there, Im having a major issue with Arma 2
My machine is windows 7 professional 32 bit
, the game was working but the graphics card i had was a crappy cheap Nvidia that just did not have the power to run it.

I had the patch installed and all the addons i wanted running , all was good exept my graphics card was too weak, so anyway i go out and get a new card a ATI Radeon HD 4600 Series.

I asked them in the store to show me the game running and it was ok. Anyway i get home connect my PC and Arma 2 stopped working, I tried everything from driver updates to reinstalling the card to system restore, so i then uninstall Arma 2 and reinstall.

I try the game before installing the 1.0.5 patch and it works, so im all smiles and then install the 1.0.5 patch, then when the patch finishes with the battle eye install i go to run the game and its back to Arma not working.

The game will load but as soon as it gets to the main menue it crashes back to the desktop. so i uninstall and reinstall and below and behold the game works fine without the patch, but once again after installing the patch the game wont work.

Any suggestions ? becase im about to go kill someone if i cant get arma 2 working properly.

Bulldogs
Bulldogs

    Warrant Officer

  • Members
  • 2031 posts

#6

Posted 18 March 2010 - 13:30

Make sure you have the latest ati driver, and try going to your my documents folder and delete the arma2 folder there. After that, try running the game again.

If that still doesn't worm then try downloading the 1.05 again
"Once that first bullet goes past your head, Politics and all that {stuff} goes right out the window. Once the 100th bullet go's no where near you, well.... maybe it's time to get some better AI"