Jump to content

- - - - -

Bad Serial Error on startup

  • This topic is locked This topic is locked
2 replies to this topic
Thread Starter
Crazy Chris
Crazy Chris

    Private First Class

  • Members
  • 11 posts

  • Joined: 24-June 2009

Posted 27 June 2009 - 15:06 #1

Hello there,
I d/l my full version from Direct2Drive and unzipped everything and ran the .exe and the game starts. However, after the BIS splash screen I get an error that says "Bad Serial Given". I already entered the activation code and that went through fine. I found another post for Steam users, but unfortunately I don't even have an ARMA2 folder in my regedit. :confused:

Any assistance is greatly appreciated.

---------- Post added at 03:06 PM ---------- Previous post was at 03:05 PM ----------

FOrgot to mention I"m running xp



  • Members
  • 6 posts

  • Joined: 02-July 2010

Posted 02 July 2010 - 06:09 #2

I am having the same issue. I know how you are feeling except it was on Arma 2 Operation Arrowhead off of steam. Have you resolved your problem. If so tell me how you solved it.


    Retired Über Verwalter

  • BI Forum Team
  • 21317 posts

  • Joined: 23-July 2001
  • LocationVisby, Gotland, Sweden

Posted 05 July 2010 - 21:29 #3

If it's a missing registry entry then it's covered and resolved in this thread: http://forums.bistud...ad.php?t=101166 if not please explain here how it's different so we can assist?

Fully retired from all forum/community related aspects so please don't contact me unless it's an emergency and nobody else will talk to you :)