Helmut_AUT

Framerate-Friendly Island - porting stuff over?

67 posts in this topic

Hi all

I'm not a modder myself, but from my observation: Arma1 really had a few islands that were easier on the framerate than Sahrani. Sakakah Al Huqf for example, the large Saudi urban map, had pretty much no to very few shader-intense objects on it.

Even in Sahrani, the southern parts of desert were very framerate friendly compared to northern woods.

It would be nice for people with less advanced graphics cards slugging around at 20fps to get a few islands which can easily give 10FPS more, without the need to reduce game or model details too much.

After seeing the AI, Editor, Weapons, MP Savegame improvements/additions in Arma2, no one will go back. It would be great to have an island that turns down graphics load so people with less hefty systems can enjoy the core engine improvements at decent framerates.

Share this post


Link to post
Share on other sites

Just wait for the official editing tools. after the new visitor will be released, there will be much user created island that are "framerate friendly"

Share this post


Link to post
Share on other sites

Hi, thanks for the answer.

From what I read, porting islands over shouldn't actually be that difficult? Maybe we can hope to see some stuff before the tools are released, which might take a bit longer.

Share this post


Link to post
Share on other sites

Porting island is atm difficulty. ArmA2 supports new layers for ground textures (parallaxmapping etc) and arma1 island doesnt support this. and nobody knows if the old wrp files are still supported in arma2.

Share this post


Link to post
Share on other sites

If we can port Sahrani and Rahmadi can't we just as easily port community made A1 Maps like Avgani and others?

Share this post


Link to post
Share on other sites

Link worked for me.

Here I am tooling around Avgani in the A2 Hind. Still a few bits of content to track down and bring across from A1 (as you'll see the first time I go to fire missiles) but basically working. Best thing is with everything on Very High and a 2400 VD I'm getting twice the frame rate (~50, though less with FRAPS running) I used to on this map in A1 with this card (9600GT).

Share this post


Link to post
Share on other sites

Well as a first attempt I just grabbed the 1.14 versions of:

buildings.pbo

buildings.pbo.bi.bisign

ca.pbo

ca.pbo.bi.bisign

cti_buildings.pbo

cti_buildings.pbo.bi.bisign

dbe1.pbo

dbe1.pbo.bi.bisign

desert.pbo

desert.pbo.bi.bisign

desert2.pbo

desert2.pbo.bi.bisign

dir.txt

hotfix.pbo

hotfix.pbo.bi.bisign

hotfix_dbe1.pbo

hotfix_dbe1.pbo.bi.bisign

misc.pbo

misc.pbo.bi.bisign

plants.pbo

plants.pbo.bi.bisign

roads.pbo

roads.pbo.bi.bisign

rocks.pbo

rocks.pbo.bi.bisign

sara.pbo

sara.pbo.bi.bisign

saralite.pbo

saralite.pbo.bi.bisign

signs.pbo

signs.pbo.bi.bisign

water.pbo

water.pbo.bi.bisign

And placed them in an @ARMA\addons\ mod folder. There is a little content still missing but I suspect (I'm just about to try it) the whole of Arma 1's addons folder could come over as I suspect BIS probably built everything in A2 with entirely different class names.

Share this post


Link to post
Share on other sites
I got some error messages about bad materials, and a few missing textures (that were probably in pbos that would break other things) and faulty config, but no more than about 100 messages in the RPT when the island first loaded

That means that A1 content DONT run in A2 perfect! Thats what i say! Layers etc changed in A2 and it would be very hard, to make a A1 wrp file a A2 wrp file without the tools. And the "ported" islands from A1 to A2 (with some errors) has not the quality they can have with the new technics in A2.

Share this post


Link to post
Share on other sites

@Defunkt

:459: it works perfect

when i play avgani map on arma 1 i get 10 fps at max with 700 viewdistance and disabled shadows in the citycenter NOW I HAVE 40 + with EVERYTHING ON HIGHEST 5000 VIEWDISTANCE :yay::yay::yay:

UNBELIEEEEEEEEVABLE

Share this post


Link to post
Share on other sites

Not working perfectly, that collection of files does cause some conflicts. I guess it's a question of de-pbo'ing them and identifying the actual portions required.

Share this post


Link to post
Share on other sites

Thanks for staying on the ball, guys. I've never learned how to mod beyond a few simple texture changes in OFP, but I really appreciate the effort.

When I got A1, I was mostly playing in the desert since my system back then couldn't hack all the trees. Feels the same with A2 now, and some maps with less vegetation will be really needed.

Share this post


Link to post
Share on other sites

@Defunkt

Not working perfectly, that collection of files does cause some conflicts.

dont know what you mean, i had only 2 reports about missing files and avgani and afghan village worked perfect, not a single problem with them, i had no problem to play on that maps at all.

my system : amd x2 6000, ati hd 4870, 2 gig ram

avgani settings in arma2 :1280x1024, 5000 viewdistance, everything on highest except fillrate and disabled bloom and blur with kegetys mod.

citycenter fps 40 +

afghanvillage settings same, fps 50 + .

on both maps i had average fps of 10- 15 fps in arma 1 but with all settings medium and some on low , viewdistance max 700.

so for me this means PERFECT 10 :bounce3:

i tried sahrani , but didnt worked, i tried southsarani and it worked but had lots of missing buildings in paraiso.

ramadi and porto worked aswell.

if you have more than 2 missing files report with your listed pbos you obviously have a problem in ur folders.

i copy and pasted exactly your listed pbos and than i copy and pasted opteryx avgani and afghan village content in same addonfolder and they work perfect.

@Opteryx

i bet you never saw your maps so beautiful as they look in arma 2 with such a high fps rate:D

now someone port iraqi and afghan forces pls ;)

Share this post


Link to post
Share on other sites

Oh my god. I need to redownload those maps, should I just extract the all the pbo's from Avgani and Afghan Village into a ArmA II modfolder or do you need other ArmA 1 files? I mean I already have the ArmA I maps in but now I'm itching to try Afghan Village.

Share this post


Link to post
Share on other sites
@Opteryx

i bet you never saw your maps so beautiful as they look in arma 2 with such a high fps rate

Well to be honest they don't look that great now, mco/multiplier texture, parallax is not working (properly?) and the clutter seems kinda weird, but there is a significant increase in frame-rate for sure. I won't bother doing any porting till the tools are available though.

Share this post


Link to post
Share on other sites
and the clutter seems kinda weird

weird? how weird?

maybe all you need is to adjust the rvmats ;)

Share this post


Link to post
Share on other sites

The thing I noticed is the ground textures are a bit funky when viewed from a distance but I figure that is a small price to pay compared to no-Avgani-until-mod-tools. However somebody would really need to determine exactly which parts of that A1 content are actually required. The messages that I first supposed were to do with missing content also appear when loading A2 maps (with the A1 content loaded as a mod) and as such must be the result of conflicts rather than missing files which (I presume) is the reason I got an error the first time I tried to use the Hind's rockets.

@Opteryx: Is there any sort of listing of referenced content available from your source files?

Share this post


Link to post
Share on other sites

i played yesterday until deep in the morning and i was amazed about both the avgani and afghan village maps and the arma2 ai even on medium skill settings.

i ambushed with a group of ai a russian convoy in avgani from rooftops and after the first 2 hits on their trucks they not only returned fire and supressed us but also some russian ai made it within minutes into our buildings and moved up and killed my ai group entirely, i survived only cause i had a uhey and had landed on another rooftop at start to have a better overview, where no stairs lead up, when i tried to fly away they shot my heli into pieces so i had to make an emergency landing in the middle of avgani, needless to say that they surrounded me and finished me off after a few minutes of endless supressing and flanking maneuvers from them:eek:

Share this post


Link to post
Share on other sites
Well as a first attempt I just grabbed the 1.14 versions of:

buildings.pbo

buildings.pbo.bi.bisign

ca.pbo

ca.pbo.bi.bisign

cti_buildings.pbo

cti_buildings.pbo.bi.bisign

dbe1.pbo

dbe1.pbo.bi.bisign

desert.pbo

desert.pbo.bi.bisign

desert2.pbo

desert2.pbo.bi.bisign

dir.txt

hotfix.pbo

hotfix.pbo.bi.bisign

hotfix_dbe1.pbo

hotfix_dbe1.pbo.bi.bisign

misc.pbo

misc.pbo.bi.bisign

plants.pbo

plants.pbo.bi.bisign

roads.pbo

roads.pbo.bi.bisign

rocks.pbo

rocks.pbo.bi.bisign

sara.pbo

sara.pbo.bi.bisign

saralite.pbo

saralite.pbo.bi.bisign

signs.pbo

signs.pbo.bi.bisign

water.pbo

water.pbo.bi.bisign

And placed them in an @ARMA\addons\ mod folder. There is a little content still missing but I suspect (I'm just about to try it) the whole of Arma 1's addons folder could come over as I suspect BIS probably built everything in A2 with entirely different class names.

Excuse me, but how exactly have you placed what files in what folders?

I have tried the following:

- create a modfolder called @opx with all his files in there plus the files you mentioned from Arma1. Edited the shortcut with -mod=@opx

No luck

- Put the opx folder with all his files plus the files you mentioned into the ArmA 2\Addons folder.

No luck

BTW. I have Arma1 fresh installed only to try Afgani. So after the fresh install I updated Arma1 up to 1.14. But I dont have these files in my Arma1\Addons folder:

dbe1.pbo

dbe1.pbo.bi.bisign

desert2.pbo

desert2.pbo.bi.bisign

dir.txt

hotfix_dbe1.pbo

hotfix_dbe1.pbo.bi.bisign

Does it not work because of the missing files?

When I go to the editor there is no Avgani or Afghan Village

Share this post


Link to post
Share on other sites
- create a modfolder called @opx with all his files in there plus the files you mentioned from Arma1. Edited the shortcut with -mod=@opx

No luck

did u put the files also into a ADDONS folder within your @opx folder?

Arma1\Addons folder:

dbe1.pbo

dbe1.pbo.bi.bisign

desert2.pbo

desert2.pbo.bi.bisign

dir.txt

hotfix_dbe1.pbo

hotfix_dbe1.pbo.bi.bisign

perhaps this is the problem cause this files are from queens gambit addon and u cannot have them by default, so maybe this is the prob why u cant load avgani

Edited by horror1

Share this post


Link to post
Share on other sites
did u put the files also into a ADDONS folder within your @opx folder?

perhaps this is the problem cause this files are from queens gambit addon and u cannot have them by default, so maybe this is the prob why u cant load avgani

Ok, I tried your suggestion with the files into Addons folder, but no luck.

I downloaded Avgani in a package. This package contains the following folders (with the files):

Afghan Village 1.0

Afgani 1.5

opxbuildings

opxmisc

opxplants

opxroads

public key

What I did, was that I put all these folders into one @opx folder with the additional Arma1 files. Or should I make one @Afgani folder with the files from the opxXXX folders and the Arma1?

Edit:

Ok, I tried it with a single @Avgani folder and only the Afgani and opx files in it. Plus an Addon folder with the Arma1 files. But now I can only chose Sahrani and Rhamadi. Still no Avgani.

Edited by dreamweaver

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now