Jump to content

Photo
- - - - -

CTD with an addon.


  • Please log in to reply
3 replies to this topic
Thread Starter
fabiantronc
fabiantronc

    Sergeant

  • Members
  • 127 posts

#1

Posted 25 January 2009 - 23:00

Hello.

I have a Crash to desktop (CTD) when I use an addon created by me.
Well, this is weird, because I tested my addon in the same computer 1 week ago and it works fine, but now I binarized the addon and go to the ArmA editor, I put 1 soldier and my addon and about the half of the loading I get a CTD.

Between the last week and this one, I formated completely the computer, I tried 3 different version of ATI drivers, 2 different version of DirectX 9, I tried binarizing the addon and not and I ask to a friend who has a Nvidia VGA and he say me get the same trouble, a CTD.

Ahh, I'm using ArmA 1.14 + QG. I downloaded BI tools 1.14 from Armaholic.com and armedassault.info, I re-installed it but the same problem.
Every addon than I pack I get a CTD when I tried to use them in the editor.

In the Arma.rpt I get this.
<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">
Exception code: C0000005 ACCESS_VIOLATION at 004544EE
graphics:  D3D9, Device: RADEON X550    , Driver:ati2dvag.dll 6.14.10.6599
resolution:  1024x768x32
[/QUOTE]

Here is the source file and the binarized version.
This is only for test, I made it only for a commander turret test.
Posted Image
www.armedassault.cl

modEmMaik
modEmMaik

    Gunnery Sergeant

  • Members
  • 433 posts

#2

Posted 25 January 2009 - 23:18

Radeons crash, when using a texture that is not 2^x.

The RPT shows a texture 1024x768, which is not acceptable for a Radeon card. Check for a UI-pbo, because such a texture is usually included in a screenshot.

You may alter the resolution of this texture to 1024x1024 or 1024x512 to prevent the Radeon-crash.





Thread Starter
fabiantronc
fabiantronc

    Sergeant

  • Members
  • 127 posts

#3

Posted 25 January 2009 - 23:46

I looked at the UI.pbo and I didn't see a texture with a format 1024x768.

Can you pack it and put on your mod folder and look if it works in your computer ?

If you pack it in the editor will be appear an pop up error but don't pay attention to that.
Posted Image
www.armedassault.cl

modEmMaik
modEmMaik

    Gunnery Sergeant

  • Members
  • 433 posts

#4

Posted 26 January 2009 - 09:04

Sorry, I got confused about the crash report. It only shows the resolution ArmA is running  Posted Image

I have just tried the download. No crash in the buldozer, athough one section seems a bit odd in the skeletons:
<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">
"OtocHlavenVelitele","OtocVelitele",
"",
"damageVez","OtocVez",[/QUOTE]

I think it should be:
<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">
"OtocHlavenVelitele","OtocVelitele",
"damageVez","OtocVez"[/QUOTE]
The binarization process shows no error...

But the game crashes, nevertheless.  Posted Image

:edit: I have removed the weapons / magazines and used an alternative definition for the tank. The crash is gone. Config.cpp and  model.cfg uploaded to pastebin

Seems that something in your config causes the crash.