spirit

Unknow mask problems

29 posts in this topic

Hey guys,

I was close to finish my artic map and then i run in problems beyond my understanding. So i hope to find some support here.

I have a 20 x 20 km artic map. The sat map was generated using L3DT. So a 20480x20480 texture. I also have a small project to test things at 2048 x 2048.

My height map went perfect, my texture loaded great. I used a mask that was all yellow to test teh texture without bothering the mask.

Now i finished the mask but as soon as bulldozer has made all the files and its about to start it crashes. When i use my my all yellow mask it goes fine. There is only 3 colors (attributes in the mask file). its a 24 bit png file 20480x20480. There is no problem with the textures as all works fine with a full yellow map. I cant reproduce the problem in the small project. I rescaled the 20480x20480 and loaded it in the small scale project 2048x2048. It all works fine.

Since i cant ask you guys to take a look at my files (way to big) i am looking for any cause that can make bulldozer crash on maks files.

So in what cases can it all crash that you guys ran into. It might set me back on track.Maybe a maximum total size (sat + mask), maybe even the weather outside. I am getting out of idea's. I realy am out of idea's after 7 days figuring out and testing all things that came in mind.

Thanks in advance banghead.gif

Just to add: I already made an island myself and never ran into this kind of problems(although a zillion of other problems). Althought that was a test by 10 by 10 km just to see if i could figure it all out. I thought i had seen all probs but no tounge2.gif

Share this post


Link to post
Share on other sites

My layers file:

class Layers

{

class sneeuw

{

texture = "watkins\data\sneeuw_mco.paa";

material="watkins\data\sneeuw.rvmat";

};

class rots

{

texture = "watkins\data\rots_mco.paa";

material="watkins\data\rots.rvmat";

};

class rots2

{

texture = "watkins\data\rots2_mco.paa";

material="watkins\data\rots2.rvmat";

};

};

class Legend

{

picture="watkins\source\mapLegend.png";

class Colors

{

/// color names should correspond to surface layer names

sneeuw[]={{255,0,0}};

rots2[]={{0,255,0}};

rots[]={{0,0,255}};

};

};

Share this post


Link to post
Share on other sites

It crashes after extruding hills and valleys. Preparing the textures finishes but takes a while. Did i go over the edge of what visitor allows? What annoys me is that a complete one color mask does work. Clueless i am left behind here help.gif

Yes the class legend png should not be in source dir i know. But makes no difference for this prob crazy_o.gif

Share this post


Link to post
Share on other sites
Did i go over the edge of what visitor allows?

Yes the class legend png should not be in source dir i know. But makes no difference for this prob crazy_o.gif

I believe it can be done, and the problem might be in a single link or direction path for a texture file or some Visitor configuration.

About the 24 bit png, you have to be 100% sure about that.

- I advise you to change the 'rots' name of your colors, use instead rotso1 and rots2 because you might have other problems in the future.

- Try to use the original path for the legend.png, but it might not be that.

- Check your paths in Visitor3.

post pics if you need. Sometimes they say more them 1000 words.

Share this post


Link to post
Share on other sites

Use a 8bit mask instead of the 24bit. I use on my Islands only 8bit mask files without any problem. BIS has done the same on the samplemap.

\Sgt.Ace

Share this post


Link to post
Share on other sites

It's supposed to be 8-bit.

-edit-

Bravo6

I suggest you correct your statements saying it's supposed to be 24-bit. This is simply not true and have misled a few beginners.

Share this post


Link to post
Share on other sites

some programs don't have 24bit option such as PS CS3 so you must use 8bit option like Sgt.Ace and Opteryx said.

I say that because some programs have both options, 8bit and 24bit, if you use 8bit while existing 24bit you might have some problems like i had.

so to clarify:

http://en.wikipedia.org/wiki/8-bit_color

Share this post


Link to post
Share on other sites

Thanks for the reply guys. About naming and other stuff. Sure it can be more handy but no need to do that until i have this active. Remember i can do a 1 color mask perfectly and it doesnt crash.

8 bit / 24 bit. It confused me also. In the small scale i use a 24 bit. In the big one also.

anyway before i get the 8 x 3 = 24 talk that i saw earlier. Just to be sure.

When i in windows xp right click the file it says 24 bits. Now is that a 24 bits or not? In my opinion it is.

question 2: How do i change it to 8 bit?

Question 3: why does the 24 bit work perfecty in the small scale map and not the big one?

question 4: Is there a maximum for the layers total file size. The layers dir including paa and png is in total 1.1 gig and 12k files. Is that problematic? I dont think so because a full one color mask gives no probs.

question 5 i checked on anit-aliasing. All colors are pure 255 variations exactly as described in the layers file. Any more i can try?

Share this post


Link to post
Share on other sites
question 2: How do i change it to 8 bit?

what program are you using?

Bravo6

I suggest you correct your statements saying it's supposed to be 24-bit. This is simply not true and have misled a few beginners.

I have reasons not to change what i said before.

For some programs this 'rule' must be broken like i said in above post.

Share this post


Link to post
Share on other sites

Hey mate,

Well i use Gimp, Photoshop, Paint. What ever does the job. However i realy need answer on how i can check that 8 bit version. The previous 8 bit, 24 bit 8x3 channels =24 bit got me totaly confused on how i now what a 8 bit is.

About program. dont matter, i have a pc, a mac and 2 OS on my pc. Can do anything, just need to know what it is:)

Share this post


Link to post
Share on other sites

Photoshop CS3 = 8bit because there no 24bit option

Fireworks MX = 24bit (else you will have problem)

you can test your self these options and get into a conclusion.

Share this post


Link to post
Share on other sites
Photoshop CS3 = 8bit  because there no 24bit option

Fireworks MX = 24bit (else you will have problem)

you can test your self these options and get into a conclusion.

Allright i go check if this can sort the problem. I did all but changing to other stuff. I though 24 bit was the way to go.

Anyway, i update if it solves things. Sure hope so, been quite some time busy on this project. Figuring a lot of stuff out.

Update to follow after work biggrin_o.gif

Share this post


Link to post
Share on other sites

Whops, you are correct, there is no way to export 24-bit rgb from PS, but I'm positive that I have had troubles with a higher bit-depth than 8 on sat/mask textures in V3.

At any rate, you'll save disk space with using a lower bit-depth.

Share this post


Link to post
Share on other sites
Whops, you are correct, there is no way to export 24-bit rgb from PS, but I'm positive that I have had troubles with a higher bit-depth than 8 on sat/mask textures in V3.

At any rate, you'll save disk space with using a lower bit-depth.

yes, with 32bit you have problems, not with 24bit.

Share this post


Link to post
Share on other sites
Whops, you are correct, there is no way to export 24-bit rgb from PS, but I'm positive that I have had troubles with a higher bit-depth than 8 on sat/mask textures in V3.

At any rate, you'll save disk space with using a lower bit-depth.

yes, with 32bit you have problems, not with 24bit.

Hmmm alright if 24 dont matter then i wonder why do it. Anyway i gues i need to learn more about that file names because i have no clue how to safe to 8 bit.

but any try is worth it since i already spend 7 days on this mask. crazy_o.gif all other stuff went perfect, it looks very very good but just that stupid mask...

Share this post


Link to post
Share on other sites

Hey people,

Well i changed a tile from the total mask by going :

image->mode->indexed->256

Then i safe it as png. The file itself now becomes smaller, however when i right-click the file and ask the summery it says 32 bit while the old version is larger but says 24 bits in the summery. This gets me confused.

Can ya help me out here?

Share this post


Link to post
Share on other sites

Allright i chanded the whole map by using Gimp. Image_> mode-> indexed->256

Result: Summery of file now says 32 bits instead of 24.

Visistor wont even load the mask file now. Before this it made all files perfectly, loaded the textures and crashes after it.

Clueless. The file itself is not big, i am more then happy to send it somebody that realy knows what he is doing because i did every step you could possible think of. Somebody? whistle.gif The mask is not that big file btw.

Ace tx for your offer mate. Link to file has been send.

Share this post


Link to post
Share on other sites

read what i wrote.

Not 32! With 32 it crashes and file is huge.

Try with 8bit, and if you dont have that option use 24 in resource.

Find the option in your program somewhere.. investigate smile_o.gif

Share this post


Link to post
Share on other sites
read what i wrote.

Not 32! With 32 it crashes and file is huge.

Try with 8bit, and if you dont have that option use 24 in resource.

Find the option in your program somewhere.. investigate smile_o.gif

Mate i know what you wrote. I just tell you the results i get when done as said above. I have been goofing around 7 days with this file and clicked any option available. I made 5 masks so far on the previous map and i havent had any problem. That is why i am out of idea's. 32 bit i know, its about results i publish with the suggested actions.

Share this post


Link to post
Share on other sites
8bitrgbgr6.jpg

mmm well my original mask is already in 8 bits a channel RGB. Just checked it with photoshop. Crap i go over everything one more time just to double double double check biggrin_o.gif

Post a tile of my mask.png. Its a small tile before it is placed together. Its the same file settings. See anything strange?

http://img513.imageshack.us/img513....MG]

Share this post


Link to post
Share on other sites
have you noticed its pixel size?

I dont know what ya mean with that mate? Its 72 dpi file. What you are looking at is a very small part from the whole mask. If you see something fishy then please explain, i go straight at it. I want to tackle this baby smile_o.gif

Share this post


Link to post
Share on other sites

if the mask has the same size as the sat_lco.png it shouldn't be a problem.

Why don't you post your visitor configurations, maybe you missed something in visitor.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now