Jump to content

Photo
- - - - -

problem with alpha texture


  • Please log in to reply
12 replies to this topic
Thread Starter
-FF-Faust
-FF-Faust

    Corporal

  • Members
  • 97 posts

Posted 27 May 2008 - 17:05 #1

Hi all, i have problem with texture of light bar on my police version of car.
On places where alpha = 1 i can see through this texture in some angles. (as you can see in my nice picture)

I tried to fix it
- in Oxygen by sort alpha, move to next alpha, move top,....
- i use *.paa and *.pac
- but nothing helped

where can be problem?
thx for replies

Posted Image




Posted Image

scubaman3D
scubaman3D

    Master Sergeant

  • Members
  • 788 posts

Posted 27 May 2008 - 18:31 #2

I think you have to use the _ca.paa or _co.paa designation. That will get rid of the translucent faces.

Thread Starter
-FF-Faust
-FF-Faust

    Corporal

  • Members
  • 97 posts

Posted 27 May 2008 - 19:02 #3

I think you have to use the _ca.paa or _co.paa designation. That will get rid of the translucent faces.

yea, i use "majak_ca.paa"

...any other ideas?




Posted Image

Linker Split
Linker Split

    First Sergeant

  • Members
  • 901 posts

Posted 27 May 2008 - 23:03 #4

you also have to assign a RVMAT to the texture.

Thread Starter
-FF-Faust
-FF-Faust

    Corporal

  • Members
  • 97 posts

Posted 29 May 2008 - 08:44 #5

[quote name='(Linker Split @ May 28 2008,01:03)']you also have to assign a RVMAT to the texture.[/QUOTE]
i tried it but it didnt help, maybe wrong RVMAT?

can u post here code of any RVMAT which will fix it pls?

I used this RVMAT

<table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">
ambient[] = {1, 1, 1, 1};
diffuse[] = {1, 1, 1, 1};
forcedDiffuse[] = {0, 0, 0, 0};
emmisive[] = {0, 0, 0, 1};
specular[] = {1, 1, 1, 0};
specularPower = 20;
PixelShaderID = "NormalMapSpecularDIMap";
VertexShaderID = "NormalMap";
class Stage1
{
texture = "FFS_Felicia\tex\plech_nohq.paa";
uvSource = "tex";

class uvTransform
{
aside[] = {1.000000, 0.000000, 0.000000};
up[] = {0.000000, 1.000000, 0.000000};
dir[] = {0.000000, 0.000000, 0.000000};
pos[] = {0.000000, 0.000000, 0.000000};
};
};
class Stage2
{
texture = "FFS_Felicia\tex\plech_smdi.paa";
uvSource = "tex";

class uvTransform
{
aside[] = {1.000000, 0.000000, 0.000000};
up[] = {0.000000, 1.000000, 0.000000};
dir[] = {0.000000, 0.000000, 0.000000};
pos[] = {0.000000, 0.000000, 0.000000};
};
};
[/QUOTE]




Posted Image

Max Power
Max Power

    Mr. Angry Face

  • Members
  • 12828 posts

Posted 29 May 2008 - 22:19 #6

This is a shot in the dark but try turning off the alpha lighting for your diffuse, specular, and emissive properties. I am not too clear on what they do, and I'm not sure if that's the problem, but it's something to look at.

The entries are in the form as follows:

lighting component = {R, G, B, A}

So try setting all of the last numbers in those entries to 0.
Posted Image
Posted Image
My inbox is fill and won't be emptied. If your PM is regarding requests to use my work, unfortunately I choose not to grant such permission. My work is for use with CWR2 only.

Linker Split
Linker Split

    First Sergeant

  • Members
  • 901 posts

Posted 30 May 2008 - 22:26 #7

try these PS and VS:

PixelShaderID = "NormalMapSpecularThrough";
VertexShaderID = "NormalMapSpecularThroughNoFade";

Thread Starter
-FF-Faust
-FF-Faust

    Corporal

  • Members
  • 97 posts

Posted 01 June 2008 - 16:53 #8

@Linker Split
When i used this <table border="0" align="center" width="95%" cellpadding="0" cellspacing="0"><tr><td>Code Sample </td></tr><tr><td id="CODE">PixelShaderID = "NormalMapSpecularThrough";
VertexShaderID = "NormalMapSpecularThroughNoFade";[/QUOTE]
i dont see througt my texture. that will be ok but i dont see througt places where is alpha channal.

So, this PS and VS disable my alpha channal?!?!
Posted Image

Scars09
Scars09

    Gunnery Sergeant

  • Members
  • 479 posts

Posted 01 June 2008 - 17:46 #9

can you please provide the texture, i would like to see if i have the same effect. i know these effects only in relation with rvmat┬┤s. for example the chrome_enviro.rvmat shows transparency related to point of view, i think there are others aswell. if nothing helps, split the texture.
sic semper tyrannis
Posted Image

Thread Starter
-FF-Faust
-FF-Faust

    Corporal

  • Members
  • 97 posts

Posted 02 June 2008 - 14:19 #10

@Scars09
Here is link for my texture:
http://www.ffstudio....OL_majak_ca.paa

Quote[/b] ]split the texture

Ofcourse this is solution but i want know where is problem.
Posted Image

Linker Split
Linker Split

    First Sergeant

  • Members
  • 901 posts

Posted 02 June 2008 - 23:52 #11

the texture you provided us is not the same as in the image you posted:

Posted Image

Thread Starter
-FF-Faust
-FF-Faust

    Corporal

  • Members
  • 97 posts

Posted 03 June 2008 - 19:49 #12

the texture you provided us is not the same as in the image you posted:

it doesnt matter , problem is same with this texture
Posted Image

Scars09
Scars09

    Gunnery Sergeant

  • Members
  • 479 posts

Posted 05 June 2008 - 17:04 #13

EDIT: i dont know why, but now i have the effect again without changing anything. the solution i wrote below is not working.
i will try few other things.


Quote[/b] ]
i can confirm the problem, the colour grey seems to have some impact on this. to get rid of it use material
Ca\data\data\default_2pass.rvmat
fixed your texture on my machine and should do it on yours aswell.
regards





sic semper tyrannis
Posted Image