icfhoop

Roads, Very Confused

18 posts in this topic

Hello all, I am a little lost right at the moment. I've searched the forums and checked the tutorials, but I couldnt find anything. What it is, is that I know you are supposed to for roads place them by going to Tools-Roads- and all that good stuff. But when I go to place a road on my map, all it appears as, is a dotted line that I cant move nor select once it has been deselected. Is there something I missed, or what?

Thanks

Share this post


Link to post
Share on other sites

Check the Biki/Visitorial3 Tutorial/roads.... that explains all you need

Share this post


Link to post
Share on other sites

Hey, I checked the biki, but it still doesnt work. Everytime I place a road, it is transparent, dotted line around it, and I can not select or move or anything, Any othere ideas?

Share this post


Link to post
Share on other sites

you havent read the biki, otherise you wouldnt ask here again.....this transparent part is the keypart of a road. One can add the other parts by using the roadplacing system....the way how to adjust and use this system, can be found in the biki.....

Share this post


Link to post
Share on other sites

Ok I still am confused but I cant dind it so yea... so do you have to use this system or can u just place roads like objects ?

Share this post


Link to post
Share on other sites

Yes...once you have adjusted aa kind of road, and added all your parts, so you only need to select the Position (A or B) aand then you can go on placing the road by woring with the next window.....

Share this post


Link to post
Share on other sites

I'm so confused, how do I even set up a road, I have looked on the biki, that didnt help me, I looked at tutorials, but im a little lost, so could you please xplaing? Thanks for your time

Share this post


Link to post
Share on other sites

Listen...I have read that section of the biki atleast 50 times literally.  Still I dont get it.  Every thime I place a road all I get is a dotted line and I cant move nor even select it.... please help me. huh.gif

Share this post


Link to post
Share on other sites

Care to post the solution? I'm sure others might find problems too... sometimes even the simplest things can confuse. I've found myself hunting for solutions till I am blue in the face... only to find I made a very basic mistake smile_o.gif

Share this post


Link to post
Share on other sites

Im really very very confused about Roads.. concern in AI behaviour.

Not how to build them in Road Network, but to make them work for AI's..

Just to add: I tried "again" BIS SampleMap, opened in visitor and exported to game just to see how AI behave on roads.

I must say i had some problem with textures.. maybe because i didn't change the .rvmat .png to .paa in first try. (not sure if textures are important for AI behavior on roads, i doubt)

I set 1 vehicle and some waypoints to test.. AI's WOULD NOT FOLLOW the road as they should! They stop and go in S's..

I also Copied the SampleMap.pbo from BIS and tried the Roads, AI's followed the roads normally.

Now this fact gives a big confusion to my head and a big question.. WHY?! Whats wrong with Visitor3?!

Is it Just Me?!

Suicide is the next step. biggrin_o.gif

edit: maybe i should add that these two map i tested SampleMap and MyMap have 256x256 and 512x512 respectively, texture layers = 40.0x40.0m

edit2: tried the SampleMap.pbo from BIS, works fine.

Share this post


Link to post
Share on other sites

Are there any road tiles or networks that are overlapping eachother? I've heard that coplanar roadway LODs will cancel each other out.

Perhaps this is the issue?

Share this post


Link to post
Share on other sites

oh.. i just sent an mp before i read your post.. confused_o.gif

you mean like this?

BayukRoad.jpg

edit: But in other hand BIS SAmpleMap use it..

BISampleMap_s.gif

1024x768

EDIT2: PROBLEM SOLVED: I would like to say that the problem I mentioned on my previous post (AI behaviour and Roads) is Cleared and Solved.

I Found the problem why AI's wouldn't follow the road normally.

Roads can be overlapping, theres no problem about it, when creating the roads they MUST be "Terminated" with option "Terminator" in visitor3 - road network. Ie, if you Generate terminator and then use other option then "terminator of" it will not work for AI's. This option must be selected when you finish a part of a road.

The possible issue that might confuse people is the fact that some roads, such as the \ca\roads\ces_d12 do Not appear on the map when the terminators are created, but if you check Buldozer they are there.

Hope this helps some people.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now