Jump to content

Photo
- - - - -

Roads, Very Confused


  • Please log in to reply
17 replies to this topic
Thread Starter
icfhoop
icfhoop

    Staff Sergeant

  • Members
  • 279 posts

#1

Posted 10 May 2008 - 01:43

Hello all, I am a little lost right at the moment. I've searched the forums and checked the tutorials, but I couldnt find anything. What it is, is that I know you are supposed to for roads place them by going to Tools-Roads- and all that good stuff. But when I go to place a road on my map, all it appears as, is a dotted line that I cant move nor select once it has been deselected. Is there something I missed, or what?

Thanks
-Being stupid is a talent, you don't grow up saying that you want to be stupid. Your born with the natural talent of it, so use it. :yay:
Posted Image

memphisbelle
memphisbelle

    Master Sergeant

  • Members
  • 661 posts

#2

Posted 10 May 2008 - 11:38

Check the Biki/Visitorial3 Tutorial/roads.... that explains all you need
Posted Image Posted Image
Posted Image
Posted Image ArmA Editing Guide Deluxe Edition - English Version Download
Posted Image ArmA Editing Guide Deluxe Edition - German Version Download
try my Weaponbox signs Addon
My System
ArmA3 Bugtracker

Thread Starter
icfhoop
icfhoop

    Staff Sergeant

  • Members
  • 279 posts

#3

Posted 10 May 2008 - 14:38

Ok thanks Ill check it out.
-Being stupid is a talent, you don't grow up saying that you want to be stupid. Your born with the natural talent of it, so use it. :yay:
Posted Image

Thread Starter
icfhoop
icfhoop

    Staff Sergeant

  • Members
  • 279 posts

#4

Posted 10 May 2008 - 14:50

Hey, I checked the biki, but it still doesnt work. Everytime I place a road, it is transparent, dotted line around it, and I can not select or move or anything, Any othere ideas?
-Being stupid is a talent, you don't grow up saying that you want to be stupid. Your born with the natural talent of it, so use it. :yay:
Posted Image

memphisbelle
memphisbelle

    Master Sergeant

  • Members
  • 661 posts

#5

Posted 10 May 2008 - 20:09

you havent read the biki, otherise you wouldnt ask here again.....this transparent part is the keypart of a road. One can add the other parts by using the roadplacing system....the way how to adjust and use this system, can be found in the biki.....
Posted Image Posted Image
Posted Image
Posted Image ArmA Editing Guide Deluxe Edition - English Version Download
Posted Image ArmA Editing Guide Deluxe Edition - German Version Download
try my Weaponbox signs Addon
My System
ArmA3 Bugtracker

Thread Starter
icfhoop
icfhoop

    Staff Sergeant

  • Members
  • 279 posts

#6

Posted 10 May 2008 - 23:07

Ok I still am confused but I cant dind it so yea... so do you have to use this system or can u just place roads like objects ?
-Being stupid is a talent, you don't grow up saying that you want to be stupid. Your born with the natural talent of it, so use it. :yay:
Posted Image

memphisbelle
memphisbelle

    Master Sergeant

  • Members
  • 661 posts

#7

Posted 11 May 2008 - 01:06

Yes...once you have adjusted aa kind of road, and added all your parts, so you only need to select the Position (A or B) aand then you can go on placing the road by woring with the next window.....
Posted Image Posted Image
Posted Image
Posted Image ArmA Editing Guide Deluxe Edition - English Version Download
Posted Image ArmA Editing Guide Deluxe Edition - German Version Download
try my Weaponbox signs Addon
My System
ArmA3 Bugtracker

Thread Starter
icfhoop
icfhoop

    Staff Sergeant

  • Members
  • 279 posts

#8

Posted 11 May 2008 - 01:33

I'm so confused, how do I even set up a road, I have looked on the biki, that didnt help me, I looked at tutorials, but im a little lost, so could you please xplaing? Thanks for your time
-Being stupid is a talent, you don't grow up saying that you want to be stupid. Your born with the natural talent of it, so use it. :yay:
Posted Image

memphisbelle
memphisbelle

    Master Sergeant

  • Members
  • 661 posts

#9

Posted 11 May 2008 - 09:25

listen.....I havent had any idea how to use this tools as well...but the biki told my everything I needed.

http://community.bis...wiki....5BF4.5D

of course you need to use our brain a little......
Posted Image Posted Image
Posted Image
Posted Image ArmA Editing Guide Deluxe Edition - English Version Download
Posted Image ArmA Editing Guide Deluxe Edition - German Version Download
try my Weaponbox signs Addon
My System
ArmA3 Bugtracker

Thread Starter
icfhoop
icfhoop

    Staff Sergeant

  • Members
  • 279 posts

#10

Posted 11 May 2008 - 14:38

Listen...I have read that section of the biki atleast 50 times literally.  Still I dont get it.  Every thime I place a road all I get is a dotted line and I cant move nor even select it.... please help me. Posted Image




-Being stupid is a talent, you don't grow up saying that you want to be stupid. Your born with the natural talent of it, so use it. :yay:
Posted Image

Nicholas Bell
Nicholas Bell

    Staff Sergeant

  • Members
  • 395 posts

#11

Posted 12 May 2008 - 12:51

I recall that when I started had the problem with just seeing the dotted lines for roads. Check out this thread - maybe it will help: http://www.flashpoin...-bin....ll;st=0

-IC-Wedge
-IC-Wedge

    Corporal

  • Members
  • 62 posts

#12

Posted 13 May 2008 - 09:54

I also had a road problem ....not sure if its what you a are talking about but here ya goes anyway

This is how i fixed it





Thread Starter
icfhoop
icfhoop

    Staff Sergeant

  • Members
  • 279 posts

#13

Posted 13 May 2008 - 23:40

Ahh I got it fixed nevermind lol.
-Being stupid is a talent, you don't grow up saying that you want to be stupid. Your born with the natural talent of it, so use it. :yay:
Posted Image

rocket
rocket

    BI Developer

  • 648 posts

#14

Posted 14 May 2008 - 01:49

Care to post the solution? I'm sure others might find problems too... sometimes even the simplest things can confuse. I've found myself hunting for solutions till I am blue in the face... only to find I made a very basic mistake Posted Image
"He will come to death. An image of the splendor of the kings of men in glory, undimmed before the breaking of the world."

Thread Starter
icfhoop
icfhoop

    Staff Sergeant

  • Members
  • 279 posts

#15

Posted 14 May 2008 - 23:48

The show roads button on the top of the screen lol
-Being stupid is a talent, you don't grow up saying that you want to be stupid. Your born with the natural talent of it, so use it. :yay:
Posted Image

bravo 6
bravo 6

    ArmAIII/OFP Fan

  • Members
  • 4499 posts

#16

Posted 16 May 2008 - 09:22

Im really very very confused about Roads.. concern in AI behaviour.

Not how to build them in Road Network, but to make them work for AI's..

Just to add: I tried "again" BIS SampleMap, opened in visitor and exported to game just to see how AI behave on roads.
I must say i had some problem with textures.. maybe because i didn't change the .rvmat .png to .paa in first try. (not sure if textures are important for AI behavior on roads, i doubt)

I set 1 vehicle and some waypoints to test.. AI's WOULD NOT FOLLOW the road as they should! They stop and go in S's..

I also Copied the SampleMap.pbo from BIS and tried the Roads, AI's followed the roads normally.



Now this fact gives a big confusion to my head and a big question.. WHY?! Whats wrong with Visitor3?!

Is it Just Me?!



Suicide is the next step. Posted Image



edit: maybe i should add that these two map i tested SampleMap and MyMap have 256x256 and 512x512 respectively, texture layers = 40.0x40.0m

edit2: tried the SampleMap.pbo from BIS, works fine.





Opteryx
Opteryx

    Maniraptor

  • Members
  • 1724 posts

#17

Posted 16 May 2008 - 10:10

Are there any road tiles or networks that are overlapping eachother? I've heard that coplanar roadway LODs will cancel each other out.

Perhaps this is the issue?

bravo 6
bravo 6

    ArmAIII/OFP Fan

  • Members
  • 4499 posts

#18

Posted 16 May 2008 - 10:26

oh.. i just sent an mp before i read your post.. Posted Image

you mean like this?

Posted Image


edit: But in other hand BIS SAmpleMap use it..

Posted Image
1024x768



EDIT2: PROBLEM SOLVED: I would like to say that the problem I mentioned on my previous post (AI behaviour and Roads) is Cleared and Solved.
I Found the problem why AI's wouldn't follow the road normally.

Roads can be overlapping, theres no problem about it, when creating the roads they MUST be "Terminated" with option "Terminator" in visitor3 - road network. Ie, if you Generate terminator and then use other option then "terminator of" it will not work for AI's. This option must be selected when you finish a part of a road.

The possible issue that might confuse people is the fact that some roads, such as the \ca\roads\ces_d12 do Not appear on the map when the terminators are created, but if you check Buldozer they are there.

Hope this helps some people.