Vasily.B

EDEN Editor BUGS

178 posts in this topic

1. Seems like placing multiple waypoints doesn't work anymore with CTRL on dev Solved in EXE rev. 135137

2. Expressions of preference attributes are not loaded when the editor is opened

Share this post


Link to post
Share on other sites

After today's dev update the following problem has appeared on 3den:

- Open editor

- insert some entity

- open debug window and type some systemChat message -> execute

- close debug window

- observe your systemchat shown

- now save the mission

- open debug window and type some systemChat message -> execute

close debug window

- observe how nothing is shown..

 

The following is in the rpt:

- Performance warning: SimpleSerialization::Write 'params' is using type of ',CONTROL' which is not optimized by simple serialization, falling back to generic serialization, use generic type or ask for optimizations for these types

- Serialization of Control variables is not implemented

 

Those two lines appear each time you excecute what ever you have written in the debug console.

 

Does this happen to anyone else or have I seriously broken something? :P

Game cache validates OK though, running no mods of any kind..

Share this post


Link to post
Share on other sites

Ok, so not me wreaking havoc here then :P

 

Really annoying bug though..

Share this post


Link to post
Share on other sites

Hi there!

 

For some reason the editor has stopped me playing my scenarios ..

every time i go to play as a character or just hit play in single player it loads then goes back to the editor.

any ideas?

Share this post


Link to post
Share on other sites

It would be nice if the CfgMusic/Sound/SFX/Voice/Environment were sorted alphabetically. I have tons of music/sounds in there and finding the right one is a pay in the arse, and yes I know one can jump directly to certain initials but that doesn't really work if the list is not sorted and in fact, it only works oncee, so one can't jump through all songs beginning with the letter "M" by pressing the "M" key repeatedly

 

Not a major issue, but certainly something that would improve usabilty in the future.

Share this post


Link to post
Share on other sites

Sound lists will be sorted alphabetically in the next dev build update. Thanks for info ;)

The debug console issue is now being investigated.

Share this post


Link to post
Share on other sites

Ok, so not me wreaking havoc here then :P

 

Really annoying bug though..

 

The debug console issue is now being investigated.

 

The fix is on the way  :wacko:

Share this post


Link to post
Share on other sites

The Role Description attribute is showing for empty vehicles, which has no effect I believe in that case.

Share this post


Link to post
Share on other sites

Is there any chance of fixing DontCreateAi aprameter in EDEN in 1.58? Its very problematic... RHS APC' and IFV's are without gunners.....

Share this post


Link to post
Share on other sites

Hey Guys. I have made a Training map using the Eden editor. At some point, when I try to play my map in Singleplayer or Multiplayer, I get this weird "top down view" of my character way up in the air. I cannot move, or do anything. I don't know what do to. It's the mission, not the intro or outro. I will post screen shots of this.

 

http://steamcommunity.com/sharedfiles/filedetails/?id=658384953 

 

Share this post


Link to post
Share on other sites

 

Hey Guys. I have made a Training map using the Eden editor. At some point, when I try to play my map in Singleplayer or Multiplayer, I get this weird "top down view" of my character way up in the air. I cannot move, or do anything. I don't know what do to. It's the mission, not the intro or outro. I will post screen shots of this.

 

http://steamcommunity.com/sharedfiles/filedetails/?id=658384953 

 

 

 

Make sure you have placed a player character.

Share this post


Link to post
Share on other sites

I found a bug with the EditXYZ control. When used in a custom attribute it's causing the following script error when opening the attribute:

15:18:56 Error in expression <sGroupCtrl 101) ctrlSetText str (_value select 0);        (_this controlsGroupCtrl 102>
15:18:56   Error position: <select 0);        (_this controlsGroupCtrl 102>
15:18:56   Error select: Type Bool, expected Array,String,Config entry

I've removed all other attributes to make sure it's caused by EditXYZ

 

The attribute looks like this:

class TestAtt
{
   displayName = $STR_establishingShot_headline;
   collapsed = 1;

   class Attributes
   {
      class CenterPos
      {
         displayName = $STR_establishingShot_centerPos_displayName;
         tooltip = $STR_establishingShot_centerPos_displayName;
         property = "Enh_centerPosition";
         control = "EditXYZ";
         expression = "missionNamespace setVariable ['Enh_centerPosition',_value]";
      };
   };
};

Nevermind, I forgot to set a default value (array)  :face_palm:

Share this post


Link to post
Share on other sites

Make sure you have placed a player character.

Yes. I did that. But after a while, with a character selected as a player, it will still do that regardless. It has done this to every mission I have made. It is so fustrating

Share this post


Link to post
Share on other sites

Theirs A Bug Were if you Run a mission on ded server of theirs a marker with a name like this spawn_1_1 it says Error Mission Loading Error this needs to be fixed sense altis life runs a lot of markers like this

Share this post


Link to post
Share on other sites

Theirs A Bug Were if you Run a mission on ded server of theirs a marker with a name like this spawn_1_1 it says Error Mission Loading Error this needs to be fixed sense altis life runs a lot of markers like this

 

You probably mean that when one copies over markers with a name mrk_1 it adds a _1 (mrk_1_1). That is fixed already so far I know

1 person likes this

Share this post


Link to post
Share on other sites

Since it is possible to kill the player entity while in 3DEN you might wanna consider disabling the 'death screen' there.

The 3D world goes all blurry until you delete the dead player entity. Might be a bit confusing to someone who might not know what's going on.. :shrug:

 

Pretty sure it's not going to happen that often, just thought I mention it.

Share this post


Link to post
Share on other sites

Am I the only one who has difficulty placing down waypoints using SHIFT+Click? Clicks are not always registered.

Also I can't see any markers in 3D view when using F6, Markers. Makes syncing to random spawns a bit difficult to guess on the map.

 

Lastly I've not been able to find any way to select a group and all its waypoints? CTRL+Click on the group used to work in the 2D Editor.

 

I'm on version 1.59.135439 but still having the above issues.

Share this post


Link to post
Share on other sites

I'm having a problem with creating missions.  I'm using ACE mod and CBA.  When using the new Eden editor whenever I create a MP mission, we lose the game anytime anyone dies.  I have under attributes>multiplayer that revive is set to spectator.  I have tested it without pluggin in mods, and it seems to work fine, but once I put in the mod settings is when I have the issue.  This is what I have set up, I am not running any scripts, and I never had this problem before Eden:

 

ACE NAME Tags: Force Hid All

 

ACE Medical:Advanced, with prevent instant death on

 

ACE ADV Medical: Paks and surgical kits are on

 

MCC GIA settings, and MCC menu settings are also turned on

Share this post


Link to post
Share on other sites

 

Hey Guys. I have made a Training map using the Eden editor. At some point, when I try to play my map in Singleplayer or Multiplayer, I get this weird "top down view" of my character way up in the air. I cannot move, or do anything. I don't know what do to. It's the mission, not the intro or outro. I will post screen shots of this.

 

http://steamcommunity.com/sharedfiles/filedetails/?id=658384953 

 

 

 

I believe the above is part of a larger issue with the 2D to 3dD conversion process. In addition to this error (resulting in the death screen map top down view even with a player placed on the map) many scripts become non-functioning as well, most addActions are absent.

Share this post


Link to post
Share on other sites

Have you disabled the simulation? Can be found in the category "Special States"

Share this post


Link to post
Share on other sites

Have you disabled the simulation? Can be found in the category "Special States"

 

Thanks. I guess it's better, even there is no effect on grenades etc anymore.

Share this post


Link to post
Share on other sites

I believe the above is part of a larger issue with the 2D to 3dD conversion process. In addition to this error (resulting in the death screen map top down view even with a player placed on the map) many scripts become non-functioning as well, most addActions are absent.

 

Ok, so it is not what i did then? Will this issue be fixed?

Share this post


Link to post
Share on other sites

Have you disabled the simulation? Can be found in the category "Special States"

That is however not a fix for this problem, as jonilahtinen said they don't simulate anymore.

Kinda silly as this is basically a main selling point of a 3D editor and it doesn't work properly....

 

EDIT:

Although at first I think the objects had the tendency to float a bit over the surface instead of clipping into it :shrug:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now