Hurtz72

Need help with RCON on ARMA 3 Server(s)

2 posts in this topic

I have asked for help in another couple of threads but still not have been provided with a solution to a problem setting up RCON on out ARMA3 servers.

I have several server instances running but to simplify I am attempting to get server 1 working with RCON first as it's installed in the steamapps directory and gets steam updates directly.

I'm using Firedaemon to start server

Here are the parameters I am using to start server 1

-cpuCount=4 -exThreads=7 -profiles=Users -BEpath=C:\Program Files (x86)\Steam\SteamApps\common\Arma 3\BattlEye -name=XXX -config=server1.cfg -netlog -steamPort=8766 -steamQueryport=27026 -port=2502 -maxplayers=50

Note that the server works fine and is up and running, players can connect so I have no issues there.

When I try to connect using RCON ( Battlewarden and EPM) I get a message that I cannot connect. I'm connecting from the local host using 127.0.0.1 and the port of 2502.

I've used RCON on this server before for DAYZ and ARMA2 but am unable to get it working for ARMA3.

Troubleshooting done so far

- Started up server using a shortcut with same startup parameters to eliminate a firedaemon / Interactive services detection window issue.

- renamed be.cfg to beserver.cfg

- copied the ban.txt to the battleye folder

- entered a password in beserver.cfg which is the rcon password

- disabled the local firewall to rule that out, network firewall should not be an issue where clients can connect on 2502 and I'm testing right from the server.

- added the -BEpath= as seen above

- confirmed that server1.cfg has batteye=1 entry and it's not commented out

I don't know what else to try, help please.

Edited by Hurtz72

Share this post


Link to post
Share on other sites
I have asked for help in another couple of threads but still not have been provided with a solution to a problem setting up RCON on out ARMA3 servers.

That is not a valid reason at all to start yet another thread. Continue where you previously posted already.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.