Jump to content

Photo
- - - - -

What REALLY helped me to improve performance


  • Please log in to reply
20 replies to this topic
Thread Starter
Thehat3z
Thehat3z

    Rookie

  • Members
  • 6 posts

Posted 09 March 2013 - 17:32 #1

Well , I don't have a high end device , my computer is pretty old.
i have 4 gigs of ram
an intel core 2 quad q6600 2.4ghz
and a gts 450 overclocked by gigabyte.
I started playing the game and got really bumped by how the game is running for me (horrible)
so i did a little search around the webz and found this "-cpucount=4"
This increased my performance so much , i actually enjoy playing the game now.
If you have some low fps , give this a shot , it helped me. A lot.

johncage
johncage

    Banned

  • 875 posts

Posted 09 March 2013 - 17:34 #2

tried that before. seems like a placebo more than anything since the fps didn't change. what did improve the performance for me was switching to the development build and downloading the 7.4mb update.

Thread Starter
Thehat3z
Thehat3z

    Rookie

  • Members
  • 6 posts

Posted 09 March 2013 - 17:37 #3

tried that before. seems like a placebo more than anything since the fps didn't change. what did improve the performance for me was switching to the development build and downloading the 7.4mb update.

How did you do that?

aplum123
aplum123

    Rookie

  • Members
  • 6 posts

Posted 09 March 2013 - 17:40 #4

Well , I don't have a high end device , my computer is pretty old.
i have 4 gigs of ram
an intel core 2 quad q6600 2.4ghz
and a gts 450 overclocked by gigabyte.
I started playing the game and got really bumped by how the game is running for me (horrible)
so i did a little search around the webz and found this "-cpucount=4"
This increased my performance so much , i actually enjoy playing the game now.
If you have some low fps , give this a shot , it helped me. A lot.

what's this cpu count thing? Is that something in the game's folder that I have to manually change?

Thread Starter
Thehat3z
Thehat3z

    Rookie

  • Members
  • 6 posts

Posted 09 March 2013 - 17:42 #5

what's this cpu count thing? Is that something in the game's folder that I have to manually change?


Click properties on your game in your steam library , click on set launch options and add that "-cpucount=x" in. i wrote x since if it depends on how many cores you have with your cpu. since i have a quad core i have 4 cores...

aplum123
aplum123

    Rookie

  • Members
  • 6 posts

Posted 09 March 2013 - 18:14 #6

Ah ok thanks :D and I also have a quad core :)

purepassion
purepassion

    Moderator

  • 4358 posts

Posted 09 March 2013 - 18:20 #7

How did you do that?


Here's how you do it :)

Posted ImagePosted ImagePosted ImagePosted Image


AussieStig
AussieStig

    Private First Class

  • Members
  • 39 posts

Posted 09 March 2013 - 18:46 #8

All these "What fixes the FPS lag" threads, and not one of them does a single thing for me :(
Unity Security Force

www.usecforce.com

Thread Starter
Thehat3z
Thehat3z

    Rookie

  • Members
  • 6 posts

Posted 09 March 2013 - 18:48 #9

All these "What fixes the FPS lag" threads, and not one of them does a single thing for me :(

I found this, give it a shot: 1. Go to Steam Library
2. Go to "Arma 3" Right Click then select "Properties"
3. Select "Set Launch Options"
4. Copy and paste the correct launch command line below to what your system is setup for and click "OK".

For AMD CPU users:
AMD Dual Core with 4GB System Ram:
"-noSplash -cpuCount=2 -high"
AMD Quad Core with 4GB Ram:
"-noSplash -cpuCount=4 -high"
AMD Six Core with 4GB Ram:
"-noSplash -cpuCount=6 -high"
AMD Eight Core with 4GB Ram:
"-noSplash -cpuCount=8 -high"
______________________________________________
If your running more than 8GB Ram then apply this to the end of the launch line:
"-maxMem=8192"
This will allow your game to utilize 8GB system Ram instead of 4GB.
______________________________________________
Intel CPU:
For Hyperthreaded CPU's such as a Quad Core you will apply this:
-cpuCount=8
This will enable your Hyperthreads on your CPU so your CPU will act as an eight core when running Arma 3.
If you are running a Hyperthreaded Six Core then:
-cpuCount=12
If you are running a Hyperthreaded Eight Core or Eight Core Xeon then apply this:
-cpuCount=16
If you are running just a non Hyperthreaded CPU such as a Quad Core then select "4" instead of "8" same for a Dual Core you will select "2" instead of "4".
All AMD CPU's are NOT Hyperthreaded so Hyperthreaded options is highly not recommended as this can cause system failure or damage.
I will not be responible for system failure and damage if you choose to select more cores then you have on your command line!

-high:
makes your operating system prioritize services and processes to run your game better but this can cause system failure and instability if you dont have a good running system. If you Overclock this can cause system instability.
-noSplash:
disables startup videos and advertisements.
-cpuCount=#:
enables extra CPU cores and Hyperthreads.
-maxMem=#:
when set to "6144" (6GB) and up lets your game use more system Ram then 4GB.
Do not set to higher than 4GB if you dont have at least 8GB. You can set to "8192" (8GB) if you have 12GB+ Ram.

IsaacLightning
IsaacLightning

    Rookie

  • Members
  • 7 posts

Posted 09 March 2013 - 19:58 #10

I found this, give it a shot: 1. Go to Steam Library
2. Go to "Arma 3" Right Click then select "Properties"
3. Select "Set Launch Options"
4. Copy and paste the correct launch command line below to what your system is setup for and click "OK".

For AMD CPU users:
AMD Dual Core with 4GB System Ram:
"-noSplash -cpuCount=2 -high"
AMD Quad Core with 4GB Ram:
"-noSplash -cpuCount=4 -high"
AMD Six Core with 4GB Ram:
"-noSplash -cpuCount=6 -high"
AMD Eight Core with 4GB Ram:
"-noSplash -cpuCount=8 -high"
______________________________________________
If your running more than 8GB Ram then apply this to the end of the launch line:
"-maxMem=8192"
This will allow your game to utilize 8GB system Ram instead of 4GB.
______________________________________________
Intel CPU:
For Hyperthreaded CPU's such as a Quad Core you will apply this:
-cpuCount=8
This will enable your Hyperthreads on your CPU so your CPU will act as an eight core when running Arma 3.
If you are running a Hyperthreaded Six Core then:
-cpuCount=12
If you are running a Hyperthreaded Eight Core or Eight Core Xeon then apply this:
-cpuCount=16
If you are running just a non Hyperthreaded CPU such as a Quad Core then select "4" instead of "8" same for a Dual Core you will select "2" instead of "4".
All AMD CPU's are NOT Hyperthreaded so Hyperthreaded options is highly not recommended as this can cause system failure or damage.
I will not be responible for system failure and damage if you choose to select more cores then you have on your command line!

-high:
makes your operating system prioritize services and processes to run your game better but this can cause system failure and instability if you dont have a good running system. If you Overclock this can cause system instability.
-noSplash:
disables startup videos and advertisements.
-cpuCount=#:
enables extra CPU cores and Hyperthreads.
-maxMem=#:
when set to "6144" (6GB) and up lets your game use more system Ram then 4GB.
Do not set to higher than 4GB if you dont have at least 8GB. You can set to "8192" (8GB) if you have 12GB+ Ram.


I have 6GB of ram, what do I do then?

icetbag
icetbag

    Rookie

  • Members
  • 5 posts

Posted 09 March 2013 - 20:00 #11

...
-maxMem=#:
when set to "6144" (6GB) and up lets your game use more system Ram then 4GB.
Do not set to higher than 4GB if you dont have at least 8GB. You can set to "8192" (8GB) if you have 12GB+ Ram.


Maybe I'm having a blonde moment, but I thought that as Arma3 is a 32bit app it would be limited to using no more than 2GB of system Ram - maybe up to 3GB of system ram if LAA is supported in Arma3?

Source: http://forums.bistud...s-64bit-amp-LAA

gossamersolid
gossamersolid

    Second Lieutenant

  • Members
  • 4459 posts
  • LocationOntario, Canada

Posted 09 March 2013 - 20:30 #12

Maybe I'm having a blonde moment, but I thought that as Arma3 is a 32bit app it would be limited to using no more than 2GB of system Ram - maybe up to 3GB of system ram if LAA is supported in Arma3?

Source: http://forums.bistud...s-64bit-amp-LAA


3GB on a 32-bit system and 4GB on a 64-bit system (if LAA is enabled - which I thought it was back in the A2 days after a patch)
logo.png
ArmA 3 - GWAR3
ArmA 2 - PCDF | Gossamer's Warfare
PC - i5 3570K | EVGA GTX 780 ACX | 16GB DDR3

icetbag
icetbag

    Rookie

  • Members
  • 5 posts

Posted 09 March 2013 - 21:22 #13

3GB on a 32-bit system and 4GB on a 64-bit system (if LAA is enabled - which I thought it was back in the A2 days after a patch)


Aha!, thanks for clearing that up.

antoineflemming
antoineflemming

    Warrant Officer

  • Members
  • 2852 posts

Posted 10 March 2013 - 00:02 #14

Well , I don't have a high end device , my computer is pretty old.
i have 4 gigs of ram
an intel core 2 quad q6600 2.4ghz
and a gts 450 overclocked by gigabyte.
I started playing the game and got really bumped by how the game is running for me (horrible)
so i did a little search around the webz and found this "-cpucount=4"
This increased my performance so much , i actually enjoy playing the game now.
If you have some low fps , give this a shot , it helped me. A lot.


Arma has always seemed to work better for older computers than it has for newer computers.

Posted Image

Posted ImagePosted ImagePosted Image
| Mediterranean Operations Addon | LION OF THE CASPIAN Expansion Pack |

System Specs:
Spoiler

NeMeSiS
NeMeSiS

    Captain

  • Members
  • 6366 posts

Posted 10 March 2013 - 00:06 #15

Maybe I'm having a blonde moment, but I thought that as Arma3 is a 32bit app it would be limited to using no more than 2GB of system Ram - maybe up to 3GB of system ram if LAA is supported in Arma3?


You are right about that, but the maxmem parameter ignores values above 2047. Like most of these threads it is mostly bad benchmarking and placebo effects, and the actual effect is zero since the game already sets itself to the correct values anyway.

Jimieus
Jimieus

    Private First Class

  • Members
  • 32 posts

Posted 10 March 2013 - 03:39 #16

^^^ This. Most of these launch parameters were made redundant after AO1.60 if I remember correctly. Whole lot of straw clutching truth be told...

Thread Starter
Thehat3z
Thehat3z

    Rookie

  • Members
  • 6 posts

Posted 10 March 2013 - 03:40 #17

I have 6GB of ram, what do I do then?

so you add
"-maxMem=6144" (without quotes)

Jimieus
Jimieus

    Private First Class

  • Members
  • 32 posts

Posted 10 March 2013 - 04:07 #18

so you add
"-maxMem=6144" (without quotes)


maxmem parameter ignores values above 2047. (as someone mentioned 2 posts above)

Please read this before advising others:
Start Parameters

Hornet
Hornet

    Private First Class

  • Members
  • 12 posts

Posted 10 March 2013 - 10:30 #19

Arma has always seemed to work better for older computers than it has for newer computers.


Why is it so? :(

Luke159
Luke159

    Rookie

  • Members
  • 7 posts

Posted 10 March 2013 - 11:02 #20

Why is it so? :(



Some engines work better on older systems, they become unstable on the newer operating systems and/or equipement. Not sure about Amra 2 or 3 because i haven't touched a computer with XP on it for many years now.