LtShadow

ArmA addons not working anymore

20 posts in this topic

I recently was trying to play ArmA Armed Assault with addons and noticed right in the middle of loading it would crash and say Application Crash and the fault module is "ntdll.dll" I already tried re-installing about 3-4 times now, also works fine without addons. Whats weird is that I have been playing WITH addons for the past 2 years and now all of a sudden they dont wanna work anymore! I have been using the same addons for the past year and a half. I already tried running as admin and all that stuff so...

HELP!!! :j::j::j::j::j::j::j::confused:

Share this post


Link to post
Share on other sites

Hi, welcome to BIS forums.

Can you give some more details, on which addons you are using, maybe links as well?

Share this post


Link to post
Share on other sites
Hi, welcome to BIS forums.

Can you give some more details, on which addons you are using, maybe links as well?

I recently have been experiencing crash errors with certain addons that have worked flawlessly before today/yesterday... This includes the A.C.E. mod and Delta Hawks P71 Police Interceptors: -ACE link http://bit.ly/IH4F3Z P71 Interceptors Link http://www.armaholic.com/page.php?id=4661 --- ArmA worked PERFECTLY before the 12th of April 2012. Even with 20 addons I had, Re-installed 4 times and fresh install (Uninstalled and re-installed completely) 3 times. I even tried a repair Ntdll.dll still no luck. Im going to try to run chkdsk for errors on my drive. Any suggestions?

:mad::confused::confused::mad::confused::confused::confused::mad:

Share this post


Link to post
Share on other sites

Thanks for the info, couple things:

when you installed ACE where do you have it, in the Arma1 directory?

how are you launching the game with ACE shortcut, if so whats your target line.

You do understand that you need EEH (extended eventhandlers for ACE)-->http://www.armaholic.com/page.php?id=2605&highlight=EXTENDED%2BEVENT%2BHANDLERS

run that as -mod=@EEH;@ACE

for the P71 Interceptors you need to create a mod folder and run it, and if your playing that with ACE then target it in your target line like so:

-mod=@EEH;@ACE;@police

@police is just a mod folder name i created, it can be any name you want but in principle you need a folder with @modname, then inside another

folder labeled addons, then the pbos for the P71 Interceptors inside the addons folder.

Im sure you understand and possibly have done all this already.

For ACE on the other hand there is a userconfig that you need to install, which is located in the @ACE

store folder, that userconfig needs to be in the same directory as @ACE.

In general if your game works fine without the mods then theres no need to uninstall and reinstall the game,

what you need to do is refer to the game's RPT-->http://community.bistudio.com/wiki/Crash_Files

The RPT will list everything happening with the game, mods, errors, ect,.

if you could based on that page post your RPT using a spoiler and lets see whats going on.

hope that helps.

Share this post


Link to post
Share on other sites

Yes the "extended eventhandlers" PBO is in the mod, but if i remember correctly its run externally along side it, so my point which i should have explained

myself was that if you didn't install it, my link to the EEH was an optional download as some folks delete stuff after installing a mod they think

is not needed, i ran into some members that were new that did that before.

anyways answer the questions I had posted previously and lets see your RPT.

Im getting a hunch and could be wrong that you installed ACE and the other addon into your main addons folder, or somewhere similar.

Share this post


Link to post
Share on other sites

Got the RPT, thanks.

Heres part of the problem, you have Arma1 WarMod running, amongst all the other stuff you have, thats a huge mod ( i should Know i built it.)

How are you launching your mods?

post your target line, as the RPT isn't specific to how you have it setup.

Also when i built WarMod it was on version 1.14, so i dont know how stable or what 1.18 is like, with game version or patch 1.14 i never had issues.

For your last timestamp:

Mods: CA;@BayCityAddons;@Police;@slr_addons;@MB2Cessna;@Avgani;@F-15;@F-16;@Nuke;@WarMod;@EEH

few things:

-never put any addon or mods, any file you download into the main arma addons directory, rule #1 not saying you have,

but just for your info, always make a mod folder, i think you get this.

-for your mods, condense them, make a folder that says something along the line of @planes, then put all your planes in there, then another mod for islands, ect,.

For WarMod which is what i built in summer 2009, the mod has little over 125 addons and mods in it running at once together.

Funny thing was I recognized all the addons, im like hey this dude is running a very familiar assortment of mods,

then i seen the WarMod folder int he rpt, and I knew it.

i would suggest changing your load order, which i dont know what it is for your target line but run:

-mod=@EEH;@WarMod; other mods.... big eeh first then big mods, then dwindle down from there.

as for the game crashing to many mods can be the issue, and wrong load order, and a possible oversized RPT.

As you said in your first post:

also works fine without addons. Whats weird is that I have been playing WITH addons for the past 2 years

and now all of a sudden they dont wanna work anymore! I have been using the same addons for the past year and a half.

What I suggest you doing is do a process of elimination, just using your shortcut to launch the game, setup 2 shortcuts, one modded, and one vanilla,

if the game runs fine, np with vanilla, then we know it may be the mods causing problems, so you need to make sure you know where all the mods are

(in one place) all in the Arma1 directory where the Arma.exe is located, make sure all addons and mods are in mod folders, not in other folders.

Then delete your rpt , dont let your rpt get big especially with the errors your getting as it will, and or might crash your game,

it has done that to me when Arma1 was the main game for me.

The first take out WarMod as that has a ton of mods in one, dont uninstall it, just take it out of your shortcut target line, and then test,

then keep doing that with all your mods, and eventually you should find the culprit, (maybe).

Hope that helps.

Share this post


Link to post
Share on other sites

Your WarMod works absolutley fine with ver. 1.18! just a fact - Here is my Target line - "C:\Program Files\Bohemia Interactive\ArmA\arma.exe" -window -mod=@BayCityAddons -mod=@Police -mod=@slr_addons -mod=@MB2Cessna -mod=@Avgani -mod=@F-15 -mod=@F-16 -mod=@Nuke -nosplash -mod=@WarMod;@EEH

I will do all what you asked. Also, I have now learned that ACE no longer is the problem ( had to just reinstall mod) so... The only addons giving me errors is the @Bay City Addons (Which only contains the BC pumper cause no one has the old addons anymore... maybe you can help with that?) and the P71's (Police cars) Which were all fine a few days ago! --- Everything else works fine except these.... Update to this post will come via reply with quotes...

Share this post


Link to post
Share on other sites

No wonder your having issues, you only need to call the -mod= parameter once.

Do like this:

"C:\Program Files\Bohemia Interactive\ArmA\arma.exe" -window -nosplash -mod=@EEH;@WarMod;@BayCityAddons;@Police;@slr_addons;@MB2Cessna;@Avgani;@F-15;@F-16;@Nuke

now my version with your mods condensed:

"C:\Program Files\Bohemia Interactive\ArmA\arma.exe" -window -nosplash -mod=@EEH;@WarMod;@islands;@Planes;@Misc

much cleaner.

here is the

Arma2: Startup Parameters

http://community.bistudio.com/wiki/Arma2:_Startup_Parameters

The only addons giving me errors is the @Bay City Addons (Which only contains the BC pumper cause no one has the old addons anymore...

maybe you can help with that?) and the P71's (Police cars) Which were all fine a few days ago!

Run them without everything else and see what happens.

Share this post


Link to post
Share on other sites

I already tried condensing and no luck... tried getting rid of the RPT file... NO luck! What should I do now??

p.s. Are you familiar with Bay City RPG? If you have their old addons from ArmA 1 can you give them to me? Thanks.

Share this post


Link to post
Share on other sites

No luck as in it keeps crashing?

If WarMod is working fine then your game shouldn't be crashing thats if that what it is doing.

your rpt should tell you whats going on.

Are you familiar with Bay City RPG? If you have their old addons from ArmA 1 can you give them to me? Thanks.

Heard of them but I was never into armaRPGS, that usually means going on some server, why dont you search for them on Armaholic, or google,

surely you could find it, but what sense is to get it if your game is not working for you, I think you have more important priorities then worrying about a mod.

Did you run vanilla Arma1 and does it work np, no crashes, freezes ect,.?

then add a mod 1 by 1, and test.

Share this post


Link to post
Share on other sites

Okay,

I did all you said and No luck (Yes, its still not working). I think this may be becoming a hardware issue?

ArmA 1 Vanilla works like a charm!

Share this post


Link to post
Share on other sites

Okay, for some odd reason. I ran ArmA with all my mods and so forth and added a NEW mod (ArmA Effect Mod) and EVERYTHING WORKS!!!!!!!!!! IDK what happend... I deleted my RPT a few times also. Now I just am going to port ArmA 2 addons to ArmA 1 (Since I am only getting the p3d version 48 error) :D Maybe you could help with that?

Thanks for your help!

Share this post


Link to post
Share on other sites
I recently was trying to play ArmA Armed Assault with addons and noticed right in the middle of loading it would crash and say Application Crash and the fault module is "ntdll.dll" I already tried re-installing about 3-4 times now, also works fine without addons. Whats weird is that I have been playing WITH addons for the past 2 years and now all of a sudden they dont wanna work anymore! I have been using the same addons for the past year and a half. I already tried running as admin and all that stuff so...

HELP!!! :j::j::j::j::j::j::j::confused:

I`ve got the same crap going on;It is Patched in the correct order(all except the last one,1.60 Patch)

sence I cant figure out witch one is emedietly before 1.60 .Then it says that it can`t decrypt the Header of the .Air.pbo file and continues to install all other files and claims that it has installed it all

OK.

SOMETHING HAPPEND WITH THE UNITS AIR.PBO FILE! AND NOW THERE IS NO ADDONS FOLDER AND ALL IS COMPLETLY GONE.

SOLUTION:MAYBE YOU CAN INSTALL THE FILE PATCH EMEDIETLY BEFORE THAT. IS IT 1.59?

HOPE THAT FIX IT.

NOW I´M REALLY PISSED OFF!! THIS BETTER WORK BETTER IN ARMA 3!!!

Share this post


Link to post
Share on other sites
I`ve got the same crap going on;It is Patched in the correct order(all except the last one,1.60 Patch)

sence I cant figure out witch one is emedietly before 1.60 .Then it says that it can`t decrypt the Header of the .Air.pbo file and continues to install all other files and claims that it has installed it all

OK.

SOMETHING HAPPEND WITH THE UNITS AIR.PBO FILE! AND NOW THERE IS NO ADDONS FOLDER AND ALL IS COMPLETLY GONE.

SOLUTION:MAYBE YOU CAN INSTALL THE FILE PATCH EMEDIETLY BEFORE THAT. IS IT 1.59?

HOPE THAT FIX IT.

NOW I´M REALLY PISSED OFF!! THIS BETTER WORK BETTER IN ARMA 3!!!

Dude your in the Arma1 section of the forums, what game do you exactly have that your having problems with, is it Arma1 or Arma2.

Only patch for Arma1 is the 1.18 patch.

Arma2OA uses the 1.60 patch.

Share this post


Link to post
Share on other sites
-for your mods, condense them, make a folder that says something along the line of @planes, then put all your planes in there, then another mod for islands, ect,.
I would claim this is just as bad as condensing all your addons in the official game's addons folders; bad practice.

Except that you are now doing it in another folder - at least that's a little better.

Merging addon files to single folders removes flexibility, maintainability, makes updates harder (hey did this PBO belong to ModX or ModY - easy to leave addons that might already have been removed).

Some mods contain similar addons to other mods, but different versions.

It all becomes a mess, unless you spend a lot of time and effort, IMO something that is left to addon makers and mixers.

Then I haven't even touched MultiPlayer, think about signature protection, needing 5 islands to join, but you have 20 islands in your @Islands modfolder, and there's many more where that came from.

Instead you should IMO deal with the issue properly, and the issue IMO is that dealing with a lot of mods in a shortcut is simply messy and not comfortable.

To solve that, you can use a Launcher. Not make a bigger mess and new problems.

Still, if you prefer a structure like @Islands to group islands together, just put the modfolders in as subfolder and take that into account in your launcher etc (-mod=@Islands\@fallujah)

Edited by Sickboy

Share this post


Link to post
Share on other sites
I would claim this is just as bad as condensing all your addons in the official game's addons folders; bad practice.

Always worked for me to condense everything into one folder, never had issues with it, and of course I agree not to put files in the official addons folder that would be trouble.

The @islands, or @planes is something I do, I personally never seen the point of having 50 separate mods in the target line,

when you could condense them based on type, but for me at least when i look at the folder i know what files belong to what, Im used to doing this with my WarMod versions.

unless you spend a lot of time and effort, IMO something that is left to addon makers and mixers.

The mixer part would be me, more like a compiler.

@Islands to group islands together, just put the modfolders in as subfolder and take that into account in your launcher etc (-mod=@Islands\@fallujah)

Hmm, I heard this before but never actually tried or did it, so for every island lets say you basically just add a \ representing a folder

with the island name and then game would recognize that and load it?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now