Jump to content

Photo
- - - - -

Black fog surrounding model


  • Please log in to reply
5 replies to this topic
Thread Starter
Double Doppler
Double Doppler

    Staff Sergeant

  • Members
  • 242 posts

#1

Posted 05 April 2012 - 18:49

After working with super-shader materials, I noticed black pp-effect fog surrounding the shell of my model in the buldozer viewer. It disappears when I zoom in real close, and fades out when I zoom out far. Does anyone know what this is and why it is happening?

Max Power
Max Power

    Mr. Angry Face

  • Members
  • 12828 posts

#2

Posted 05 April 2012 - 19:27

Real time anti aliasing.
Posted Image
Posted Image
My inbox is fill and won't be emptied. If your PM is regarding requests to use my work, unfortunately I choose not to grant such permission. My work is for use with CWR2 only.

Thread Starter
Double Doppler
Double Doppler

    Staff Sergeant

  • Members
  • 242 posts

#3

Posted 05 April 2012 - 21:01

How would I go about disabling this effect and is it visible in-game like the way it is in buldozer?

Max Power
Max Power

    Mr. Angry Face

  • Members
  • 12828 posts

#4

Posted 05 April 2012 - 21:15

Sorry, I meant to say ambient occlusion. It was early in the morning for me. This may have something to do with your graphics drivers.

Is it a small object? Are you moving the camera near it or zooming?

The buldozer config file is located in:

your user profile\Documents\ArmA 2\buldozer.cfg

Edited by Max Power, 05 April 2012 - 21:22.

Posted Image
Posted Image
My inbox is fill and won't be emptied. If your PM is regarding requests to use my work, unfortunately I choose not to grant such permission. My work is for use with CWR2 only.

Thread Starter
Double Doppler
Double Doppler

    Staff Sergeant

  • Members
  • 242 posts

#5

Posted 05 April 2012 - 21:24

Is it a small object? Are you moving the camera near it or zooming?


Moving the camera near it. Before I used supershaders on my materials it was fine. I have made NOHQ, smdi and as maps of the textures and their effects work, however I get the fog problem.

I would like to know what problems cause this, so I could put an end to it. My object is a hatchback car, similar in size to the golf in Arma 2.

Edited by Double Doppler, 05 April 2012 - 21:28.


Max Power
Max Power

    Mr. Angry Face

  • Members
  • 12828 posts

#6

Posted 05 April 2012 - 21:39

Ambient occlusion measures the distance between surfaces and puts shadows on the interior to simulate the fact that light can't really get there. SSAO computes the difference in depth of the surface being displayed and compares between pixels on screen. Something about the calculations seems to go awry when the camera is very close to an object. At any rate, I find this doesn't happen if I use zoom instead. You can edit the ssao settings in your graphics drivers or in the buldozer.cfg to possibly find a solution to the problem, maybe by increasing its accuracy or by turning it off.

Edited by Max Power, 05 April 2012 - 22:46.

Posted Image
Posted Image
My inbox is fill and won't be emptied. If your PM is regarding requests to use my work, unfortunately I choose not to grant such permission. My work is for use with CWR2 only.