Jump to content

Photo
- - - - -

OFP freezing when loading unoff. addons


  • Please log in to reply
3 replies to this topic
Thread Starter
L.K.
L.K.

    Private First Class

  • Members
  • 29 posts

#1

Posted 15 January 2012 - 17:23

Hello, I'm having a strange error.
The game, CWA/OFP version 1.99 -but it also happens with 1.96-, completely freezes whenever I try to load an unofficial addons in the editor or when I try to load a mission that uses unofficial addons. At that point I'm given no other option aside from rebooting my PC.

It happened for the first time a week ago after some Windows XP updates. I had never experienced this before and it's really strange.
I updated motherboard drivers (it's a ASRock K7VT6), my video card drivers (Radeon 9200 SE) and my sound card drivers (C-Media AC97, comes bundled with the motherboard) but that didn't seem to do the trick.

My motherboard chip is based on VIA and I already tried to set the AGP to 4x.
Reinstallation OFP has been tried too. My operative system is Windows XP Service Pack 3. To whom it may concern, I'm posting the "flashpoint.rpt" file:

=====================================================================
== C:\Documents and Settings\Documenti\Giochi\Operation Flashpoint\FLASHPOINTRESISTANCE.EXE
=====================================================================
Exe version: Sat Jan 14 12:42:29 2012

graphics: Direct3D HW T&L , Device: RADEON 9200 SERIES , Driver:ati2dvag.dll 6.14.10.6614
resolution: 1025x769x32
Addons:
[Addon listed here, I'm removing them.]
Mods: RES;ObjectPack;USSR
===FROZEN====>>>>>>BEG
Version 1.96
Fault address: 0052545D 01:0012445D C:\Documents and Settings\Documenti\Giochi\Operation Flashpoint\FLASHPOINTRESISTANCE.EXE
file:
world: Intro
Prev. code bytes: 33 C9 EB 05 1B C9 83 D9 FF 85 C9 74 10 FF 45 FC
Fault code bytes: 83 C0 04 39 7D FC 7C B7 B8 BC D6 7D 00 5F 5E 5B

Registers:
EAX:10B84B80 EBX:0076BC65
ECX:FFFFFFFF EDX:00003865
ESI:0076BC88 EDI:00000015
CS:EIP:001B:0052545D
SS:ESP:0023:0012EBB8 EBP:0012EBC8
DS:0023 ES:0023 FS:003B GS:0000
Flags:00200206
===FROZEN====>>>>>>END


Edit: I noticed that the game freezes only with some addons.
DKM's Rah-66 ''Comanche'' works fine and so do the Marine Assault Pack units.
Still many other unofficial addons make the game freeze.

Edited by L.K., 15 January 2012 - 18:04.


sanctuary
sanctuary

    First Lieutenant

  • Members
  • 5163 posts

#2

Posted 15 January 2012 - 22:59

Sometime there are some unofficial addons that really don't play well together with some mods (or even without) and may put a big strain on the performance that can freeze indeed the game.
Additionally, using too many addons at once in a mod folder can result in the same problems

Be sure to try the -nomap parameter in your OFP shortcut

And when testing, you can try to play OFP windowed (see the startup parameter page linked) , so when OFP freeze on you, you can at least kills the window with ctrl+alt+ del without having to reboot your computer manually (as in full screen the ctrl+alt+del task manager panel may be invisible if OFP freeze.)

Be sure to have no unofficial addon in your OFP or OFP\Res\ folder, and use only mod folders for unofficial addons.

Other than testing addons one by one when you're experiencing freeze, i'm not sure there's an obvious way to locate the exact source of the problem.

Thread Starter
L.K.
L.K.

    Private First Class

  • Members
  • 29 posts

#3

Posted 16 January 2012 - 11:15

Even if I had already tried that, thank you for your advices, Sanctuary! :)
Apparently, I solved the problem by reinstalling the motherboard drivers, and ticking off most of the options in the "API" section of the CATALYST Control Center. Sure, I lost some graphic details, but at least the game runs.

Thread Starter
L.K.
L.K.

    Private First Class

  • Members
  • 29 posts

#4

Posted 17 January 2012 - 11:12

I confess I hadn't noticed it.. It's strange considering that my screen resolution is set to 1024x768.