Jump to content

Photo
- - - - -

Microphone not detected/how to change mic device


  • Please log in to reply
2 replies to this topic
Thread Starter
a wild goat
a wild goat

    Corporal

  • Members
  • 91 posts

#1

Posted 23 July 2011 - 01:21

basically when I use VON my mic cant be heard. what people hear is the sound from my game. I believe this is because I have two sound cards. one of them being a USB sound card that I use to connect ONLY my mic to my comp, then my actual PCI sound card to handle the all other audio (i do this because the PCI sound card's mic input sucks). so obviously whats going on here is arma thinks that my microphone is my either the USB soundcard's speakers or my PCI soundcard's speakers, so i need to figure out how to change my microphone device in arma. before you ask, I have searched the forums already and found like 17 posts with no answers. I have checked my a wild goat.arma2oaprofile for any setting to change my mic with no result, same with arma2oa.cfg. & for anyone that thinks i am truly retarded YES THE MIC IS PLUGGED IN AND YES IT WORKS FINE.

p.s. sound card is a Diamond XS51

tl;dr: how do you change your microphone device in ArmA 2 OA?

Edited by a wild goat, 23 July 2011 - 01:23.
sys info

proud creator of crappy, frustrating and impossible to beat missions

vohk
vohk

    Sergeant

  • Members
  • 119 posts

#2

Posted 23 July 2011 - 02:01

You don't. Arma2/OA seems to select the Windows default recording device on start up. If you have Windows 7: Control Panel -> Sound -> Recording Devices. Make sure your desired input is the default device and ideally disable any recording devices. Ensure it is working in Windows, then launch the game. Don't unplug or disable the mic while the game is running, or you'll have to restart it.

If that doesn't work, I have no idea what's going on.

Thread Starter
a wild goat
a wild goat

    Corporal

  • Members
  • 91 posts

#3

Posted 23 July 2011 - 09:34

yep your right. I had previous gone the Recording Devices list and seen my mic had been set to default, but there was alot of other devices including my speakers in that list that hadnt been disabled, so i went ahead and disabled them and voila. now i can be as ridiculous as i please in life servers. thanks for the help!
proud creator of crappy, frustrating and impossible to beat missions