Jump to content

Photo
- - - - -

ARMA 2:OA beta patch 74858


  • Please log in to reply
105 replies to this topic
Thread Starter
WillaCHilla
WillaCHilla

    Staff Sergeant

  • Members
  • 232 posts

Posted 01 November 2010 - 14:49 #1

http://www.arma2.com/beta-patch.php

[74856] Fixed: Tanks were jumping a lot when driving over stones far from a camera (http://dev-heaven.net/issues/1707).
[74849] Optimized: Improved performance when wheeled or tracked vehicles are moving (related to ground trace maintenance).
[74832] Fixed: Possible player desync after DeleteVehicle command when player is a gunner.
[74765] Fixed: Audibility of the VoN direct channel and conversations are now based on the player camera position, instead of the unit position.
[74690] Improved: Tree LOD blending is now smoother in many situations.



alternative download-link: here

Edited by WillaCHilla, 01 November 2010 - 20:32.

Posted Image
| Coop-missions almost every evening [GMT+01:00] | [Support for required Mods and A.C.R.E]

Spoiler

Pauliesss
Pauliesss

    Sergeant Major

  • Members
  • 1462 posts

Posted 01 November 2010 - 15:08 #2

Thanks BIS! :yay:

Xeno
Xeno

    ACE Team Leader

  • Members
  • 1814 posts

Posted 01 November 2010 - 15:10 #3

The main version number for this beta patch was updated to 1.55 (instead of 1.54).

So you are not able to play on 1.54 servers with this patch anymore.

Xeno

Edited by Xeno, 01 November 2010 - 15:43.

[SIZE=1][/SIZE]

Pauliesss
Pauliesss

    Sergeant Major

  • Members
  • 1462 posts

Posted 01 November 2010 - 15:29 #4

Something is wrong with this beta version - stuttering, very slow texture loading and problems with LODs...:(

Screen: http://i51.tinypic.com/10n9gnq.jpg

Edit: Nevermind, it was caused by my horrible game settings - everything very high and 10,000 view distance. Sorry. :j:

Edited by Pauliesss, 01 November 2010 - 16:00.


Himmelsfeuer
Himmelsfeuer

    Banned

  • 724 posts

Posted 01 November 2010 - 15:33 #5

Mh, dont got this problem.
Thx BIS, hope to see the AI Fixes in upcoming Betas!

TRexian
TRexian

    Master Gunnery Sergeant

  • Members
  • 1227 posts

Posted 01 November 2010 - 15:35 #6

Regarding Xeno's point about the beta having a different version number... I don't do much MP, but if I decide to, is it possible to just rename the current 1.54 beta folder as betaTemp or something, then install the new one, and just re-name them if I want to go online?

TIA,
T

seelix
seelix

    Staff Sergeant

  • Members
  • 248 posts

Posted 01 November 2010 - 15:37 #7

:ok:
I like this logfile.
Thanks alot.

Thr0tt
Thr0tt

    Master Sergeant

  • Members
  • 800 posts

Posted 01 November 2010 - 15:39 #8

Regarding Xeno's point about the beta having a different version number... I don't do much MP, but if I decide to, is it possible to just rename the current 1.54 beta folder as betaTemp or something, then install the new one, and just re-name them if I want to go online?

TIA,
T


Yes, Just rename the last beta folder to <beta.123456> then install the new one, that way if you need to revert just rename the latest and remove the .123456 for the one you wish to use (probably best to use the real beta release versions. I did have 10 in there but deleted them as I never reverted.
Specs: Gigabyte GA-MA790XT-UD4P | AMD Phenom II x4 965 BE 3.4GHz | Sapphire RADEON HD 7850 (Latest Cats) CCC |8GB DDR3 1333MHz Dual Channel |Samsung 2232BW 22" LCD & Hanns-G HH281 28" LCD | X-Fi Ultimate Gamer (5.1) | LiteOn DH20A4P DVD-RW | Saitek Cyborg Evo Joystick | Win7 Ultimate

ChiefRedCloud
ChiefRedCloud

    Sergeant

  • Members
  • 161 posts

Posted 01 November 2010 - 15:42 #9

Regarding Xeno's point about the beta having a different version number... I don't do much MP, but if I decide to, is it possible to just rename the current 1.54 beta folder as betaTemp or something, then install the new one, and just re-name them if I want to go online?

TIA,
T


As far as I know, any BETA patch is established in a seperate folder from your actual OA exe. So you meerliy click on the REGULAR exe for normal play. and the BETA (in the Expansion folder) exe to test out the BETA.

But in addition, since most of us DO play multiplayer on a regular basis (Xeno being one of our online heros) this is a BIG deal. Was this in the change log Xeno or did I just miss it?

TRexian
TRexian

    Master Gunnery Sergeant

  • Members
  • 1227 posts

Posted 01 November 2010 - 15:48 #10

Thanks, guys. The deal would be that I'd want to use the latest beta patch (I really truly love it) for online. :) Only test the new beta in SP.

Pauliesss
Pauliesss

    Sergeant Major

  • Members
  • 1462 posts

Posted 01 November 2010 - 16:00 #11

Nevermind, it was caused by my horrible game settings - everything very high and 10,000 view distance. Sorry. :j:

Suma
Suma

    BI Developer

  • 3707 posts

Posted 01 November 2010 - 16:20 #12

The main version number for this beta patch was updated to 1.55 (instead of 1.54).

So you are not able to play on 1.54 servers with this patch anymore.


This incompatibility is required because of following fix:

Audibility of the VoN direct channel and conversations are now based on the player camera position, instead of the unit position.


This fix causes old and new version using completely different mechanism how player position is transferred, therefore old and new clients/servers cannot be mixed together. Hopefully it will not take too much long before we release a stable 1.55 to unite the MP community again.

Edited by Suma, 01 November 2010 - 16:28.
Typo

Ondrej Spanel, BIS Lead Programmer

Xeno
Xeno

    ACE Team Leader

  • Members
  • 1814 posts

Posted 01 November 2010 - 16:26 #13

This fix cause old and new version using completely different mechanism how player position is transferred, therefore old and new clients/servers cannot be mixed together. Hopefully it will not take too much long before we release a stable 1.55 to unite the MP community again.

Thanks for the info Suma.

Xeno
[SIZE=1][/SIZE]

=kct=blackmamba
=kct=blackmamba

    First Sergeant

  • Members
  • 901 posts

Posted 01 November 2010 - 16:28 #14

i hope this bug is fixed now..??
http://dev-heaven.net/issues/14410
it is set to upcoming version.. beta version??

Himmelsfeuer
Himmelsfeuer

    Banned

  • 724 posts

Posted 01 November 2010 - 16:29 #15

http://dev-heaven.net/issues/5183 Solved finally,-thx!
http://dev-heaven.net/issues/3168
http://dev-heaven.net/issues/14410
Any chance we see those 3 fixed in the next betas Suma?
Would be nice if those get sorted out after such a long time..they are bad gamebreakers!

@BlackMamba
Sadly its still not fixed...

Edited by Himmelsfeuer, 01 November 2010 - 16:50.


RobertHammer
RobertHammer

    Second Lieutenant

  • Members
  • 4780 posts

Posted 01 November 2010 - 16:29 #16

This incompatibility is required because of following fix:
This fix causes old and new version using completely different mechanism how player position is transferred, therefore old and new clients/servers cannot be mixed together. Hopefully it will not take too much long before we release a stable 1.55 to unite the MP community again.


So Suma you should add that fix on that stable 1.55 and not before :-/ - anyway thx
Posted ImagePosted Image
There's one place for One Snake and for One BigBoss !!!
Posted Image

=kct=blackmamba
=kct=blackmamba

    First Sergeant

  • Members
  • 901 posts

Posted 01 November 2010 - 16:34 #17

http://dev-heaven.net/issues/5183
http://dev-heaven.net/issues/3168
http://dev-heaven.net/issues/14410
Any chance we see those 3 fixed in the next betas Suma?
Would be nice if those get sorted out after such a long time..they are bad gamebreakers!

@BlackMamba
Sadly its still not fixed...


hmm thats bad news..:headscratch:

RobertHammer
RobertHammer

    Second Lieutenant

  • Members
  • 4780 posts

Posted 01 November 2010 - 16:37 #18

Himmelsfeuer - are you sure?
http://dev-heaven.net/issues/5183 - should be fixed in this new beta
Posted ImagePosted Image
There's one place for One Snake and for One BigBoss !!!
Posted Image

NkEnNy
NkEnNy

    Your member title is shown beside posts you make

  • Members
  • 919 posts
  • LocationOslo, Norway

Posted 01 November 2010 - 16:38 #19

AI tuneups or placebo?

I have a test map I tend I tend to run a few times with each beta upgrade (which pits eight Force Recon soldiers against a Russian Infantry squad) Three times in a row the Force Recon troop has won-- which usually doesn't happen.

Please. No one burst my bubble :P

-k
ARMA 2 Mission packs:LITE Coop mission package + LIMA coop mission package (ACE + ACRE) + More ACE + ACRE missions. + Aliabad coop Mission Package+ Fireforce Takistan
ARMA 3 Mission packs:Fourplay Coop Mission Pack OUTDATED
Kill things, break stuff. Repeat as necessary.

KeyCat
KeyCat

    Warrant Officer

  • Members
  • 2835 posts
  • LocationSweden

Posted 01 November 2010 - 16:46 #20

Just had a quick test and noticed the following which I haven't seen before (I usually don't play in 3rd perspective view) so don't know if this (minor) animation anomaly is new to this beta..

While prone and start to crawl forward the weapon swings out besides the body, see screenshots...

Posted Image

another one with standard A2 unit

Posted Image

Also an old issue (now with pics and repro mission). This damn "auto stand feature" while crawling besides low walls have gotten me killed many times so a gentle reminder so it's not forgotten ;)

Posted Image

Now crawl forward 1 m and you will automaticly stand up!?

Posted Image

Link to repro mission: A2OA_B74858_Auto_stand-up.zip

Only had limited time but tree LOD's seems nicer, the Z-fight issue reported in Beta 74630 (and prev.) is about the same but on the other hand it's not mentioned in the changelog either.

Also sent dumpfiles to Dwarden since I got a crash while exiting.

/KC

Edited by KeyCat, 01 November 2010 - 17:17.

>> It's all about teamwork! <<