Jump to content

Photo
- - - - -

Battleye Failed to update.


  • Please log in to reply
22 replies to this topic
Thread Starter
Plimmy
Plimmy

    Private First Class

  • Members
  • 16 posts

#1

Posted 09 August 2010 - 20:49

I bought OA and installed. Then I bought Arma2 .......then I uninstalled OA, then installed Arma2 then reinstalled OA. Playing OA MP is fine but when I join an MP game of Arma2 I get kicked telling me that Battleye failed to update. I downloaded the 1.05 patch and extracted the Battleye installer and ran it. There is now the battleye folder in Arma2 with the DLL files...........but I still get kicked from MP games even though I downloaded the latest files from the Battleye website. Does anyone have any ideas as I would like to play some Arma2 MP.


Thanks......................Plimmy.

Thread Starter
Plimmy
Plimmy

    Private First Class

  • Members
  • 16 posts

#2

Posted 10 August 2010 - 07:03

I tried again last night and noticed other players were being kicked with the same message. Can anyone help me?

mrcash2009
mrcash2009

    Second Lieutenant

  • Members
  • 4228 posts

#3

Posted 10 August 2010 - 10:25

If your Vista / Win7 make sure you run your game exe as administrator (via properties of your game icon) currently in those O/S systems battle eye will kick you if its not set.

Its not related to "failed to update" initially but most people who have been kicked from servers via battle eye for no good reason repeatedly normally means they need to do the above.

Edited by mrcash2009, 10 August 2010 - 10:28.


SICK OF IDIOTS & STEAM.


Thread Starter
Plimmy
Plimmy

    Private First Class

  • Members
  • 16 posts

#4

Posted 10 August 2010 - 12:24

If your Vista / Win7 make sure you run your game exe as administrator (via properties of your game icon) currently in those O/S systems battle eye will kick you if its not set.

Its not related to "failed to update" initially but most people who have been kicked from servers via battle eye for no good reason repeatedly normally means they need to do the above.


Hi.........I am running XP so I dont have to worry about admin mode.

$able
$able

    BattlEye Developer

  • Members
  • 697 posts

#5

Posted 10 August 2010 - 13:41

but I still get kicked from MP games even though I downloaded the latest files from the Battleye website.


Are you sure you downloaded this file: http://www.battleye....a2/BEClient.dll?

Thread Starter
Plimmy
Plimmy

    Private First Class

  • Members
  • 16 posts

#6

Posted 10 August 2010 - 15:50

Are you sure you downloaded this file: http://www.battleye....a2/BEClient.dll?


Hi and thanks for the reply.............yes I downloaded it from the Battleye website. But just to make sure I downloaded your one too. Ill give it a try and let you know.

---------- Post added at 04:50 PM ---------- Previous post was at 04:22 PM ----------

Tried that file and still getting kicked. I did notice that when I see the browser it tells me that patch 1.07 is now available even though my version is 1.07. Plus when I join a coop it tells me that there is a missing or removed file.

Thread Starter
Plimmy
Plimmy

    Private First Class

  • Members
  • 16 posts

#7

Posted 10 August 2010 - 20:14

I must say that the support from BIS regarding this is pretty poor. There was not much response on the foums plus my email never got answered. Another thing is that the patch 1.0 to 1.07 missing the Battleye installer is also lame. There is no mention apart from being buried on these forums about how to overcome it. On the Battleye site you can oly download the .dll files and not the installer. Plus the patch is quite old now and there hasnt been a change to included Battleye.

Anywhooo rant over. I managed to fix the prob by uninstalling Arma2 and OA then reinstalling Arma2...........applying the all version patch and find the Battleye installer. Unfortunatley I had to work this out myself. Perhaps a sticky would ne nice.

BUT thanks to those who posted a reply anyway. :)

Jack_Ryan_
Jack_Ryan_

    Sergeant

  • Members
  • 110 posts

#8

Posted 10 August 2010 - 21:10

Still more battleye errors. It was kicking people from our server, saying not responding, when the people were fighting right beside us. Too bad when software developers ignore their so called protection.

$able
$able

    BattlEye Developer

  • Members
  • 697 posts

#9

Posted 11 August 2010 - 16:16

I must say that the support from BIS regarding this is pretty poor. There was not much response on the foums plus my email never got answered. Another thing is that the patch 1.0 to 1.07 missing the Battleye installer is also lame. There is no mention apart from being buried on these forums about how to overcome it. On the Battleye site you can oly download the .dll files and not the installer. Plus the patch is quite old now and there hasnt been a change to included Battleye.

Anywhooo rant over. I managed to fix the prob by uninstalling Arma2 and OA then reinstalling Arma2...........applying the all version patch and find the Battleye installer. Unfortunatley I had to work this out myself. Perhaps a sticky would ne nice.

BUT thanks to those who posted a reply anyway. :)


You don't need the BE installer. The BEClient.dll is enough. If you had followed the exact instructions on the website, it would have worked.

---------- Post added at 18:16 ---------- Previous post was at 18:09 ----------

Still more battleye errors. It was kicking people from our server, saying not responding, when the people were fighting right beside us. Too bad when software developers ignore their so called protection.


So why don't you report it? Could you please contact me directly if you are sure that these kicks are not the result of game crashes?

Thread Starter
Plimmy
Plimmy

    Private First Class

  • Members
  • 16 posts

#10

Posted 11 August 2010 - 18:11

[quote name='$able']You don't need the BE installer. The BEClient.dll is enough. If you had followed the exact instructions on the website, it would have worked.[COLOR="Silver"]

Hi........I cant seem to find instructions on how to install. All I could find was place this file into your Battleye folder. That doesnt really help people who have installed 1.0 to 1.07 patch which doesnt include the Battleye installer. Where does it say create a folder in the arma2 directory and name it BattlEye? Where are these exact instructions?

$able
$able

    BattlEye Developer

  • Members
  • 697 posts

#11

Posted 11 August 2010 - 20:22

Where does it say create a folder in the arma2 directory and name it BattlEye? Where are these exact instructions?


Nowhere, you are right. I was probably expecting too much from you. ;) I will change that.

Thread Starter
Plimmy
Plimmy

    Private First Class

  • Members
  • 16 posts

#12

Posted 11 August 2010 - 20:58

Nowhere, you are right. I was probably expecting too much from you. ;) I will change that.


OK. I know it isnt easy trying to keep an eye on things like that. Thanks for the update. Maybe it would be a good idea, as there are new people buying Arma2 on the back of OA, to include Battleye installer in the 1.07 patch.

Thanks. :)

carco69
carco69

    Private First Class

  • Members
  • 15 posts

#13

Posted 15 August 2010 - 19:11

[QUOTE = $ poder ; 1715315 ] En ninguna parte , tiene usted razón . Probablemente estaba esperando demasiado de usted. ; ) voy a cambiar eso. [ / quote ]

Sorry my english...

My son has the same problem that Plimmy. He has bought Arma 2 and he has put the patch 1.00 to 1.07 that hasn´t executable of Battleye.
The other patches (1.02, 1.03, 1.05 that has the battleye) doesn´t work and he has download a lot of times this pacthes for to try it...
His instalation has the original ArmA 2 and the 1-07 pacth actually.
We need the executable of BattlEye for Arma 2, please. In the page of http://www.battleye.com/ only is the two DLL´s archives for upgrade, no one install archive.
Thx for all, and sorry again if it´s very hard to understand me )))

$able
$able

    BattlEye Developer

  • Members
  • 697 posts

#14

Posted 15 August 2010 - 19:25

In the page of http://www.battleye.com/ only is the two DLL´s archives for upgrade, no one install archive.


Please read the other posts in this thread and follow the instructions on the website. You don't need an installer. You only need to create a folder called "BattlEye" and put the BEClient.dll in there.

carco69
carco69

    Private First Class

  • Members
  • 15 posts

#15

Posted 15 August 2010 - 21:22

[QUOTE = $ poder ; 1719506 ] Por favor, lea los demás puestos en este tema y siga las instrucciones en la página web . Usted no necesita un instalador. Sólo tienes que crear una carpeta llamada " BattlEye " y poner el BEClient.dll allí. [ / quote ]

Gracias, pero ....
Hemos creado una carpeta llamada en BattlEye USER/AAPDATA/LOCAL/ARMA2 y hemos puesto BEClient.dll allí como hemos hecho al principio de nuestro problema , pero no funciona.
¿Cuál es el problema ahora , entonces?
Gracias por su answher .

---------- Post added at 09:22 PM ---------- Previous post was at 09:20 PM ----------

[quote name='Plimmy']OK. I know it isnt easy trying to keep an eye on things like that. Thanks for the update. Maybe it would be a good idea, as there are new people buying Arma2 on the back of OA, to include Battleye installer in the 1.07 patch.

Thanks. :)[/QUOTE]

i´ve done as you, but doesn´t work still...
Did you do anything more?
Thanks

$able
$able

    BattlEye Developer

  • Members
  • 697 posts

#16

Posted 15 August 2010 - 22:08

i´ve done as you, but doesn´t work still...
Did you do anything more?
Thanks


Did you read my last post? You need to create a BE folder in your ArmA 2 install directory (as explained on the download page).

Also, I don't understand your language. Please post in English only.

Edited by $able, 15 August 2010 - 22:11.


Emerald 8
Emerald 8

    Lance Corporal

  • Members
  • 54 posts

#17

Posted 16 August 2010 - 14:40

$able,
Can you explain why battleye is kicking players an hour into the game?

$able
$able

    BattlEye Developer

  • Members
  • 697 posts

#18

Posted 16 August 2010 - 14:41

$able,
Can you explain why battleye is kicking players an hour into the game?


Can you be more specific please?

carco69
carco69

    Private First Class

  • Members
  • 15 posts

#19

Posted 16 August 2010 - 17:30

Gracias $ _POWER
Yo no entendía el lugar donde PTU el archivo ...
Muy bien y de trabajo ))

Thread Starter
Plimmy
Plimmy

    Private First Class

  • Members
  • 16 posts

#20

Posted 17 August 2010 - 00:23

[quote name='carco69'][QUOTE = $ poder ; 1719506 ] Por favor, lea los demás puestos en este tema y siga las instrucciones en la página web . Usted no necesita un instalador. Sólo tienes que crear una carpeta llamada " BattlEye " y poner el BEClient.dll allí. [ / quote ]

Gracias, pero ....
Hemos creado una carpeta llamada en BattlEye USER/AAPDATA/LOCAL/ARMA2 y hemos puesto BEClient.dll allí como hemos hecho al principio de nuestro problema , pero no funciona.
¿Cuál es el problema ahora , entonces?
Gracias por su answher .

---------- Post added at 09:22 PM ---------- Previous post was at 09:20 PM ----------



i´ve done as you, but doesn´t work still...
Did you do anything more?
Thanks[/QUOTE]

HI.............I had the same prob and even creating the folder and putting in the dll files didnt work. The only way I got it to work was to uninstal arma2 and OA, then clean the registry with CCleaner (google it), then reinstall arma2 patch it then install OA apply patch for OA then install battleye with the installer. I got my battleye installer from the 1.05 patch. I opened up the patch exe with winrar and got the battleye installer that way.

Edited by Plimmy, 17 August 2010 - 00:27.