CMDRTACO

Member
  • Content count

    9
  • Joined

  • Last visited

  • Medals

Community Reputation

10 Good

About CMDRTACO

  • Rank
    Private
  1. Are you still working on this project? Looks very promising if you continue to deliver on your roadmap.
  2. It's really a simple mission already. I don't think it's the mission system itself because it works fine in all other aspects. The AI will die properly if it's doing anything other than a full speed run.
  3. I created a new mission for Dayz Wicked AI mod that simply spawns one AI and sets a waypoint. The mission ends when you either kill the AI or it reaches the waypoint. The issue is with the killing of the AI. If I shoot it when it's walking, kneeling, basically anything except a full run, it dies, produces a corpse and the mission ends like it should. If I shoot the AI when it's in a full run, the mission ends, but the AI keeps running with no corpse. The AI is removed in all other aspects. I can no longer see it via ESP. Any thoughts on how I can track this down?
  4. I've verified that BE kicks the headless client after seven minutes every time.
  5. My headless client keeps getting kicked for publicvariable #0 "AntiHackNotRunning" = "AntiHackNotRunning". I've tried everything I know to do. The Battleye service is running, I've copied the DLL to the root directory with the client executable. I've added "battleyeLicense=1;" to the headless client profile. I've added the headless client as an admin for infistar. I'm out of ideas and not sure what to try next.
  6. How would you do this without the CBA addons? The CBA addons are taking me down a rabbit hole I don't want to follow. It's causing all kinds of issues with Infistar and version issues.
  7. It may make more sense if I post show the sequence of what I'm trying to do. I'm calling a script in the init.sqf that runs a query and I also run the query directly out of the init.sqf. They run fine and show in the arma2net logs. In the fn_selfActions.sqf script, this section will call a script called plotpole.sqf if someone is targeting a plotpole they own. if (_cursorTarget isKindOf "Plastic_Pole_EP1_DZ" && (getPlayerUID player) in _allowed && (speed player <= 1)) then { if (s_player_plotpole_dialog < 0) then { s_player_plotpole_dialog = player addAction ["Manage", "custom\plotpole.sqf", [_cursorTarget, _owner], 5, false]; }; } else { player removeAction s_player_plotpole_dialog; s_player_plotpole_dialog = -1; The plotpole.sqf file then calls the PlotPoleLoadLists script which is where I'm having the issues. private ["_plotpole", "_owner"]; CurrentPlotpole = (_this select 3) select 0; _owner = (_this select 3) select 1; createdialog "PlotPoleManager"; if (0 > 2) then { //_owner != getPlayerUID player ctrlEnable [4503, false]; ctrlEnable [4504, false]; }; call PlotPoleLoadLists; call PlotPoleMaintainInfo; private ["_owner","_nearby","_vars","_friends" ]; lbClear 4500; lbClear 4501; _nearby = player nearEntities ["CAManBase", 10]; PlotPoleNearbyList = []; { if (_x != player and _x isKindOf "Man" and !(_x isKindOf "zZombie_base")) then { PlotPoleNearbyList set [count PlotPoleNearbyList, [name _x, getPlayerUID _x]]; lbAdd [4500, format["%1", name _x]]; }; } forEach _nearby; _owner = [player, (getPlayerUID player)]; systemChat("Owner: " + (str _owner)); _friends = "Arma2Net.Unmanaged" callExtension "Arma2NETMySQLCommand ['dayz_overpoch_server_1', 'SELECT PlayerName, FriendUID FROM friend_data LIMIT 10']"; systemChat ("Friends: " + (str _friends)); _friends = call compile format["%1", _friends]; systemChat ("Friends: " + (str _friends)); { systemChat ("For Each: " + (str _x select 0)); lbAdd [4501, format["%1", (_x select 0)]]; } forEach _friends; Here's the arma2net logs 08/14/2014 19:18:20 Arma2NET 2.3.0.0 running on CLR 4.0.30319.1 08/14/2014 19:18:20 Loaded into process arma2oaserver 08/14/2014 19:18:20 Loading add-ins 08/14/2014 19:18:20 Domain Name Version Publisher Description 08/14/2014 19:18:20 DefaultDomain Arma2NETMySQL 0.1.0.0 firefly2442 Runs MySQL procedure commands. 08/14/2014 19:18:20 DefaultDomain Arma2NETMySQLCommand0.1.0.0 firefly2442 Runs raw MySQL/SQLite commands 08/14/2014 19:18:20 DefaultDomain Arma2NETMySQLCommandAsync0.1.0.0 firefly2442 Runs asynchronous raw MySQL/SQLite commands 08/14/2014 19:18:20 DefaultDomain ClrVersion 2.0.0.0 Scott_NZ Retrieves the version of the Common Language Runtime. 08/14/2014 19:18:20 DefaultDomain CompareVersion 2.0.0.0 Scott_NZ Compares two version strings and returns an integer indicating how they compare. 08/14/2014 19:18:20 DefaultDomain Version 2.0.0.0 Scott_NZ Returns the version of Arma2NET. 08/14/2014 19:18:20 DefaultDomain GetClipboardText 1.0.0.0 Scott_NZ Gets the clipboard text value. 08/14/2014 19:18:20 DefaultDomain SetClipboardText 1.0.0.0 Scott_NZ Sets the clipboard to a text value. 08/14/2014 19:18:20 DefaultDomain CommandLine 2.0.0.0 Scott_NZ Returns the command line used to start the application. 08/14/2014 19:18:20 DefaultDomain DateTime 2.0.0.0 Scott_NZ Returns the current date and time. 08/14/2014 19:18:20 Arma2NET initialized in 00:00:00.0546466 08/14/2014 19:18:21 function: Arma2NETMySQLCommand ['dayz_overpoch_server_1', 'SELECT PlayerName, FriendUID FROM friend_data LIMIT 3'] 08/14/2014 19:18:21 maxResultSize: 10239 08/14/2014 19:18:21 Result size: 38 08/14/2014 19:18:21 Result: [[["xxxxxx", "1234566789"]]] 08/14/2014 19:18:22 function: Arma2NETMySQLCommand ['dayz_overpoch_server_1', 'SELECT PlayerName, FriendUID FROM friend_data LIMIT 3'] 08/14/2014 19:18:22 maxResultSize: 10239 08/14/2014 19:18:22 Result size: 38 08/14/2014 19:18:22 Result: [[["xxxxxx", "123456789"]]] As you can see the two that are run from the init.sqf run, but there's nothing from the one in PlotPoleLoadLists.sqf.
  8. I have tried it inside an isServer, but it didn't work. I've used systemChat to print variables as it goes through the script and the variables come back null. I'm not clear on what you mean by it has to be called from inti.sqf. Are you saying the arm2netmysql plugin will only work if directly called from init.sqf? If so, I'm not sure how useful this would be then.
  9. I hope you guys can help me with this one. I can finally get the plugin to work if I either call a query directly from init.sqf or call another script from init.sqf, but I can't seem to get a query to run from another sqf script. Here's what I have in my init.sqf. if (isServer) then { _friends = "Arma2Net.Unmanaged" callExtension "Arma2NETMySQLCommand ['dayz_overpoch_server_1', 'SELECT PlayerName, FriendUID FROM friend_data LIMIT 3']"; [] execVM "ArmaNetTest.sqf"; <----points to the test script with the query. }; Both of those generate an event in the logs and shows the correct returned result set, but when I try and run the same query from another script, nothing happens. I don't see anything in the any of the server logs. Thanks in advance.