Jump to content
Sign in to follow this  
ebanks129

OA Pbo's for mapping

Recommended Posts

Has anyone tried un pbo'ing or de pbo'ing any of OA pbos to place objects on their map? I'm gettin an error message once i try to place an object when buldozer is running and it something about bad version in p3d? :confused:

does anyone think will we have to wait until tools are released for OA?

Share this post


Link to post
Share on other sites

of course... A2 buldozer does not know how to deal with v49 ODOL/LODO models from the A2OA content you are adding to your map.

However, you could rename your current Oxygen2 pointed to 'buldozer' to say 'buldozer.exe.0' and rename your 'P:\bin' folder to say 'P:\bin.0' and then copy the ArmA2OA.exe over to where Oxygen2 expects your buldozer.exe to live and rename it to buldozer.exe (better solution than altering the pathname in options).

Then you'd extract your A2OA bin.pbo and copy it over to your P:\ drive.

Now you should be able to launch buldozer to see your model/island. Same applies to V3. This works fine for O2 but haven't tried myself for V3. Sometimes the talking 'tween V3/O2 and buldozer.exe is out-of-order so to speak.

I haven't tried as yet, but probably binarize will not process references to them either. Just a guess at his stage though.

So, you're probably/possibly 'cack-out-of-luck' if you want to try and pump out an OA map until some new tools arrive on the scene.

The problem you will have most I think will be binarize... I might give it a bash sometime soon just to see.

PS. A2 & A2OA both use the same WRP file version. A2OA uses v49 ODOL's but will present earlier version fine as well. A2 or the A2 tools variant of buldozer can only understand up to v48 ODOL's.

Edited by Synide

Share this post


Link to post
Share on other sites

Actually, In the mean time till a new tools suite comes out you can use the A2 build tools (including binarize) to add Arrowhead buildings, structures & miscelaneous stuff from OA content to your islands.

Lets say you wanted to add \ca\structures_e\HouseK\House_K_1_EP1.p3d to your island.

Of course you should already have extracted structures_e.pbo to your P:\.

Find your .p3d you want to add, open it in a HexEditor and change the version of the odol from 49 back to 48.

Eg.

v49tov48.png

  • This will ONLY alter your extracted reference material from OA over on your 'P:\' drive development area.
  • This will allow the A2 binarize to process the reference to the OA object you are trying to add to your map.
  • So long as the original OA object is available to the map when you run it in game you won't have a problem.

This should be viewed as a stop-gap measure till you recieve some updated tools from BIS.

Cheers, Sy.

Edited by Synide

Share this post


Link to post
Share on other sites

Thanks synide for the tips, im having some major difficulties with my OA based terrain tho, i get errors upon launching OA that prevents it from launching, or then i get binarize.exe crashes...

the error looks like this:

Arma2 OA: No entry 'bin\config.bin/CfgInGameUI/MPTable.shadow'

then OK->

ArmA 2 OA: Error compiling pixel shader

then quits.. i find this very strange behaviour considering i've only added a map.. How have you set up your folders et cetera to prevent this? Also, what is the proper requiredAddon name for the OA objects, for examples structures_e.pbo

Share this post


Link to post
Share on other sites

for examples structures_e.pbo?

extractpbo.exe

then, look at the config.cpp.cfgPatches for the name they use.

pay particular attention to the $prefix$ it aint necessarily in the same pathways as arma2 ca

Share this post


Link to post
Share on other sites

Got it working again, not exactly sure what was wrong..

But bulldozer does not seem to be able to display hexed tree models properly, sometimes it just displays the shadow, other times i crashes.. what gives?

Edit: Nevermind, apparently you need to use the OA .exe and bin to view the tree models in visitor.

Edited by DigitalCenturion

Share this post


Link to post
Share on other sites

http://dev-heaven.net/projects/mikero-pbodll/files

ConvertP3D.exe AnyOA.p3d 48

reverts operation arrowhead p3d files to Arma2 type 48 for use in bulldozer

This is a FULL fix, not a patch from one signature to another.

There are no known differences between 48 (arma2) and 49 (oa), except for some very minor architectural re-arrangments. This re-arrangement, may have resulted in an improved speed or efficiency of the model, or it may not.

Regardless, the above exe creates a fully compatible p3d

Enjoy

---------- Post added at 02:41 AM ---------- Previous post was at 02:36 AM ----------

MoveObject.exe AnyOA.p3d From\Here To\There

revised exe corrects small issues with Arrowhead P3ds that have stagecounts so that it can be moved into any folder of choice

Share this post


Link to post
Share on other sites
of course... A2 buldozer does not know how to deal with v49 ODOL/LODO models from the A2OA content you are adding to your map.

However, you could rename your current Oxygen2 pointed to 'buldozer' to say 'buldozer.exe.0' and rename your 'P:\bin' folder to say 'P:\bin.0' and then copy the ArmA2OA.exe over to where Oxygen2 expects your buldozer.exe to live and rename it to buldozer.exe (better solution than altering the pathname in options).

Then you'd extract your A2OA bin.pbo and copy it over to your P:\ drive.

Now you should be able to launch buldozer to see your model/island. Same applies to V3. This works fine for O2 but haven't tried myself for V3. Sometimes the talking 'tween V3/O2 and buldozer.exe is out-of-order so to speak.

I´ve copied arma2oa.exe, renamed it to buldozer, copied oa´s bin folder to P:\ drive, but as soon as buldozer launches, it crashes up.

Undoing it and I can as usual load up my map.

Could anybody make visitor3 it work acording to the solution above?

Solved! Buldozer OA wont load without sat imagery loaded. Thanks guys!

Edited by stormridersp
solved

Share this post


Link to post
Share on other sites

Same problem I have ..... need a batch file to go through the main directory and all subdirectories, finding all p3ds and converting each.

Converting them 1 at a time I just can't bring myself to do .....

Share this post


Link to post
Share on other sites

run from the same place as convertp3d.exe

rem change OA v49 p3d Tag back to v48, so binarize can process them
dir /b /S p:\ca\*.p3d >listdir.txt

FOR /F "tokens=1* usebackq delims=" %%A in (listdir.txt) do (
convertp3d -48 "%%A"
if errorlevel 1 goto err
)
del listdir.txt
exit /b 0
:err
echo failed at v49->v48
pause
exit /b 1

Share this post


Link to post
Share on other sites

I'm still getting this message "The application has failed to start because its side-by-side configuration is incorrect"

Any help regarding this will be much appreciated.

Edited by Aplion

Share this post


Link to post
Share on other sites

ToraBora makes use of almost only OA objects. I converted all the OA objects (type 49 back to 48) to be able to see them in bulldozer. Furtermore i used the exe from OA, copied and renamed it to bulldozer and use it instead of the a2 one. Maybe this helps?

Share this post


Link to post
Share on other sites
ToraBora makes use of almost only OA objects. I converted all the OA objects (type 49 back to 48) to be able to see them in bulldozer. Furtermore i used the exe from OA, copied and renamed it to bulldozer and use it instead of the a2 one. Maybe this helps?

Thanks a lot for the tip mate, I'll give it a try ..

UPDATED ...

OK but ... I need either the p3ds either a way to make them compatible with A2 ... ToraBora island does not containing any p3d but just classnames ... so my problem is still the same as before.

Edited by Aplion

Share this post


Link to post
Share on other sites

Huh?

You ONLY convert the depbo'ed AO content in your working P drive.

You reference those converted models in VISITOR, and then your Terrain will work for everyone who has AO.

You dont need to transfer any models to your terrain project.

You only convert them so you can properly reference them in Visitor during the DESIGN phase of your project.

Share this post


Link to post
Share on other sites

Gnat, first of all thanks for reply ... to be completely clear, I'm not asking actually for any models ...

... as I said in my previous post, I'm facing problems with conversion procedure of those models in order, as you said, to have them properly referenced in Visitor during design phase ...

Edited by Aplion

Share this post


Link to post
Share on other sites

Aplion,

Chill's recommendation should work. I'm using OA objects, roads in my map without any problems. Just convert the stuff in your P:/CA folder to ODOL 48.

What exact error are you getting? Lots of people have converted the p3ds and they work fine in Visitor.

Tup

Share this post


Link to post
Share on other sites

Tupolov ... I'm getting this error message when I'm trying to convert the p3ds ... "The application has failed to start because its side-by-side configuration is incorrect" ...

So my problem is that I can't figured out the exact procedure for the conversion ... and that's I'm asking for.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×