Sign in to follow this  
Followers 0
maruk

ARMA II - Linux Server 1.04 Public Beta UPDATED

70 posts in this topic

An updated version of Linux beta server build 61018 is available now for download. Most important change is added support for http://www.battleye.com anticheat system.

We are pleased to announce that Arma II Linux Server 1.04 Public Beta is available now for download. We believe all major performance and stability problems are fixed now.

Please post your feedback to this thread.

Thank you again for your help with the testing of the Linux server platform for Arma II.

ArmA 2 - Linux Standalone Server 1.04

=====================================

Copyrigt © 2009 Bohemia Interactive Studio. All rights reserved.

For more information please visit

http://community.bistudio.com/wiki/ArmA:_Dedicated_Server

Installation instructions:

==========================

1. Following programs must have been installed on your Linux-box:

tar, gcc. Optional: md5sum (for setup integrity check)

1a. On some verions of Linux (this was reported for RedHat 9

and Gentoo linux 2.4.20) the NSCD deamon must be installed to

run ArmA 2 server successfully. Caching of DNS would be sufficient.

2. Copy the whole "ArmA 2" directory from Windows

to some Linux-directory (ArmA2). DON'T DO ANY DATA CONVERSIONS

(even "dos2unix" translation of text files is not necessary).

Example: you can use PKZIP (WinZip, PowerArchiver, etc.) on

Windows and "unzip" on Linux.

Don't use upper case letters in the ArmA2 directory name

(/home/bob/arma2 will be good, /home/bob/ArmA

may cause some troubles).

ArmA2 directory should contain subdirectories "Addons", "Bin",

"Campaigns", etc.

3. Copy the "server-x.xx.tar.gz" (x.xx is version number) file into

the ArmA2 directory. Unpack and install it with commands:

arma2$ tar -xjf server-x.xx.tar.bz2

arma2$ ./install

Watch the messages - they will inform you whether your installation

is successful.

4. Dedicated server can be started in foreground:

arma2$ ./server

Or in background:

o$ nohup ./server > out.txt 2> err.txt &

[1] <pid>

5. Running server can be stopped by executing:

$ kill -s SIGINT <pid>

Where <pid> is process-id of mother server thread (printed out in

"nohup" command).

6. ArmA2 server has a feature: command-line parameter

"-pid=<pid_file>". It causes creation of <pid_file> with

PID of root ArmA2 process. If IP port specified in "-port=<nn>"

parameter is busy (in usage), ArmA2 will terminate immediately

and <pid_file> won't be written..

7. The "arma2server" script is provided for automatic server

start/restart/status query/etc. Please be sure to edit

CONFIGURATION PARAMETERS in lines 12 to 18 !

After this is done, install (hard-link?) the script into

"/etc/rc.d/init.d/arma2server" file. After that it can be managed

by "chkconfig" (see info/man).

Edited by Maruk

Share this post


Link to post
Share on other sites

Nice, looking forward to putting our server up. Thank you for your continued (and outstanding) support of PC gaming.

Share this post


Link to post
Share on other sites

Hi!

Thx for this beta release :)

I've 1 question. Server running fine on my Ubuntu 9.10 Desktop,

but not on this same OS in a Vmware "computer"

When ./server : ./server doesn't exist

Tried after a new install.

Thx for help ;)

Share this post


Link to post
Share on other sites

hi^^, sorry for my bad english eheh, i have a problem :(.

When i start del linux server with no custom mission i'ts ok,but when i start the server with a custom mission (and i have edited the server.cfg ) the server run, but not load the map and the player see waiting for host.

Share this post


Link to post
Share on other sites

So far so good.

I'm seeing much better use of both cpus in our server.

32613 swec      18  -2  526m 490m  11m R 98.0 24.2   4:24.87 server
32606 swec      18  -2  526m 490m  11m R 96.3 24.2   5:45.26 server

That's excellent and did not happen in the alphas. :)

FPS seems to be remaining high for longer also but a bit early to tell.

Share this post


Link to post
Share on other sites
hi^^, sorry for my bad english eheh, i have a problem :(.

When i start del linux server with no custom mission i'ts ok,but when i start the server with a custom mission (and i have edited the server.cfg ) the server run, but not load the map and the player see waiting for host.

Same thing on my windows 2003 server. I think it's not a linux server problem only ;)

Share this post


Link to post
Share on other sites

Has anyone tried 'Arma II Linux Server 1.04 Public Beta' on FreeBSD's Linux Binary Compatibility mode?

Hope BIS would be able to release future Arma II dedicated server binaries for FreeBSD also.

Share this post


Link to post
Share on other sites

Since I have two running instances of ArmA II Servers (Linux 1.04 Public Alpha) i have a question. Is it possible to just copy the server and arma2server data in the existing Installation Folders and Overwrite the Files ?? I think this should work, because the install Process (tolower) is only renaming the Files and takes away the capital Letters..

Has anyone tried it this way ??

Greetz,

Share this post


Link to post
Share on other sites

That's Greate, thanks for your hardworking.

Could anybody tell me which beta version is well matched with the linux version, should i patch the latest beta before i install the linux version ?

Share this post


Link to post
Share on other sites

Hi, is that normal ?

vizjer:/home/arma2# ./arma2server start

Starting ArmA 2 server...

vizjer:/home/arma2# nohup: redirecting stderr to stdout

Share this post


Link to post
Share on other sites
Maciek;1496034']Hi' date=' is that normal ?

vizjer:/home/arma2# ./arma2server start

Starting ArmA 2 server...

vizjer:/home/arma2# nohup: redirecting stderr to stdout

An overlook in the arma2server script that doesn't redirect "nohup" error output to a file (nohup is used to keep the server running even after you log out).

Nothing serious

Share this post


Link to post
Share on other sites

One of cores work for 100% (it's decreasing FPS on server) and the rest is about 15%, I've got 4 cores (phenom II 940). I've beed trying irqbalance demon, (./server -cpucount=1 and with -cpucount=4) same result. Is it normal too ?

Does anyone notice difference between runing arma server in 32 bit and 64 bit linux ?

Sorry for my English :)

Share this post


Link to post
Share on other sites
~Steiner;1495988']Since I have two running instances of ArmA II Servers (Linux 1.04 Public Alpha) i have a question. Is it possible to just copy the server and arma2server data in the existing Installation Folders and Overwrite the Files ?? I think this should work' date=' because the install Process (tolower) is only renaming the Files and takes away the capital Letters..

Has anyone tried it this way ??

Greetz,[/quote']

it should work. Maybe better would be to create more than two ArmA2 Linux servers, thousand of them, flood the internet world with ArmA2 Linux Servers, give them a try ;)

Share this post


Link to post
Share on other sites
it should work. Maybe better would be to create more than two ArmA2 Linux servers, thousand of them, flood the internet world with ArmA2 Linux Servers, give them a try ;)

Thanxs for your fast reply @Bebul. If the Performance Tests will bring the results I´m hoping for, I´ll be the last who won´t bring up more than the two running Servers :bounce3:

Greetz,

Share this post


Link to post
Share on other sites

Can we know under which Linux distro BIS tested and originally "built" and "finalized" this dedicated version of the ArmA 2 Linux server bin? (ie. which is it known to best run under without too much excessive side tweaking - I presume BIS used a distro fairly "out of the box" Linux distro to build and test this? - What distro is the benchmark?)

Edited by Bob.Dob

Share this post


Link to post
Share on other sites

How about the rest of you Linux server admins then? Which distros have you been using for dedicated ArmA 2 server?

Share this post


Link to post
Share on other sites

Server FreeBSD

Linux Beta: v1.04.60159

+ ARMA2_Build_60588

AI in the game does not work.

Bots in the game are on the ground, motionless.

in the log server.

WATCHDOG (64372): [sat Nov 28 05:56:40 YEKT 2009] Starting server (port 2302)...

Cannot register unknown string STR_USRACT_ACTION_CONTEXT

5:56:48 Создан выделенный Ñервер.

5:56:49 Идентификатор Ñервера Ñоздан

ArmA 2 Console version 1.04 : port 2302 - Sockets

14:09:23 Игрок SER ÑоединÑетÑÑ.

14:09:27 Игрок SER приÑоединилÑÑ (id=499205).

Mission MP_WarWelcome.utes: Number of roles (16) is different from 'description.ext::Header::maxPlayer' (9)

14:11:03 Роли назначены.

14:11:03 Чтение заданиÑ...

14:11:05 Задание загружено.

14:11:51 Игра началаÑÑŒ.

ca\dubbing\global\radio\female03\cz\veli.wss: sSize 0

ca\dubbing\global\radio\female03\cz\numbers\one2.wss: sSize 0

ca\dubbing\global\radio\female03\cz\sesedat.wss: sSize 0

ca\dubbing\global\radio\female03\cz\report\presunnapozici.wss: sSize 0

ca\dubbing\global\radio\female03\cz\numbers\zero.wss: sSize 0

ca\dubbing\global\radio\female03\cz\numbers\two.wss: sSize 0

ca\dubbing\global\radio\female03\cz\numbers\eight.wss: sSize 0

ca\dubbing\global\radio\female03\cz\numbers\zero.wss: sSize 0

ca\dubbing\global\radio\female03\cz\numbers\zero.wss: sSize 0

ca\dubbing\global\radio\female03\cz\numbers\seven.wss: sSize 0

ca\dubbing\global\radio\female01\cz\veli.wss: sSize 0

ca\dubbing\global\radio\female01\cz\sesedat.wss: sSize 0

ca\dubbing\global\radio\female03\cz\slysisq.wss: sSize 0

ca\dubbing\global\radio\female03\cz\static\prijem01.wss: sSize 0

ca\dubbing\global\radio\female03\cz\numbers\two2.wss: sSize 0

ca\dubbing\global\radio\female03\cz\toschytal.wss: sSize 0

Server: Object 7:14 not found (message 121)

Server: Object 7:19 not found (message 121)

Server: Object 7:23 not found (message 121)

Server: Object 7:23 not found (message 93)

Server: Object 7:23 not found (message 67)

Server: Object 7:24 not found (message 86)

Server: Object 7:27 not found (message 121)

Server: Object 7:31 not found (message 121)

Server: Object 7:35 not found (message 121)

Duplicate weapon ItemMap detected for USMC_Soldier_TL

Duplicate weapon ItemCompass detected for USMC_Soldier_TL

Duplicate weapon ItemWatch detected for USMC_Soldier_TL

Duplicate weapon ItemRadio detected for USMC_Soldier_TL

Duplicate weapon ItemMap detected for USMC_Soldier_TL

Duplicate weapon ItemCompass detected for USMC_Soldier_TL

Duplicate weapon ItemWatch detected for USMC_Soldier_TL

Duplicate weapon ItemRadio detected for USMC_Soldier_TL

ca\dubbing\global\radio\female01\cz\nastoupit.wss: sSize 0

Server: Object 7:39 not found (message 121)

Server: Object 7:43 not found (message 121)

ca\dubbing\global\radio\female01\cz\sesedat.wss: sSize 0

ca\dubbing\global\radio\female01\cz\nastoupit.wss: sSize 0

ca\dubbing\global\radio\female01\cz\vystoupit.wss: sSize 0

Server: Object 7:48 not found (message 121)

Server: Object 7:50 not found (message 121)

Server: Object 7:51 not found (message 121)

Server: Object 7:52 not found (message 121)

Server: Object 7:52 not found (message 99)

Server: Object 7:53 not found (message 100)

Server: Object 7:53 not found (message 191)

Server: Object 7:52 not found (message 98)

Server: Object 7:52 not found (message 98)

Server: Object 7:52 not found (message 99)

Cannot create non-ai vehicle Misc_Cargo1Bo,

Cannot create non-ai vehicle Misc_Cargo1B,

Cannot create non-ai vehicle Misc_Cargo1B,

Cannot create non-ai vehicle Misc_Cargo1B,

Cannot create non-ai vehicle Misc_Cargo1Bo,

Cannot create non-ai vehicle Misc_Cargo1Bo,

Edited by Sergei_100

Share this post


Link to post
Share on other sites
How about the rest of you Linux server admins then? Which distros have you been using for dedicated ArmA 2 server?

[CiA] running the server on debian. no problem so far.

Share this post


Link to post
Share on other sites

Hi,

Running on Debian 4, 64bit with DualCore AMD4200+ CPU and 4 Gigs of Ram. I started two ArmA II Instances w/o any trouble so far.

Greetz,

Share this post


Link to post
Share on other sites

A) Keep the distros you're using coming guys! Will be interesting to see seeings how BIS doesn't seem to specify anything!

B) Is this server binary fully 64-bit OS ready or are are any of you guys running it on 32 bit for performance reasons?

Edited by Bob.Dob

Share this post


Link to post
Share on other sites
A) Keep the distros you're using coming guys! Will be interesting to see seeings how BIS doesn't seem to specify anything!
I've had it up and running fine on CentOS 5.4, both 32-bit and 64-bit variants.
C) Is this server binary fully 64-bit OS ready or are are any of you guys running it on 32 bit for performance reasons?
The server is a 32-bit application and runs fine on 64-bit Linux systems. In that regard, yes, it is "fully 64-bit OS ready". (It is not, however, a 64-bit binary, if that's what you meant.) Edited by Killswitch
punctuation

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0