Jump to content
Sign in to follow this  
delphiace

Having problem running Arma 2

Recommended Posts

When running ArmA 2 I get this message:

"The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86(32-bit) or x64(64-bit) version of the program, and then contact the software publisher."

1 errors during installation related to unable to install DirectX. I account that to already having that version installed on the system.

Purchased the game from Direct2Drive.

System:

CPU: i7 920 @ 2.67GHz

Ram: 6 gb

OS: Vista Ultimate SP2 (64-bit) (also same issue under windows 7 (64-bit)

Video ATI 4670 chip set w 512mb ram.

Thank you in advance!

Share this post


Link to post
Share on other sites

Is there a solution to this issue yet?

I upgraded to W7 64 bit yesterday, reinstalled ArmA 2, and am having this exact problem. Was running XP Home beforehand.

I will keep this post bumped until someone responds with a soultion or a link to a solution :/

I'm also using the D2D downloaded version.

Share this post


Link to post
Share on other sites

There were no install errors, and there is no registry issue.

I tried running in compatibility mode and still nothing worked.

I also e-mailed D2D to see if there was a known solution to this but no answer yet.

Share this post


Link to post
Share on other sites

Check in the registry. If the key is in HKLM->Software->Bohemia Interactive Studios->Arma 2, then the key is in the wrong place and that's what the issue is.

This is likely the cause because when the key is there Windows thinks it's a 64 bit application and will attempt to run it as one. When it fails at that it will bring up that error message. If the key is under the WoW64BitNode dir instead it should automatically run it in 32 bit mode (emulated)

---------- Post added at 03:08 PM ---------- Previous post was at 03:05 PM ----------

Oh, and for the directX installation problems, make sure you're installing the directX 9 Distrib, not the DirectX 10 distrib.

Share this post


Link to post
Share on other sites
Check in the registry. If the key is in HKLM->Software->Bohemia Interactive Studios->Arma 2, then the key is in the wrong place and that's what the issue is.

This is likely the cause because when the key is there Windows thinks it's a 64 bit application and will attempt to run it as one. When it fails at that it will bring up that error message. If the key is under the WoW64BitNode dir instead it should automatically run it in 32 bit mode (emulated)

.

It's under the "WoW6432Node" and still giving that message.

This is extremely frustrating.

I don't think the issue has anything at all to do with dx9. W7 has dx11 by default.

Share this post


Link to post
Share on other sites

Good to see you solved it in another thread.

One thing I'll note about Direct X. Some people have Direct X issues and I mention to install the latest direct X 9 even if using Vista or Windows 7 and usually get a response of "But Vista/7 uses DX10/11". Arma 2 doesn't use DX10 or 11, it uses 9, and as such if the 9 section of DirectX didn't install correctly under Windows Vista/7 or it's not up to date then it'll affect games that don't run Direct X 10 (like Arma 2 and many other games)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×