Sign in to follow this  
Followers 0
dwarden

Missing xAudio2 file(s) & sound issues

145 posts in this topic

Everyone receiving ARMA 2 crash or fail to start due to xaudio or x3daudio etc.

install the DX9 redist as admin! (this including VISTA and Seven users !)

June2010 (latest)

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=3b170b25-abab-4bc3-ae91-50ceb6d8fa8d

February2010 (latest for Windows XP SP2 and 2000)

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0cef8180-e94a-4f56-b157-5ab8109cb4f5

August2009

http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=04ac064b-00d1-474e-b7b1-442d8712d553

March2009 (older)

http://www.microsoft.com/downloads/details.aspx?FamilyID=0CF368E5-5CE1-4032-A207-C693D210F616

after extracting this file run dxsetup.exe ! (as admin)

note:

same DirectX folder is also included with both ARMA 2 Demo and ARMA 2 full on STEAM

STEAM\STEAMAPPS\COMMON\ARMA 2 DEMO\DirectX\DXsetup.exe

STEAM\STEAMAPPS\COMMON\ARMA 2 \DirectX\DXsetup.exe

-------

X-Fi owners make sure You get latest Creative Labs drivers from 26.6.2009 for WindowsXP or for Windows 7 from 16.6.2010

Audigy owners make sure You get latest Creative Labs drivers from 26.6.2009 or newer

Realtek owners make sure You get latest drivers 2.27 or newer

-------

HINT: TO prevent SOUND distortions please use AUDIO volume levels equal to default or lower !

HINT: TO prevent SOUND distortions please try disable X-Fi CMSS-3D/SVM !

-------

Note: there is no OpenAL in ARMA 2, period !

-------

Edited by Dwarden

Share this post


Link to post
Share on other sites

i load directx 9 redlist as administrater. well i have a directx10 windows vista and ive already loaded it but im still coming up with this error message This application has failed to start because x3dAudio1_6dll was not found :mad: note: im am trying to play the demo p.s. looks like a crazy game:yay:

Edited by wizbomb

Share this post


Link to post
Share on other sites

DX10 in Vista is not affected by this update,

VISTA have DX9+DX9EX and DX10

first make sure You have Vista Service Pack 2 (is now released for all languages)

then retry install of this DX9 march 2009 update

Share this post


Link to post
Share on other sites

Where do you extract the files too? I dont really understand the ArmA files or what?

EDIT: scratch that I am an idiot. Nevermind

Edited by IronCadian7

Share this post


Link to post
Share on other sites

also when ever the error comes up it says Arma2Demo.exe - Unable to locate component, i tryed your suggestion on the windows vist service pack but i already have it installed. Why wont it work? the file that is asking for i cant find is there a way i can download that particular one?

Edited by wizbomb

Share this post


Link to post
Share on other sites

You`re talking about just crashing? I ve got no crash,but just no sounds.At all. Checked out Direct x, drivers seem to be all right cause it works fine in another games. But sound won`t work in this game for me!( Did anybody have this problem?

Share this post


Link to post
Share on other sites

no we are talking about the game wont even start, just be happy you can play it :mad: its everything ive been looking for in a game

maby ill have better luck on the steam version on my other computer

Edited by wizbomb

Share this post


Link to post
Share on other sites

Is anybody getting random stuttering/static sounds while playing?

I'm running the game through an Asus Xonar Essence STX and I can pick up auditory anomalies quite easily with my headphones and it can ruin the atmosphere.

My most obvious example was when driving the tank in the boot-camp mission, the engine sound would cut in/out unless I was accelerating at some points.

Share this post


Link to post
Share on other sites

OMG I JUST GOT THE GAME TO WORK AND IT FRIGGIN' ROOOCKS!!!!!!!!!! but the demo doesent have everything i had wished for, if yall are wondering what you have to do is download directx9 redlist and where you downloaded it to you look for a file called directxsetup and boom ARMA2 WORKS! this game is so realistic

---------- Post added at 12:12 AM ---------- Previous post was at 12:11 AM ----------

Is anybody getting random stuttering/static sounds while playing?

I'm running the game through an Asus Xonar Essence STX and I can pick up auditory anomalies quite easily with my headphones and it can ruin the atmosphere.

My most obvious example was when driving the tank in the boot-camp mission, the engine sound would cut in/out unless I was accelerating at some points.

are you playing the demo?

Share this post


Link to post
Share on other sites

are you playing the demo?

Nope full version, updated to 1.02.

The sound stuffing up isn't a constant annoyance, it just happens sporadically.

Share this post


Link to post
Share on other sites

Wizbomb, you ve just download and set direct x, mean update?

Guys! Are there anybody who has no sound at all? it would be a big frustration to uninstall it without even 5min playing and enjoying(

Share this post


Link to post
Share on other sites

no i downloaded a file from mircrosoft and where i downloaded it to i found a file called DXsetup and it will start an installation, it might fix your problem

Edited by wizbomb

Share this post


Link to post
Share on other sites
Can I get a link to download directx 9 redlist?

it's the URL address in first post ...

Share this post


Link to post
Share on other sites

I cant download that setup to DXSETUP folder ( exactly it isn't folder ). If I run it to ARMA 2 DEMO folder, there appears bout 40 unextracted files.

Share this post


Link to post
Share on other sites

it's an archive (compressed with installer + it's files inside)

when you run directx_mar2009_redist.exe

it then ask on EULA, click then

then choose directory where it extracts to

then in that directory choose DXsetup.exe and run it as admin

Share this post


Link to post
Share on other sites
Is anybody getting random stuttering/static sounds while playing?

I'm running the game through an Asus Xonar Essence STX and I can pick up auditory anomalies quite easily with my headphones and it can ruin the atmosphere.

My most obvious example was when driving the tank in the boot-camp mission, the engine sound would cut in/out unless I was accelerating at some points.

Im using a Xonar D1 and sound is fine in SP.. but in MP it crackles and pops all the time. Sometimes it gets so bad that the directional sound becomes corrupted and sounds start coming from different directions.

I previously had a creative X-Fi card... and after reading about how this card and SLI gfx cards caused the popping/crackling i decided to get the Xonar..

needless to say im gutted that the issue remains with my new card.

that and the random CTDs has left me rather disappointed. I love the game and have been playing the series since OFP came out.. but its almost imposs to play online for me.

Share this post


Link to post
Share on other sites

Thanks to all helpers!!!!

Game is working. My mistake always was that when I hadran the mar_redist2009 thing, and to ARMA 2 folder began a lots of unextracted files, I deleted them and then ran DXSETUP. But then I tried to not delete those files and run DXSETUP and it works!!

THX.

EDIT: BTW my computer could easily run the whole game in Normal/High, Im talking of demo. Can my computer still run the whole game or does it even effect is it demo or whole game?

Share this post


Link to post
Share on other sites

i have another computer that id like to play this game on....its a duo core processor 2.8, witch i hear isnt the best thing but what if i have a good graphics card and a shit load of memory will it help because im upgrading it with two sticks of memory witch make a gig and another hard drive with about 360 gigs of memory so ill have two hardrives. will i be able to play this game at low or medium settings? i could turn down the resalution will that help because i think arma's the coolest game out there right now but but my computer sucks(to some degree) and i cant pay for a quad core because im only 13 ive got an allowance from cuttin grass but thats it

Edited by wizbomb

Share this post


Link to post
Share on other sites

Received the game today and will install shortly.

I notice in the read me for patch 1.02.58134 it says " DirectX 9 March 2009 is required and should be updated during the patching process automatically "

If I am doing a fresh install of the game and install the patch at the same time then I assume I don't need the March DirectX update as stated at the beginning of this post ??

cheers

Share this post


Link to post
Share on other sites
it's an archive (compressed with installer + it's files inside)

when you run directx_mar2009_redist.exe

it then ask on EULA, click then

then choose directory where it extracts to

then in that directory choose DXsetup.exe and run it as admin

And DXsetup.exe is where? The OP only states where it is for steam...

Share this post


Link to post
Share on other sites
And DXsetup.exe is where? The OP only states where it is for steam...

it's where you choose to extract these files to ...

as i wrote several times already ...

Share this post


Link to post
Share on other sites
... and after reading about how this card and SLI gfx cards caused the popping/crackling...

I had the crackling issue with my X-Fi card. I have FFDShow installed and the issue was linked to the FFDSHow Audio Codec. Excluding Arma2.exe from FFDShow fixed the sound issues for me.

Share this post


Link to post
Share on other sites
And DXsetup.exe is where? The OP only states where it is for steam...

  1. Download directx_mar2009_redist from the link on page one of this thread.
  2. Make a temp folder on your desktop, your documents or anywhere you like.
  3. Run the self extractor file and point the location to the temp folder you just created
  4. Open your temp folder and run the DXsetup as administrator

Share this post


Link to post
Share on other sites

Note: there is no OpenAL in ARMA 2, period !

hmm, why does the disk install it then?

does this mean it is safe for me to go to add/remove and uninstall this OpenAL rubbish?

I am trying everything here to stop my CTD's

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0