Sign in to follow this  
Followers 0
dwarden

NVIDIA video card(s) owners read here!

1537 posts in this topic

-1. DISABLE AMBIENT OCCLUSION in NVIDIA Driver Control panel !

0.

You shall try first NVIDIA 195.xx beta drivers or later ! Up to 12% performance increase in ARMA 2

1.

NVIDIA videocard owners with newer cards and drivers supporting PhysX when disabling PhysX acceleration:

* this works mainly for 260 and newer GPU serie resulting into performance boost for NVIDIA users in ARMA 2 , yet some 9800/8800 users experiencing smoother gameplay

A. Control Panels > NVIDIA PhysX control panel > Settings > switch to NO PHysx acceleration ! > click on "OK"

B. Right click on desktop > NVIDIA Control Panel > Set Physx configuration > Select "Disabled" > Click on "Apply"

2. SLI profile should be part of latest drivers ,

so following applies for old drivers only

2a.

NVIDIA SLI owners shall try use NVIDIA beta SLI profile ARMA 2 support for 186.18:

http://www.nvidia.co.uk/object/nvidia_sli_profile_patch_uk.html

Anyone who install nVidia's fix should deinstall/remove the EVGA fix before installing nVidia's, if its previously installed!

2b.

NVIDIA SLI owners can gain additional performance by using EVGA SLI enhancer

http://www.evga.com/articles/00463/Default.asp

more info and feedback about EVGA SLI enhancer here: http://forums.bistudio.com/showthread.php?t=76369

3.

VISTA (64b) users may get way faster/smoother framerate in windowed mode with 186.18 drivers

4a.

force VSYNC off in drivers

4b.

Alter RenderFramesAhead in ARMA2.cfg

5.

Try turn off Threaded Optimization in the nVidia control panel to resolve

crashes with "V-buffer creation error" & "Vertex Buffer out of memory" etc.

details in this post http://forums.bistudio.com/showpost.php?p=1614205&postcount=328

---

please when posting feedback into this thread add what driver version of PhysX and NVIDIA (both are standalone packages) You have

NOTE:

following should be fixed already in 1.05

on some OS (e.g. Vista64) with 4+> GB there is need to startup game with -winxp commandline paramater (arma2.exe -winxp)

or/and limit windows memory in startup paramaters to <4GB memory

this vary by driver builds and other system variables so please try first the commandline option

fixes and improvements are in work ...

Edited by Dwarden

Share this post


Link to post
Share on other sites

Yes, I can confirm that it works. I have a single nVIDIA GeForce GTX 280 and I tried disabling it in the nVIDIA Control Panel. Worked like a charm. My FPS increased by about 10 to 20 FPS.

Share this post


Link to post
Share on other sites

Turn PhysX off? For real?

:O

I'm in for a try though, so thanks..

Also DLed the SLI enhancement, will try that later too.

thanks again

***EDIT***

Have now DLed the SLI enhancement. This made Nvidea control panel recognize the ARMA2.exe (which i renamed again from Crysis64.exe to Arma2.exe). With standard settings I started playing, which seems to work very good for me.

have yet to try SLI settings + turn PhysX off

***EDIT***

Have now tried using SLI ---> works great (about 36-38 fps)

With physX off I find video goes a little bit less though.

Still keep crashing, though not so much anymore (in MP). When I do get an answer about the origin of error, it's always nvidea..... So hopefully THEY will provide new driver (newer than 186.xx) soon

Edited by JohnyFrosty

Share this post


Link to post
Share on other sites

GF8800GTX 768MB, turning PhysX off: 0 FPS more.

NV Driver: 186.18

PhysX: 9.09.0428

MfG Lee

Edited by Lee_H._Oswald

Share this post


Link to post
Share on other sites
GF8800GTX 768MB, turning PhysX off: 0 FPS more.

MfG Lee

please add you NVIDIA and PHYSX driver build, thanks

Share this post


Link to post
Share on other sites

NVIDIA System Information report created on: 06/28/2009 14:45:14

System name: TOASTER

[Display]

Processor: Intel® Core2 CPU 6420 @ 2.13GHz (2133 MHz)

Operating System: Windows Vista Home Premium, 32-bit (Service Pack 1)

DirectX version: 10.0

GPU processor: GeForce 8800 GTX

Driver version: 181.22

Stream processors: 128

Core clock: 552 MHz

Shader clock: 1331 MHz

Memory clock: 891 MHz (1782 MHz data rate)

Memory interface: 384-bit

Total available graphics memory: 2047 MB

Dedicated video memory: 768 MB

System video memory: 0 MB

Shared system memory: 1279 MB

Video BIOS version: 60.80.13.00.00

IRQ: 16

Bus: PCI Express x16

[Components]

nvCpl.cpl 2.2.360.00 NVIDIA Control Panel Applet

nvCplUI.exe 2.2.360.00 NVIDIA Control Panel

nvViTvS.dll 7.15.11.8122 NVIDIA Video and TV Server

NVMCTRAY.DLL 7.15.11.8122 NVIDIA Media Center Library

nvDispS.dll 7.15.11.8122 NVIDIA Display Server

NVCPL.DLL 7.15.11.8122 NVIDIA Compatible Windows Vista Display driver, Version 181.22

PhysX 909.00.10 NVIDIA PhysX

nvGameS.dll 7.15.11.8122 NVIDIA 3D Settings Server

No noticeable increase in FPS with PhysX off.

Share this post


Link to post
Share on other sites

adjusted sticky for less confusion

Share this post


Link to post
Share on other sites

WOW!

SLi works after downloading and installing the SLi Enhancement!

thanks Dwarden!

Share this post


Link to post
Share on other sites

Physx disabled = NO HELP, same laggy low fps.

-winxp parameter is not helping either.

I'm getting frustrated this tweaking, nothing has been helping so far. End users should not have to tweak their games to get them working. Especially if their rigs are better than optimal system requirements for the game.

[Display]

Processor: Intel® Core2 Quad CPU Q9450 @ 2.66GHz (2667 MHz)

Operating System: Windows Vista Home Premium, 64-bit (Service Pack 1)

DirectX version: 10.0

GPU processor: GeForce GTX 285

Driver version: 186.18

Stream processors: 240

Core clock: 680 MHz

Shader clock: 1476 MHz

Memory clock: 1250 MHz (2500 MHz data rate)

Memory interface: 512-bit

Total available graphics memory: 2815 MB

Dedicated video memory: 1024 MB

System video memory: 0 MB

Shared system memory: 1791 MB

Video BIOS version: 62.00.50.00.01

IRQ: 16

Bus: PCI Express x16

[Components]

nvCpl.cpl 2.5.383.06 NVIDIA Control Panel Applet

nvCplUI.exe 2.5.383.06 NVIDIA Control Panel

nvViTvS.dll 8.15.11.8618 NVIDIA Video and TV Server

NVSTVIEW.EXE 7.15.11.8618 NVIDIA GeForce 3D Vision

NVSTTEST.EXE 7.15.11.8618 NVIDIA 3D Vision Test Application

NVSTRES.DLL 7.15.11.8618 NVIDIA 3D Vision Module (4161853)

NVMCTRAY.DLL 8.15.11.8618 NVIDIA Media Center Library

nvDispS.dll 8.15.11.8618 NVIDIA Display Server

NVCPL.DLL 8.15.11.8618 NVIDIA Compatible Windows7 Display driver, Version 186.18

PhysX 909.04.28 NVIDIA PhysX

NVCUDA.DLL 8.15.11.8618 NVIDIA CUDA 2.2 driver

nvGameS.dll 8.15.11.8618 NVIDIA 3D Settings Server

Edited by silu-

Share this post


Link to post
Share on other sites

8800gt AMD 4800+ x2 2.4 MHz NVdrivers 186.18

No difference either way and tested with Fraps ArmAII-Mark

Share this post


Link to post
Share on other sites

Just wondering, would the GTX260 benefit from the SLI enhancer?

Share this post


Link to post
Share on other sites

I have GTX 295 and neither PhysX disabling helped nore using the SLI enhancment fix from EVGA. My problem still is, that Arma2 doesn't recognize my graphic card correctly with the latest nvidia drivers 186.18. In Arma2 menu there are only 2 options for TEXTURE DETAILS and GRAPHIC CARD MEMORY (LOW & NORMAL). The graphics inside game look horrible, no rendered textures, everythign looks like rabbish. There are missing options HIGH and ULTRAHIGH in graphic options menu, because the game can't allocate all the memory for the GTX-295 and recognize it as a high-end graphic card. Also tried to manually change values in arma2.cfg on this side but without success! I tried a lot, but still no success. That sucks!

Share this post


Link to post
Share on other sites

@ Sloop - You are setting your Arma2.cfg file localvram setting to what your card has in bytes right? 896 mb physical mem per core = 939524096 bytes

so you should have localvram = 939524096

or you could try double it to account for both cores maybe.

save the file

then make sure that you go to make it read only.

Weird thing happened for me, (i was locked to low/norm) after doing this it still wouldn't work, UNTIL I died in the campaign and then when I went to the video options from the death screen it let me change it.

Share this post


Link to post
Share on other sites

I already tried this pal, I entered exact these values you mentioned, and I write-protected afterwards the arma2.cfg file. But still no success! :( I'm frustraded dear BIS support ... please help!

Share this post


Link to post
Share on other sites

BI ADMIN

Turned physx's off no change

GPU driver : 186.18

Physx : 909.04.28

Share this post


Link to post
Share on other sites

hi,

I have

9800GTX+ 512 card

2GB 1066 Ram (ganged 128bit??? or I can ungange it to 64 bit??)

Gigabyte 750a SLi DS4 MOBO

Phenom 9950

Windows XP pro 32 bit

I have up to date drivers on both chipset and gfx card.

I have enabled Hybrid SLi in the bios setup with 256mb so the system mem is now 1.75gb

all I want to know is what diff is this gonna make as so far I cant see any?

will it be better to take off the SLi?

the game runs fine on std single card setup with no SLi on High to med settings and AA on norm but I want to try get a tad more?

Also I take it that IF i was to SLi 2 cards I would need a 9800 GTX+ and not just any 9800 card? or would a 9800GTX card do it?

I am confused

cheers in advance

billy

Share this post


Link to post
Share on other sites

GF8800GTX 768MB, turning PhysX off: 0 FPS more.

NV Driver: 186.18

PhysX: 9.09.0428

Guys at least we know BIS is trying to fix the problem... but I dont think its just Nvidia related... the game kills most CPU's... much more than it should for what it is... I mean the AI is not doing ground breaking stuff.

Yapa

Share this post


Link to post
Share on other sites

Cpu : E6850 @3.6 GHz (400 Mhz bus)

MEM :4 Gb DDR2 800 MHZ 3-3-3-10 (400 Mhz bus)

MB : X48 DQ6 Gygabyte

GPU = GTX 295 1.8 Gb vram

HD: 2x 2x Samsung 1 Terra 7200 Rpm 16 Mb cache (RAID 0)

OS : Vista 64 Ultimate sp1

Driver : 186.18

PhysX: 9.09.0428

Arma2 retail box European by 505 Games

Disabling physx: makes some improvement, a bit less stuttering. I get some Spykes up to 40fps But its spikes, not stable at all. i have between 15 to 26 fps all options set to normal . but still, to have enjoyable gameplay/fps i have to set options to (at these settings i get between 20-30 fps with some spikes to 40)

interface resolution 1680x1050

3d resolution 1680x1050

viewdistance : 3000 (i would lower it but its realy needed to fly)

Textures : LOW

Video Memory :Very High

Anisotropic : Normal

AA : normal

World Detail : Very low

Object : High

Shadow : Disabled

postprocessing Disabled

this are the only settings i can play without stuttering

one thing i can notice is the Fps drops alot when the camera is moving (ot turning but MOVING)

another thing i can notice at these settings is the GPUS are used to a max of 20%, my GPUs temp only increase by 2-3 degrees, while playing L4D it increase by 15-20° . cpu usage goes from 80% to 91%

since improved patch 1.02 i get random program termination/ return to desktop crashes after 20 minuts to an hour gameplay. The game doesnt render the sky on chernarus island unless i swap video memory option to anything and then back to very high.

good luck fixing this, koz i realy would like to enjoy arma2 as i did enjoy arma1.

One thing you might look into is wich retail game version people are using. it would not be the first time in game industry that a poor implementation of the securom protection by the editor will result in broken performance ingame

Edited by Ka-Oz

Share this post


Link to post
Share on other sites

Intel Core2 Duo, 2.66mhz

2gigs RAM

8800GT

WinXP

My machine suffers from a random occasional fatal video device driver crash. "Infinite Loop caused Thread stuck in Device Driver" type of a crash. The display adapter goes haywire and Win XP hangs and then shuts down to the desktop using a default video driver.

Otherwise, the frame rate is playable (but could probably be better).

Share this post


Link to post
Share on other sites

GTX 295 turning Physx Off didnt do anything, same exact FPS.

Share this post


Link to post
Share on other sites

GTX260 216 - Physics OFF - no FPS improvement

Rest of Rig

e6600 Oced @ 3Ghz (yes, i have tried with lower and stock clocks)

4GB DDR2 800Mhz CL4

2x320 HDDs SATA2 - ArmA2 not installed on the same Physical drive as OS

seems my graphic settings are there just for the fun of it, changing them around from High/Very High to Low/Very Low doesn't NOT increases my FPS

Share this post


Link to post
Share on other sites

Absolutely no fps difference with PhysX on/off, windowed or -winxp parameter. Tested in editor on Chernarus with player position in the middle of a forest (31fps with the blow settings). Framerate usually around 30fps (inside forests) or 50fps when on a field.

It would help the testing if we knew where exactly to watch for better fps. Inside a campaign mission, just in the editor, and if so, where? Middle of the forest, looking over an empty field or inside a town?

Intel Core2Quad @ 3.4GHz

NVIDIA GTX 260 (192 cores), 186.16, PhysX 909.04.28

4GB RAM

Windows 7 x64 RC (7100)

Settings: Texture Memory "Default", Textures "High", Anisotropic "Very High", Landscape detail "Low", Object Detail "High", Shadows "High", Postprocessing "High", Antialiasing "Off"

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0