Sign in to follow this  
Followers 0
rellikki

Texture quality sucks!

59 posts in this topic

How can I make better textures to my addons, like this, or this?

Always when I place some textures to my addons, they suck crazy_o.gifconfused_o.gif

I'm trying to use photoshop and everything but it seems that it doesn't help sad_o.gif

Share this post


Link to post
Share on other sites

some colours become pixelated for one reason or another but remember that bulldozer wont always mip map stuff correctly - try zooming in and out onto the newly textures area etc and it should become more hi res - dont take what you see in bulldozer as the gospel truth, it can be very deceiving smile_o.gif

Share this post


Link to post
Share on other sites

I created yesterday a concrete texture:

2048 x 2048 (576 pixels)

tga: 8.193kb

pac: (converted with textview): 1.366kb

*unfortunately i can't find any working link for pan-tool*

I then applied them both onto one of my buildings and guess

which did look sooo much better huh.gif

Yeah the tga one.

It's also a matter of the size of the texture window when

applying it in o2 (off course something what is only logical,

but should be mentioned in case you don't think on this).

But remind that it's also a matter of how many pixels a picture

contains - the more pixels per cm/inch, the higher the quality.

Picture size then again deals about how the dimension of the

picture is, when applying it onto a face.

plz correct me someone, if i spoke total crap now, but that's

how i understand and experienced it.

~S~ CD

Share this post


Link to post
Share on other sites

also remember to copy and paste your flashpoint cfg from your game into the bulldozer directory and overwrite the orignal one... the cfg contains what preferences you decided (texture viewing size, etc etc) and if its not set up correctly, your textures will always look crap tounge2.gif

Share this post


Link to post
Share on other sites

Yea textures in buldozer look very blurry but ingame they look very ok smile_o.gif

Share this post


Link to post
Share on other sites

Of all the conversion tools, O2 itself is giving me the best result, not that I consider it good sad_o.gif

i.e. take a TGA file and ask O2 to load it into a tex window, it converts it and you'll find the new coresponding PAA file in the DATA directory of O2. Unload the tex file, move the paa file from data to your addon directory, then load it again.

Of course this is old news to many of yous.

Share this post


Link to post
Share on other sites
Gnat @ June 25 2005,19:54)]Of all the conversion tools, O2 itself is giving me the best result, not that I consider it good sad_o.gif

i.e. take a TGA file and ask O2 to load it into a tex window, it converts it and you'll find the new coresponding PAA file in the DATA directory of O2. Unload the tex file, move the paa file from data to your addon directory, then load it again.

Of course this is old news to many of yous.

But to some it's not wink_o.gif

thx for that one Gnat,

o2 converted paa looks pretty much like the tga version

but same filesize like the textview converted pac smile_o.gif

~S~ CD

Share this post


Link to post
Share on other sites

I was including the paatool in my comparison ...... as I said, O2 gives the better result.

What I suspect but cant prove is that machine/PC setting and/or drivers affect the conversion quality of each of the available tools..... otherwise I can't explain why some people get better results than others.

Share this post


Link to post
Share on other sites

do what messiah said and it will probably solve your o2 blurry texture problems.

Share this post


Link to post
Share on other sites
do what messiah said and it will probably solve your o2 blurry texture problems.

Hmm... Oh yeah, it looks better than before wow_o.gif Thanks for all answers!! smile_o.gif

Share this post


Link to post
Share on other sites

Hate to bring up an old post, but I'm having similar issues with textures in O2. The conversion to paa/pac is fine. Loading up the auto-converted paa or pac in texview shows that the texture hasn't lost much in the way of quality.

However, O2 seems to refuse to use anything other than the 256^2 mip. Using a downsized 512^2 texture or saving it in its original 1024^2 size nets zero noticeable difference when loaded up in O2. This is making texture tweaking rather difficult for the finer details. Is there any way to up the mip level? And yes, O2 is using my default Flashpoint .cfg settings.

edit: To add, the mipping is actually working, as I can see the textures drop to a lower mip when I move the camera back; it just won't go past 256^2. huh.gif

Share this post


Link to post
Share on other sites

More often than not this happens with textures with alpha channels but sometimes with those without, a simple trick to get textures using the best mipping level is to ensure they mapped onto a 3 dimensional object and not a plane. You can do this any way you want but I sometimes hide a very small cube inside an object and map the texture onto it - works a charm.

Share this post


Link to post
Share on other sites

I've been having the same problem, too. I have tried everything that everyone has suggested in this thread, but nothing has worked. I've gone as far as to make a texture that is 4096x512, but it gives me the same results as a texture that is 1024x128. I have converted the texture using every tool available, including O2 itself. I have tried texturing a primitive along with the part I want to texture. I have copied the flashpoint.cfg file to the bulldozer directory several times. However, the texture remains blurry both in Bulldozer and in game.

-Pilot

Share this post


Link to post
Share on other sites

Well, my textures are currently mapped to a 3d object. And as I stated before, Bulldozer is currently using my Flashpoint cfg settings.

Not a huge deal for the time being, just rather annoying that I can't see fine details in the textures. Any alternative solutions?

Share this post


Link to post
Share on other sites
Quote[/b] ]Copy the flashpoint.cfg from your ofp root to your buldozer root.

Done, no change sad_o.gif

I'm thinking maybe the texture is cursed...that or the faces I am trying to texture crazy_o.gif

-Pilot

Share this post


Link to post
Share on other sites

@Student Pilot

I'm not really sure, but textures having high dimension aspect ratio (1024x128 means 8:1) may cause dedicated servers to crash.

Also, that might be a reason of your problems. Just try to resize it to 1024x512 and see what it looks like.

Share this post


Link to post
Share on other sites

Actually, its nothing much to do with the size of your texture..the answer lies with the dpi - dots per inch. If your dpi is 72 dots per inch, ingame from far the 72dots seems compact and small, no problem, beautiful, but when u get close to it and that pic expands full screen, you gonna see the size of the dots as blobs of colours, totally out.

Normal advertising prints in the printing industry asks for 300 dpi ratings. Ask your fave printer at printing shops or any graphic students and they will tell u 300dpi when blow up to poster size will look good and definately better than one at default 72 or 96dpi in most current graphic software.

However, do take note of the file size..the more dpi you have, the bigger your file size gonna be. Worse if you gonna give 1024 X 1024 and larger file!..You gonna crap out the game. Experiment and trade off what you can hide...thats the only way a real game developer would do it, he will never sacrifice game play for more than 40% art.

Share this post


Link to post
Share on other sites

Thanks for the info on dpi, that is something I never knew.  Another question, I have tried increasing the dpi, but my editing program won't change the dpi for tga files.  Is this a limitation of the tga file type or of my editing software?

-Pilot

EDIT:

I use GIMP for texture editing.

EDIT EDIT:

Oh hell, I think I just found out why the texture was blurry. My screen resolution is 1024x768 and I had OFP running at 2048x1024. I reduced the game resolution to my comp resolution and the textures look great. I don't think any of you can imagine how angry I am with myself...or how embarassed I am. That's been the problem for the past 6 months. banghead.gif Please accept my appologies as I put on my noob cap goodnight.gif

Share this post


Link to post
Share on other sites

but if you copied your flashpoint.config file to buldozer ..... why didnt you get the same resolution crazy_o.gif

Share this post


Link to post
Share on other sites

I'm afraid you're wrong on this one, phil. No texture formats (including PAA/PAC) carry information about optical resolution, because it's completely irrelevant, since textures formats are never used to print anything.

The analogous effect is achieved by a combination of texture dimensions and UV mapping parameters. The denser mapping is, the better optical resolution you're gonna get. However, this will never exceed 96dpi, which is the limit for most current day monitors, both CRT and LCD.

Anyway, good to hear the problem was solved. smile_o.gif

Share this post


Link to post
Share on other sites
@Student Pilot

I'm not really sure, but textures having high dimension aspect ratio (1024x128 means 8:1) may cause dedicated servers to crash.

correct - texture ratios MUST be lower than 8:1 otherwise the addon will fail to work on dedicated servers!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0