Sign in to follow this  
Followers 0
Bontee

Either I can connect, or everyone else can, not both.

2 posts in this topic

Hello all,

 

First of all, sorry if this is in the wrong place, wasn't sure if it should go here or in the troubleshooting section...

 

The issue I'm having is that if I host (dedicated server) on 127.0.0.1 (localhost) I can connect and everything works, but no one else can connect.

If I change the IP (in the launch parameters for the dedicated server) to my internal IP, my friends can join and play and it all works fine for them, but I get the error they normally get with the localhost option (Connecting Failed) and can not join.

 

Ports 2032 - 2035 are forwarded.

Using the Epoch mod (the only mod installed), which seems to be working fine when anyone connects.

 

Any ideas? I've been googling around all day and seem to be stuck... Any info anyone needs I can provide. :D

 

Thanks!

Share this post


Link to post
Share on other sites

your client and the server can not use the same ports if on the same machine

If they are different machines and you are hosting from your home network, then i would suspect your server is not configurred correctly on the router

Set the server up to run on non default ports and make sure the upnp box is ticked and read up on how to set a dedicated server up on the router you are using (They all have their idiosyncracies)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0