Skinniest

20 FPS and CPU/GPU (both) running on 30% ?

19 posts in this topic

Hey. So I have this problem.

I play arma with 65 addons intalled and with my friend which got a little worse PC than me.

I got fresh new Windows 10 (just intalled it)

Main problem is that I have 20-25 FPS at max. When something happens it drops to 9-15 FPS on this rig:

AMD FX 8350 8-core 4 ghz

GTX 1060 G1 Gaming 6G

16GB RAM DDR3

Motherboard: ASrock N68-GS4/USB3 FX

2TB HDD (Game is installed here tho)

120GB SSD (Windows 10 and some addons are here)

My friend which got a little worse GPU and CPU then me gets 30-40 FPS with same addons on same Own made server (hosted by me)

Best part is that I installed MSI afterburner and checked CPU and GPU usage. GPU: 20% to 50% (average 35%) CPU: 30% to 35% (average 31%)

I play on Custom details but most of details I have on Ultra

Render distance: 3000

Object: 1500

For Example when I put 2v2 squads with 6 members each and they start shoot, I have 15-18 FPS. My CPU is on 40% and GPU is 15% (Just tested it)

But on Takistan without AI (only me) I have 60 FPS O.o

I have newest drivers (I am using Geforce experience like everybody else)

I guess it is just arma but I can see a lot of people which have scenarios with even more AI, players, addons and any other good stuff and have solid 60 fps with similiar or even worse PC

I tryed to fix this by using NVIDIA controll panel like:

Maximum pre rendered frames 1
Power management mode Prefer Maxmum Power

Still nothing

 

List of addons:

JSRS Soundmod

EricJ Taliban Units

CBA

whole CUP

Whole NIArms

whole HLC

Complementary Police weapons

Complementary Police Equipments

Task_Force_Radio

US Military MOd

SPN Russian Spetznatz Weapons units and vehicles

Simple Single Player cheat menu

RM SWAT Uniform

Whole RHS

Bundeswehr

Immersion Cigs

RHS&RH&HLC compatibility patch

ACE

Personal Arsenal

ARES

Kunduz, Afghanistan

Huey Pack

BCOMBAT

VSM-Vests and Helmets

Theseus Services

TacticalBeards

RH M4

RH acc

Niko's USA Megapack

Niko's USA Megapack (Vests)

ASCZ Heads

ASDG Joint Rails

Blastcore

75th Ranger equipment

Ace and RHS compatibility patches

Also I have 64 bit Windows. When hit Play with my addon pack enabled it says that ACE and Task Force Radio are 32 bit only. My friend does not get this error. I tryed to reinstall whole addon pack but this issue still persist. I hit play anyway (64bit) and addons are working correctly O.o

 

Playing on servers like Altis life or ARMstalker is impossible. With 11 fps It is unplayable

Games like Witcher 3 on ultra with hairworks = 50 fps

Witcher 3 without hairworks = 80-100 fps

Share this post


Link to post
Share on other sites
6 minutes ago, Skinniest said:

I play arma with 65 addons intalled

THAT there is your problem! 

1 person likes this

Share this post


Link to post
Share on other sites

your cpu is garbage. only amd worth playing with is the new ryzen cpu. also dont compare arma to witcher, arma is a whole another 10 levels above any RPG game. sorry but it looks like you will have to buy a whole new CPU and motherboard if you really want to play arma. 

Share this post


Link to post
Share on other sites
1 minute ago, kremator said:

THAT there is your problem! 

I would disagree because I know people that plays with even more addons. For example Task force Roddenberry (CZ clan)

Share this post


Link to post
Share on other sites
2 minutes ago, veles-zv said:

your cpu is garbage. only amd worth playing with is the new ryzen cpu. also dont compare arma to witcher, arma is a whole another 10 levels above any RPG game. sorry but it looks like you will have to buy a whole new CPU and motherboard if you really want to play arma. 

I disagree. I have this processor more then year or so and I never had problem with it

Share this post


Link to post
Share on other sites
1 minute ago, Skinniest said:

I disagree. I have this processor more then year or so and I never had problem with it

you can disagree all your want but old AMD CPU which have very little single core performance does not do well and that just a repeatable fact.  search for yourself and again dont compare other games to arma, other games dont even come close to what arma can and has been doing for over a decade. 

1 person likes this

Share this post


Link to post
Share on other sites
On 7/3/2017 at 1:02 AM, veles-zv said:

you can disagree all your want but old AMD CPU which have very little single core performance does not do well and that just a repeatable fact.  search for yourself and again dont compare other games to arma, other games dont even come close to what arma can and has been doing for over a decade. 

Solo i have from 60 to 120 fps in cities 55-65 some places dip to 30s on AMD FX6300....I play KOTH 90+ players and thats where my CPU is the worst outside battle zones i have 45 fps in battle zones from 13 to 35 XD 

Share this post


Link to post
Share on other sites
On 5. 7. 2017 at 8:57 AM, Arson0207 said:

Solo i have from 60 to 120 fps in cities 55-65 some places dip to 30s on AMD FX6300....I play KOTH 90+ players and thats where my CPU is the worst outside battle zones i have 45 fps in battle zones from 13 to 35 XD 

Still better then me tho

Share this post


Link to post
Share on other sites
4 hours ago, Skinniest said:

Still better then me tho

My friends has same CPU like you and has same problem while i'm fine lol I have some addos for day Z uniforms and stuff but i never play it recently installed redux and have stable 30-55 fps  in Tanoa for some reason Tanoa is more stable for me than any other map 

Share this post


Link to post
Share on other sites
8 hours ago, Arson0207 said:

My friends has same CPU like you and has same problem while i'm fine lol I have some addos for day Z uniforms and stuff but i never play it recently installed redux and have stable 30-55 fps  in Tanoa for some reason Tanoa is more stable for me than any other map 

Well, That means Arma doesn't like my processor but you can't say that my CPU is shit. I have 230 games on steam +some games on origin, battlenet, uplay.

Cod IW - 80 fps on ultra while cpu is on 80%

Witcher 3 - As I said

GTA V - 40 on mega ULTRA (means I have everything enabled) while CPU is on 80%

 

Share this post


Link to post
Share on other sites

hm, you said that you host the mission and play it, right? Your friend who connects to you to join the game gets better frames? If that is the case, its probably because you are hosting AND playing at the same time. Your friend should get better frame rate since hosting is demanding.

Share this post


Link to post
Share on other sites

I use an AMD processor as well..an FX6350 6core is it as good as Intel..no..but it works fine and I can get 40+ Fps most places and its smooth..mine isn't as strong as yours is either..and I run an AMd Vid card RX460 so it isnt as good as yours is. The biggest thing I see is your render distance...I have mine at 2000 and 1500 respectively..I mean seriously unless your flying all the time you cant see that far or shoot that far anyway. Also if your hosting on your PC and having friends join that takes alot of Fps away from your set up. You really can't compare Arma to any other game..it has so much more going on it and the maps themselves are so much bigger its not a fair comparison. Dont expect too much as far as Fps goes..there are alot of tweaks you can do that will incrementally help your performance. You wont get an automatic boost but its a slow process to work through. Run the game on high priority,run Steam on low,dont stream at the same time,and cut back your view distance. check out youtube for a list of videos people have made with tweaks..some work..some don't..just always log what you did so you can change it back if needed.

 

As far as TaskForceRadio..check their page..there are 32 and 64 bit DLLs I run a 64 bit server and havent had any issues with TFR at all. I'd uninstall TFR..re-install and go step by step off of there webpage for 64bit install. Hope some of this helps.

 

 

Diesel

1 person likes this

Share this post


Link to post
Share on other sites

CPU usage doesn't matter because the game pushes most of the stuff through first core. If you see lower than 99% GPU usage you are limited by CPU, RAM and/or Hard drive speed because they can't push enough work for the GPU.

 

That's how this engine works. Don't compare your AMD FX results to anyone that has Intel in this game because it really can lack behind. Even dual core Intel Pentium can beat it when it is clocked the same.

 

Then about why you get lower fps than your friend with same specs and mods. Well you're hosting, maybe your hard drive is slower or fragmented, maybe your friend has more overclock, you have more programs running in the background or some bad anti virus that slows you down, he has set up lower video settings like view and object distances and detail, you have some broken mod etc.

 

Takistan isn't as heavy as Altis. Also if you have Takistan on SSD then that also makes some difference.

1 person likes this

Share this post


Link to post
Share on other sites
On 02/07/2017 at 11:59 PM, Skinniest said:

I disagree. I have this processor more then year or so and I never had problem with it

You've had it for a year, but others have had it since it came out in 2012. It's an old clunker by now. Your scattergun approach to choosing addons can't be helping either.

1 person likes this

Share this post


Link to post
Share on other sites

If I was running that many addons on my rig, it would also crawl.  You CAN'T need that many all of the time.  Either use THE Arma3 launcher or use a launcher tp pick the addons you need for a game.

1 person likes this

Share this post


Link to post
Share on other sites

CUP and RHS, in particular, overlap heavily. Many of those addons add a lot of content which is duplicated by others. If you can cut down on everything that's duplicated in RHS, then you won't lose much in terms of equipment that's available, but might eke out some extra performance.

 

At any rate, CPU is the culprit here. I don't see why content packs would cause much trouble in that area, but this CPU has too poor single thread performance to be much good in ArmA. Also, JSRS is CPU heavy, which compounds the issue. 30% usage means, on an octocore, two cores maxed out and one partially loaded. ArmA won't use all 8. Graphics are a result of that, with GPU simply not having that much to do. ArmA3 is absurdly CPU heavy, more so than any other game, including famous CPU hogs like Skyrim.

Share this post


Link to post
Share on other sites

 

Can someone explain me how this wizard made 40 FPS on Altis life with same procesor while I have incredible 12 fps on altis life ?

Share this post


Link to post
Share on other sites
19 hours ago, Skinniest said:

 

Can someone explain me how this wizard made 40 FPS on Altis life with same procesor while I have incredible 12 fps on altis life ?

Very low view and object view distances, 4,4GHz CPU and 1866MHz RAM and decent server is my bet.

2 people like this

Share this post


Link to post
Share on other sites
On 7/17/2017 at 5:01 AM, St. Jimmy said:

Very low view and object view distances, 4,4GHz CPU and 1866MHz RAM and decent server is my bet.

He also set his shadows off by setting Shadow Distance to 0. That makes the game look like shit. (circa 2003)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now