Jump to content
ACRE_Team

Advanced Combat Radio Environment 2 (ACRE2)

Recommended Posts

This imgur album I made a while ago shows some of the detail that the algorithm generates: http://imgur.com/a/P9BSn

 

Warning it is fairly old, and there was a bug at the time where reflections were not causing phase inversion.

 

Also this album might be interesting to some: http://imgur.com/a/9jETM

 

It shows fade over altitude differences.

  • Like 1

Share this post


Link to post
Share on other sites

[Cross-post from the ACRE2 issue tracker.]

 

I was having this same issue as well.

 

Summary:

Player A - Can transmit and receive over VON, can transmit but not receive (possibly?) over radio.

Player B - Can transmit and receive over VON, cannot transmit (possibly?) but can receive over radio.

 

It's unknown whether the problem lies with player A or B because it always failed in one direction. B transmitting to A.

 

Tested this in multiple missions. Tried with no ACRE modules as well as all modules enabled. Tried mission before adding ACRE2 and then re-saved the mission after adding ACRE2. Tried adjusting all "difficulty" options to remove all signal loss/interference/etc issues and still did not work.

 

Player B tested his radio from both very close range (<3m) and a medium distance (~50-100m). Tried with players facing each other and facing away. With one player facing and one facing away.

 

Ultimate solution was:

 

1) Tested between 2 players on a blank mission with only two stock NATO rifleman. Only mods loaded were CBA and ACRE2 (in that order). This resolved the issue.

2) Went back to the old mods (CBA, ACRE2, ACE3, RHS USF/AFRF, etc.) and made sure that all players and the server had identical mods in a 100% identical order. This resolved the issue.

 

My suggestion for those that are still having this issue is to try #1 and see if the problem is resolved. If so, likely something in your mission, mods, or mod order is the issue.

 

Share this post


Link to post
Share on other sites

I think that it's great that you moved to distributing this via Steam.

So you might want to add the URL in the first post:

https://steamcommunity.com/sharedfiles/filedetails/?id=751965892

BTW in the first post you mention "AI reveal now takes in account player current speaking volume", was this feature added by ACRE2 or an improvement of in-built feature?

Can you confirm that this feature works, even if the unit has no radio? e.g. with Iron Front Lite mod

Thanks for all your hard work.

Share this post


Link to post
Share on other sites

I heard that ACRE doesnt have "ts auto-channel move" feature. If  35 players  per side have special secret briefings on the map before launching the mission, then they must switch chanels manualy???

Share this post


Link to post
Share on other sites

I heard that ACRE doesnt have "ts auto-channel move" feature. If  35 players  per side have special secret briefings on the map before launching the mission, then they must switch chanels manualy???

There is no auto-move, no. Either move manually or simply don't have briefings on the briefing stage of loading. I am not sure why you are so surprised (???), it is not something we consider priority, it might come, but who knows.

Share this post


Link to post
Share on other sites

Hello to all, 

Me and my team was using acre in Arma 2 days, and everything was working perfectly. 
In Arma 3 we started using tfar i we did not have major problems.
Now, we want to use acre2, but we have problem with long range radios. We use long range radio a lot, for CAS and artillery missions.
So, we tested acre LR on Altis. I placed 2 helicopters on Molos airfieldand and we were using AN/PRC - 117F. We took off, and at distance of 2km we couldn't hear each other. We were on the same height, no physical obstacles between us. I did not use any modules, and did not change any settings. Everything was at acre defaults. We use cba, ace3, and rhs mods.

Do we need to place acre antena? Does acre antena have any functionalities at the moment?

Share this post


Link to post
Share on other sites

I have a problem with Exile Mod and ACRE 2. Can Help anyone?

 

It works but I can not use items such example Water Bottle

RPT Log:

14:59:23 !!!! WARNING ONEACHFRAME POSSIBLY REASSIGNED !!!! IT APPEARS THAT A ADDON OR MISSION HAS POSSIBLY FAILED TO CORRECTLY USE THE BIS STACKED EVENT HANDLER FUNCTIONS FOR ONEACHFRAME!

Share this post


Link to post
Share on other sites

I'd like to make a request that I'm sure you received many and many times...but I hope that you'll change your idea about what I'm writing...

 

As clan, we use ACRE from the beginning (from day 0 you released it for Arma3) and we're very happy about it.

I follow this thread (and the older one) and I've read your reply to people asked to remove the popup that notices a problem with the inventory system of Arma.

If I remember well, you always replied that it's needed because otherwise people start to complain to you about malfuntioning of radios.

 

I understand your position and I have to say that it's good to show this, hoping that people will complain Bohemia and not you but what I'm asking is to give us the opportunity to hide that popup after an amount of seconds (minutes) or using a button.

In this way you give me this information, I read it but I can play without that during the rest of the 2/3 hours missions.

 

Do you think it's possible to rethink your position like the way I proposed?

 

Thanks in advance for your reply.

  • Like 2

Share this post


Link to post
Share on other sites

I'd like to make a request that I'm sure you received many and many times...but I hope that you'll change your idea about what I'm writing...

 

As clan, we use ACRE from the beginning (from day 0 you released it for Arma3) and we're very happy about it.

I follow this thread (and the older one) and I've read your reply to people asked to remove the popup that notices a problem with the inventory system of Arma.

If I remember well, you always replied that it's needed because otherwise people start to complain to you about malfuntioning of radios.

 

I understand your position and I have to say that it's good to show this, hoping that people will complain Bohemia and not you but what I'm asking is to give us the opportunity to hide that popup after an amount of seconds (minutes) or using a button.

In this way you give me this information, I read it but I can play without that during the rest of the 2/3 hours missions.

 

Do you think it's possible to rethink your position like the way I proposed?

 

Thanks in advance for your reply.

:jump_clap:  :jump_clap:

Share this post


Link to post
Share on other sites

Hello there,

 

we are a gaming community and recently switched from TFAR to ACRE, which we essentially like better. 

I have a quick question regarding TS setup for this release. 

 

Some members (including me) have problems with volume settings, people are talking in normal volume in TS but you can hardly understand them ingame. This seems to be happening because ACRE ignores the TS's volume settings set by the client. -> My receiving volume in TS is set to +10, but ACRE seems to ignore it / sets it to +0 when ingame. 

 

 

The release notes (from 2 years ago) say 

  • TS3 individual set volumes are now applied to people speaking

but it does not seem to be the case anymore.

 

Is this the desired behaviour or are we missing something (except putting TS to max. volume in Win sound mixer etc.)? 

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Blop bloop.

Bleep bloop.

 

On teamspeak, go to settings - plugins - select acre 2- settings - you will have two cool bars to turn up and down, this overwrites the teamspeak volume, the affect only works in-game.

 

Individual volume for specific people can still be set by right clicking the name, and changing volume.

Share this post


Link to post
Share on other sites

this overwrites the teamspeak volume ...

The thing is, I don't want to overwrite the TS volume. The Pre-and Post-Mix bars (set to higher levels) cause the sound to clip, which is quite painful for my ears :/.

 

 

Individual volume for specific people can still be set by right clicking the name, and changing volume.

No, it cannot, as long we are ingame the individual settings seem to cause no effect. As I said, "This seems to be happening because ACRE ignores the TS's volume settings set by the client. ".

"-> My receiving volume in TS is set to +10, but ACRE seems to ignore it / sets it to +0 when ingame. "

Share this post


Link to post
Share on other sites

Turn down game sounds volume, increase TS volume. Solved ;)

Wysłane z mojego Moto G 2014 przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Turn down game sounds volume, increase TS volume. Solved ;)

I really appreciate your intention to help me, but it seems you don't understand my question.

 

I want to know if 

  • ACRE ignoring the TS settings

is

  • the desired behavior

or

  • if I'm missing something else that could fix the problem (e.g. a tickbox that I didn't see, which says "use Teamspeak³ sound settings", or an obvious parameter that needs to be changed, you get me); I'm not looking for a workaround.

 

Turning the game volume down and the system volume up seems more like a workaround with side effects that I don't necessarily want to experience.

 

Right now I'm assuming the problem is on the client side, not on ACREs side.

Share this post


Link to post
Share on other sites

3D talk is more fluid compared to 0-1 behaviour in TFAR. Thanks to this it's more realistic, you just have to get used to it if you never used ACRE2 before.

Also check your speaking volume in game, you have 5 levels of volume under CTRL+TAB.

Share this post


Link to post
Share on other sites

3D talk is more fluid compared to 0-1 behaviour in TFAR. Thanks to this it's more realistic, you just have to get used to it if you never used ACRE2 before.

Also check your speaking volume in game, you have 5 levels of volume under CTRL+TAB.

This is all very interesting but it still does not answer if ACREs behaviour is desired or not.

I really don't want to seem cocky but it seems you did not read my question.

Share this post


Link to post
Share on other sites

I am not entirely 100% on the sound stuff as I didn't write the code for it. But it's my understanding the TS system is somewhat overriden. My advice is to increase only the postmix volume in the plugin settings. For me personally the premix does add distortion but postmix doesn't this however seems to be unique to individuals' setups.

Share this post


Link to post
Share on other sites

Hey guys I'm not sure if this has been brought up prior to this but is it possible to add a function like tfr has where it will change.he your channel to the correct teamspeak channel?? (litrally the only reason my unit refrains from testing it to be put in use :(

Sent from my E6653 using Tapatalk

Share this post


Link to post
Share on other sites

Is there any instructions on how to enable the sound for the radio?  If I download it via Workshop,will it place the radio sound so that it works,or will I have to do that myself?

I tried ,but failed sadly.tnx

Share this post


Link to post
Share on other sites

Hey guys I'm not sure if this has been brought up prior to this but is it possible to add a function like tfr has where it will change.he your channel to the correct teamspeak channel?? (litrally the only reason my unit refrains from testing it to be put in use :(

It's on our list for sure, but we have no time frame when it might be implemented if ever.

Share this post


Link to post
Share on other sites

Does someone have a similar message in theit server rpt?

 

Error in expression <Type false)) exitWith { false };


if( !ACRE_AI_ENABLED && _var ) then {
[] call>
Error position: <ACRE_AI_ENABLED && _var ) then {
[] call>
Error Undefined variable in expression: acre_ai_enabled
File idi\clients\acre\addons\api\fnc_setRevealToAI.sqf, line 13

 

We don't use mission modules to configure ACRE, we use the following settings in the init.sqf of our missions:

[false, true] call acre_api_fnc_setupMission;
[true] call acre_api_fnc_setRevealToAi;
[0.25] call acre_api_fnc_setLossModelScale;
[false] call acre_api_fnc_setFullDuplex;
[false] call acre_api_fnc_setInterference;
[true] call acre_api_fnc_ignoreAntennaDirection;

["en","Englisch"] call acre_api_fnc_babelAddLanguageType;
["fr","Französisch"] call acre_api_fnc_babelAddLanguageType;
["ch","Chinesisch"] call acre_api_fnc_babelAddLanguageType;

Everything is working fine during the game, as far as we recognize it. But I discovered above error message.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×