Sign in to follow this  
Followers 0
Hoopenfaust

Low FPS on iMac 5K (no mods)

5 posts in this topic

1. No ultra settings available in video configuration (in game) to take advantage of GPU. 

2. No matter what setting I use, I'm only getting 11 fps - Even in the tutorial scenarios.

3. 1.54 was not like this  :(

4. I noticed most choices are not available in the dropdown menus.

 

iMac Specs:

 

I was on Yosemite with the same problem. Upgraded to El Capitan last night. Although my benchmark tests were much higher with El Capitan, I'm getting the same results.

 

iMac (Retina 5K, 27-inch, Late 2014) 

   

1 3.5 GHz Intel Core i5 CPU: 4-core

32 GB RAM

AMD Radeon R9 M290X - VRAM: 2048 MB

 

Any help would be appreciated.

Share this post


Link to post
Share on other sites

Just a quick update.

 

Dropped my in-game resolution to half of native 5k display and adjusted my viewing distances and now I've got something a lot better. A little blurry compared to native resolution but hey... it's a port.

 

I've also loaded a whole bunch of mods and that hasn't effected my FPS.

 

I also downgraded my version to 1.54 to test and I'm getting 2x the FPS with the exact settings as 1.58. WTF.

Share this post


Link to post
Share on other sites
On 19.8.2016 at 8:33 PM, Hoopenfaust said:

Just a quick update.

 

Dropped my in-game resolution to half of native 5k display and adjusted my viewing distances and now I've got something a lot better. A little blurry compared to native resolution but hey... it's a port.

 

I've also loaded a whole bunch of mods and that hasn't effected my FPS.

 

I also downgraded my version to 1.54 to test and I'm getting 2x the FPS with the exact settings as 1.58. WTF.

 

Might be a little late here, but here goes.

 

A. iMac is not very powerful machine and it only has mobile GPU

B. 5K gaming is practically impossible even on most high end PC's (Solitaire etc should run ok) :)

C. It's a port and Macs are not meant for "AAA-gaming"

 

 

Share this post


Link to post
Share on other sites

I used to run Arma 3 on bootcamp. I have the same iMac as you (5k late 2014 etc.) 

 

I could run it on ultra settings, above 1080p and I would get 90fps in open fields and in the cities/forest on Tanoa around 40fps. 

 

The OSX port when it first came out was awesome!, I got around 60fps but no stuttering and seemed to be pretty consistent even with complicated and full custom missions. So I know its not due to a weak computer. I just think they need to optimize. hopefully they don't give up because I don't run bootcamp anymore

 

Share this post


Link to post
Share on other sites

by the way I am getting like 20fps now will all the settings at the lowest and the resolution cut to 720p

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0