zonekiller

ZKs -=LOST SP=- Single Player Survival Mission (With Optional Base Building)

92 posts in this topic

On 19/02/2016 at 11:38 PM, zonekiller said:

Press 4 for him to use or find Vehicles.

Press 6 for him to get Items and Guns.
Press ~ to get them to Regroup or Stop.
Press F1 when they are close to you. < 3 meters, to access their inventory.

Now I am quite certain that these don't work. In Malden, without any of my TeamSwitch shenanigans, I recruit a unit, and the 4-6 keysopen the usual radio menus, whether the unit is selected with F2 or not. Same with F1, or "~", it acts as in a normal Arma3 mission without these extras. It would be simpler imho if these actions were in the radio menu, 0-9-4 is not that much slower to access that just 4, and messes less with the stock game keyboard menus.

Share this post


Link to post
Share on other sites
55 minutes ago, neofit said:

Now I am quite certain that these don't work. In Malden, without any of my TeamSwitch shenanigans, I recruit a unit, and the 4-6 keysopen the usual radio menus, whether the unit is selected with F2 or not. Same with F1, or "~", it acts as in a normal Arma3 mission without these extras. It would be simpler imho if these actions were in the radio menu, 0-9-4 is not that much slower to access that just 4, and messes less with the stock game keyboard menus.

I exclusively play the MP version but AI should work as it should in MP or SP.  You HAVE to select them first (F2 onwards) first of all before pressing 4 (veh menu), 6 (item menu) or 1,1 for return to formation.  Without AI selected (or multiple selections) then a lot of menus won't work (obviously 1,1 will for multiple AI)  I send My AI off hunting for items regularly (ESPECIALLY defibs !)

Share this post


Link to post
Share on other sites
7 hours ago, kremator said:

I exclusively play the MP version but AI should work as it should in MP or SP.  You HAVE to select them first (F2 onwards) first of all before pressing 4 (veh menu), 6 (item menu) or 1,1 for return to formation.  Without AI selected (or multiple selections) then a lot of menus won't work (obviously 1,1 will for multiple AI)  I send My AI off hunting for items regularly (ESPECIALLY defibs !)

Oh, then I guess I totally misunderstood the instructions. Of course I used the Fn-6-(0-0-0...) etc. commands to order them around, like I used from the OFP days to all the other missions in Arma 3, as well as all the other command menus. I mean how can you even play with AI team mates without using those? But since options 4 and 6 had had a special mention in the instructions, I imagined that these menus were completely modified for this mod :), but they are normal, with a bit of extra orange, and are working perfectly.

 

I guess a different wording would have been less confusing, something like "you can use extra options in the 4 and 6 command menus to tell the him to help you loot stuff, vehicles, guns, ammo, etc"

 

Now I wish there was an actual command to disable and enable their sentient behaviour. Most of the time I love it when they go looking for the most important stuff themselves, like guns, ammo, backpack, medical stuff... But then, even when they have 3 mags for their AK, right in the middle of the firefight they sometimes go "I'll go get me some ammo". Really? Sure I can keep yelling a -1-1 every time, but it would be better if I told them "look, from now on no initiative until I say otherwise", and then, when we get into town and kill the first defenders, "go on, have at it".

1 person likes this

Share this post


Link to post
Share on other sites

How am I supposed to receive mission rewards? (Playing the latest Malden version)

 

I needed to destroy a plane before it took off. Went to the NE airfield, RPG-ed the plane, got a "mission success" message, received another mission. Then I checked my inventory and didn't notice anything new there. Went to the wreck, thinking that maybe, like in the Exile mod, there would be a chest with stuff at the location, but no such luck. I'm not working for free :). So how is the rewarding process supposed to happen?

 

BTW, the RPG-ed plane turned into a rusted wreck after burning out, but I couldn't dismantle it. Same with a wrecked attack chopper by the airfield. Then the burnt out wreck of a light chopper that I had downed by the same airfield could be dismantled. I suppose it depends on the class?

Share this post


Link to post
Share on other sites

When you succeed at a mission, there is a box that spawns behind the vehicle.  Loot that.

 

Everybody should be able to dismantle wrecks.  Haven't seen the bug where I couldn't dismantle it.  Will look again.

Share this post


Link to post
Share on other sites
25 minutes ago, kremator said:

When you succeed at a mission, there is a box that spawns behind the vehicle.  Loot that.

Still can't find it. It was a huge C-192 plane, maybe the box was damaged by the primary or secondary explosions? Maybe in "[(position _myplane),(direction _myplane),10] spawn Mission_Reward;", the 10 is not enough for a plane this size?

 

25 minutes ago, kremator said:

Everybody should be able to dismantle wrecks.  Haven't seen the bug where I couldn't dismantle it.  Will look again.

I tried again and found a spot from where the dismantling worked. Or maybe it was because of the reload. Anyway, the burnt out wreck has been dismantled.

Share this post


Link to post
Share on other sites

Apparently I misinterpreted another line in the first post. I thought that a bedroll would allow one to sleep, e.g. pass the time. Without NVGs nor torches, what is one I supposed to do between 19 and 7, when it's pitch dark? Without the ability to "wait n hours" a SP scenario is not playable.

Share this post


Link to post
Share on other sites

Yeah the bedroll only helps to heal and lower thirst and hunger. When it is dark you keep yourself safe and wait it out. NV are found as mission rewards. 

 

 

Share this post


Link to post
Share on other sites
1 minute ago, kremator said:

When it is dark you keep yourself safe and wait it out.

That's not very fun in a solo game. I did a "SkipTime n" in the console, but it's not enabled by default, so a first-time player may not be able to do that.

Share this post


Link to post
Share on other sites

I figured out the problem with some wrecks not being dismantlable. It's not a wreck issue. I am having some insane "lag" with all the orange commands. Sometimes, when I hit the "holster weapon" command, it takes more than a minute to answer. But this one has no pre-requisites so it is is always displayed. But the ones like "Dismantle", "Repair", "create ammo for the vehicle" one, "Deactivate bomb", are a pita to use because of the lag. As if the game had a lot of other stuff to process in these routines, before he even starts to check the command availability. So it is easy to get to a wreck, not see the option to Dismantle, and not knowing that it will appear within a couple of minutes, go on your merry way thinking that the wreck is not Dismantlable.

 

As an example, just now, I got to a boat to repair it and had towait a couple of minutes for the Repair option to appear. Then like 30 secs for it to show me the "Checking parts status" hint, then once it was done, each repair and the refuel started without delay, as if the "pipe" had finally cleared. Then I jumped in, hit "Reload Weapon" and started moving between seats to see if either the commander or the rear gunner ones will show me the option to make ammo (I had all the mats in the inventory), a couple of minutes later I got the message that "No Weapon to Reload" because I probably was in the wrong position when the check was finally done, and yet no option to craft ammo.

 

Edit: Of course, reloading or even restarting the game does not help.

Share this post


Link to post
Share on other sites

Ouch that lag doesn't sound good.  Never encountered that in the MP version.

Share this post


Link to post
Share on other sites

Also, I can die, lie down while the rest of the AIs keep duking it out, the Esc key or any other don't react, then about a minute later it catches up with reality, the small "heart" icons instantly fills up with blue, and proper death with the "Load" menu finally arrives.

Share this post


Link to post
Share on other sites

@neofit  Not had the lag issue as of yet, what are your PC specs

Share this post


Link to post
Share on other sites
6 hours ago, zonekiller said:

@neofit  Not had the lag issue as of yet, what are your PC specs

i7 4790K, 16 GB RAM, 970 GTX, game run from an Evo 850 SSD.

 

But that's not relevant, the mission itself does not lag. Everything plays fine with good fps. The impression it gives is that there is some thread that manages all the mission specific orange commands, and that half the time this thread is busy with something, up to a couple of minutes sometimes. Then the pipes clear, and I can run a few of the orange commands one after the other, then again, the next one will take from 15s to like 2 minutes to be performed, or take that time to check the availability of an action on the current target. When in doubt, I ask for a "Shoulder weapon" since it's always present to see if the it's the orange thread that's unresponsive again or if the target is invalid.

 

Funny thing, the first time I noticed it, a few hours in, I was trying to repair a car. I hit "repair", nothing. I go to another spot on the car, "Repair", nothing. Another spot, "Repair", the command would briefly flash, and nothing. And so on. "Shame it doesn't work, I love Prowlers" thought I. Then a bit later, suddenly, I get a "Checking status"  hint (don't remember the actual text), and the damage values appear: "Engine x%, Wheels y%, Fuel z%, Engine x%, Wheels y%, Fuel z%, Engine x%, Wheels y%, Fuel z%, ...", about as many times as I had pressed "Repair" with no response.

Share this post


Link to post
Share on other sites

is the lag still there if you save and resume the mission

Share this post


Link to post
Share on other sites
32 minutes ago, zonekiller said:

is the lag still there if you save and resume the mission

 

20 hours ago, neofit said:

Edit: Of course, reloading or even restarting the game does not help.

 ;)

Share this post


Link to post
Share on other sites

I've restarted again, thinking that the VComm AI mod had done something. So without VComm AI, at the end of the first in-game day already I started feeling a few seconds lag between the "shoulder weapon" command and its execution. When removing a bomb in pitch black conditions at around 18:50, it took about 15 seconds for the command to be performed.

 

Worst of all was using the bed roll. You right-click on it, nothing. Then try again and again, and seconds later a few appear on the floor at once. So you pick them up and end up having 4 your inventory. Or drop one, wait patiently for it to appear, then try to pick it up. Nothing, so you try again and so on, then end up with a few in your inventory.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now