DnA

Release Candidate Branch Discussion

362 posts in this topic

When launched for the first time from SP Eden, 

"EachFrame" missionEventHandlers added during preInit are ignored.

class CfgFunctions { class a  { class b { class c {
                file = "preInit.sqf";
                preInit = 1; 
            }; }; }; };
diag_log text format ["[%1] Start Preinit]", diag_frameno];
addMissionEventHandler ["EachFrame", {
        diag_log text format ["[%1] EachFrame]", diag_frameno];
}];
diag_log text format ["[%1] End Preinit]", diag_frameno];

Yeilds just 

 

19:07:11 [29318] Start Preinit]

19:07:11 [29318] End Preinit]

But no EachFrame debug. MP does not seem to be effected.

1 person likes this

Share this post


Link to post
Share on other sites

Did anyone else lose the transparency on scopes in the developer version update that came out today (4-20-2016, San Diego, California time).  My RCO and a few other scopes have no transparency.  It's like trying to look through a brick wall.

-V

Share this post


Link to post
Share on other sites

Posted this over in the Dev Branch general discussion, but just in case I mentioned it here again: So far while replaying the unified campaign, I cam upon two missions that couldn't be finished:

Share this post


Link to post
Share on other sites

Movement bug: transitioning to crouch while primary-weapon-lowered-standing-idle will raise your weapon

 

And that 'forced prone while unarmed animation transitioning' bug hasn't entirely been squashed, it happens sometimes when transitioning from unarmed sprint to jog, while turning. It is very hard to reproduce

 

...And the rank symbol in the player's diary (press j) is always corporal no matter what rank you really are

Share this post


Link to post
Share on other sites

 

Posted this over in the Dev Branch general discussion, but just in case I mentioned it here again: So far while replaying the unified campaign, I cam upon two missions that couldn't be finished:

 

 

I can confirm the problem with Wet Work in which your two frogman squadmates thrash around in the water after spotting AAF on beach, and won't move at first.  After clearing the beach myself and going to chapel on hill north of Girna, at least one of them finally appeared next to me around time Get In Position task completed.  After doing most of the shooting myself, with help from Bravo squad, they seemed to stay on hill near chapel while I searched for high value target.  I then got into truck with Bravo, but frogman squadmates never did.  We drove away and mission ended normally.  I did a replay of Wet Work and did not revert to start of mission.  BTW, I had only one, count 'em, one, clip of ammo at mission start.

 

On a replay of Crossing Paths, everything was normal.  The mission started in total darkness, however, and I had a VERY tough time finding the backpack with the NVG.

 

----

 

On another note, I'm not sure I like the key color inversion thingy when you click on a mission in menu.  The key turns black when selected if mission has been completed:

 

485a0b484315458.jpg

 

which is a little confusing, since the key is active.  Perhaps it would be better if the key of a completed mission stayed white when selected.  You would still be able to see the white key given the gray ring around it, and the white bar indicates which mission is selected.

Share this post


Link to post
Share on other sites

Is it no longer possible to hide the overlay for the Splendid Camera in version 1.60.136052?

In 1.58.135742 and earlier versions it was possible to hide the overlay by pressing the H key. That no longer works in the current RC build.

Share this post


Link to post
Share on other sites

Is it no longer possible to hide the overlay for the Splendid Camera in version 1.60.136052?

In 1.58.135742 and earlier versions it was possible to hide the overlay by pressing the H key. That no longer works in the current RC build.

Press backspace

1 person likes this

Share this post


Link to post
Share on other sites

Is it known that remoteExec only accepts numbers in 1.60?

 

The following doesn't work anymore :

remoteExec ["some_function", _target];

 

 

Pretty damn annoying... :(

 

EDIT : remoteExec ["some_function", player] doesn't work either.

 

EDIT² : Nevermind, looks like you have to use the following syntax now, even if you don't need to pass any arguments :

[] remoteExec ["some_function", _target];

 

Share this post


Link to post
Share on other sites

Press backspace

Oh I've been wondering why the H doesn't work in dev branch for a long time. Then I just thought that they're soon removing 2D editor so maybe the camera also gets removed and never reported it :D

Share this post


Link to post
Share on other sites

Completed tasks during the mission as well as the first assigned task in the briefing screen are missing their title and description and is of a common occurrence.

 

Note that some tasks that are assigned during the mission also have their titles and description missing.

 

KCPmT8v.jpg

Share this post


Link to post
Share on other sites

Showcases: Scuba

Animation of dead have the age old arms out stretched when you hit the boat with an RPG.

Share this post


Link to post
Share on other sites

It is difficult to read the player names and scores of those playing as civilian on the scoreboard in version 1.60.136125 (17-05-2016) RC branch.

See this screenshot for reference.

Share this post


Link to post
Share on other sites

Minor issue I've noticed in RC 1.60:

 

The intro/splash-screens for all the official showcase missions (that appear just before the UAV rotation overview screen) are only visible on screen for a split second.

Giving us no time to view or read them. This has been happening for the last 1-2 weeks on Dev. The campaign missions don't seem to be affected.

 

E

Share this post


Link to post
Share on other sites

Ok I have a weird issue with the map. Replaying the campaign with the RC, and I notice that sometimes when I move the mouse around there seems to be an invisible "blocker" on the map somewhere in the lower half of the screen.

 

What I mean is, usually when you move the cursor on the map you get the red crosshair, but at one point it turns into the default arrow, and if I richt-click on that place I cannot drag the map around. It seems to be an invisible rectangular shape that is overlaying the map, and in that area the normal controls do not work, like there is another window over the map.

 

It *seems* to be related to the compass, like the compass display is  extending beyond the bounds of the model itself.

 

Also, the name of the mission I am currently at is "Bingo Fuel" (yeah that one :) ) but the map says "intro1", and in fact I think it said that for all of the missions so far.

1 person likes this

Share this post


Link to post
Share on other sites

@Alwarren : it is also in dev since a quite long time. I've not tried with last version.

 

--EDIT : in dev since the implementation of support for map-drawing

Share this post


Link to post
Share on other sites

@Alwarren : it is also in dev since a quite long time. I've not tried with last version.

 

--EDIT : in dev since the implementation of support for map-drawing

 

Thanks for the confirmation. I am running this one without any addons (well just FHQ CombatMode) and I was going nuts with it :)

Share this post


Link to post
Share on other sites

VERY NASTY BUG:
in command mode [del] you cannot command your people by number keys [1,2,3,4,5...] - everytime you mark your people (using F1, F2...) and clicking number [1,2,3...] it automaticly unmark teammates.
It really need to be fixed, today i spent 15 minuts by ordering team to get in 3 vehicles in desired seats.

Share this post


Link to post
Share on other sites

Thanks for the confirmation. I am running this one without any addons (well just FHQ CombatMode) and I was going nuts with it :)

Sounds like the same issue as I reported a few weeks back and have been following it up.

Related to the implementation of the new respawn screen (see my posts in the dev topic)

DarkDruid is looking into it. I've narrowed a rpro down to autosaving and then loading that autosave.

It occurs in all official showcase missions.

Share this post


Link to post
Share on other sites

A couple of movement bugs seem to be back on RC...

Transitioning to unarmed walk from unarmed jog while turning results in going prone

Transitioning to prone while unarmed sprinting results in talking a step to the left a bit

Transitioning to crouch while rifle-lowered standing results in weapon being raised

Transitioning to crouch from rifle-raised standing while turning results in weapon being lowered

1 person likes this

Share this post


Link to post
Share on other sites

A couple of movement bugs seem to be back on RC...

Transitioning to unarmed walk from unarmed jog while turning results in going prone

Transitioning to prone while unarmed sprinting results in talking a step to the left a bit

Transitioning to crouch while rifle-lowered standing results in weapon being raised

Transitioning to crouch from rifle-raised standing while turning results in weapon being lowered

Thank you, Arbiter

5 people like this

Share this post


Link to post
Share on other sites

Thank you, Arbiter

Uhm, no - I'm just a regular Minor. Can't you see my blue armour? XD

Share this post


Link to post
Share on other sites

Uhm, no - I'm just a regular Minor. Can't you see my blue armour? XD

NNNnneeeeeeeeerrrddddduuuh!!!.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now