DnA

Release Candidate Branch Discussion

362 posts in this topic

No worries.

 

There are four new actions available that allow for vehicle weapon switching, with each new action relating to a weapons group. These weapon groups exist as config parameters in the vehicle class and return an enumerated number value, which correlates to a specific weapon type or grouping of weapon types. The available weapon types and their values are as follows, defined in Arma 3's basic defines:

 

Hopefully this answers your question. :)

That explains how the weapons are grouped for the vehicle's control scheme, but what parameters does it use to determine whether a particular cfgWeapons class (or maybe it's the cfgMagazines class) belongs in WEAPONGROUP_CANNONS or WEAPONGROUP_MGUNS etc.?

Share this post


Link to post
Share on other sites

@Endstar

 

Thanks for the info about configuration on the vehicle side but could you also drop some info about the weapon configuration as da12thMonkey asked?

 

 

Why was this issue not addressed yet? 

Mapping controls binds Joystick and key

Such an anoying issue. Nobody needs a analog axis as a modifier key... Please fix it.

3 people like this

Share this post


Link to post
Share on other sites

The launcher crashes when I try to sort by players (descending) in the server browser. (current 1.56 RC)

Share this post


Link to post
Share on other sites

Am I the only one who founds the new font really ugly? What type of font it is? Personally I think Purista was much better, the new one is too big, bold and condensed and typography isn't good too, spaces between letters etc.

I was excited about new font, but this was not I was imagining.

 

http://imgur.com/a/4rmsZ - screens of arsenal with new and the old font

1 person likes this

Share this post


Link to post
Share on other sites

It does look a bit odd. But I give it one or two weeks and then I will get used to it.

 

@EndStar

Where do we define that a M134 is a "cannon" and a M260 Launcher is a Rocket Launcher?

 

How should we handle a often used "Safe" fire mode and put that one to maybe WeaponGroup 4?

 

Thanks

Share this post


Link to post
Share on other sites

Some info on how can we set new Eden categories and subcategories would be nice.

An example of how the class CfgEditorCategories and CfgEditorSubcategories work, would help a ton.

Share this post


Link to post
Share on other sites

Some info on how can we set new Eden categories and subcategories would be nice.

An example of how the class CfgEditorCategories and CfgEditorSubcategories work, would help a ton.

https://community.bistudio.com/wiki/Eden_Editor:_Object_Categorization

 

CfgEditorCategories and CfgEditorSubcategories classes merely contain displayname = "Some Text String"; parameter for the title that appears in the editor lists.

 

Whether a cfgVehicles class shows up in them, is dependant on setting the editorCategory = "Class from CfgCategories"; and editorSubcategory = "Class from CfgEditorSubcategories"; parameters for that vehicle.

 

According to the documentation above. If none is set, it will use the defined faction = "class from CfgFactionClasses"; in place of a category, and vehicleClass = "Class from CfgVehicleClasses"; in place of a subcategory; much like the old 2D editor.

1 person likes this

Share this post


Link to post
Share on other sites

Added: Geometric occluders

Excellent this when incorporated into models and with the new createObject commands could prove to be a great addition

 

My question is

Does this mean more Non Enterable buildings. They already confirmed that there is gonna be a lot of them in Apex. 

Share this post


Link to post
Share on other sites

Am I the only one who founds the new font really ugly? What type of font it is? Personally I think Purista was much better, the new one is too big, bold and condensed and typography isn't good too, spaces between letters etc.

I was excited about new font, but this was not I was imagining.

Is this something we can change? Because i agree that the old was best and easy to read.

Share this post


Link to post
Share on other sites

Game is currently crashing every like 3 minutes while in the 3D editor. here is the error: "The instruction at 0x0000000000EA5FB3 referred memory at 0x0000000000004F45. The memory could not be read." I'm also Windows 10 if that helps solve this at all.

Share this post


Link to post
Share on other sites

I agree with Evromalarkey. The font seems a bit.....off. I actually would prefer the old font to this. The only difference for me is that, now the font of the UI (and mouse wheel options) is smaller and much harder for me to read than it was. I have tried changing the UI size, but that was way overkill. I guess I will have to get used to it.

1 person likes this

Share this post


Link to post
Share on other sites

I can't currently use Game Updater to get RC Branch. Dev branch (and every other that doesn't require password) works fine. It says something about the password so something about the Steam likely? "ERROR! Timed out waiting for password check."

 

Just a funny coincidence that you just said in the SITREP you can use the game updater to get the RC branch but currently it somehow isn't possible (bugged) :rolleyes:

1 person likes this

Share this post


Link to post
Share on other sites

I can't currently use Game Updater to get RC Branch. Dev branch (and every other that doesn't require password) works fine. It says something about the password so something about the Steam likely? "ERROR! Timed out waiting for password check."

 

Just a funny coincidence that you just said in the SITREP you can use the game updater to get the RC branch but currently it somehow isn't possible (bugged) :rolleyes:

 

I couldn't manage to make it work neither. So i am waiting for the official release...

Share this post


Link to post
Share on other sites

I could be wrong, but as of the 100mb+ dl today on RC branch, my font appears to be bigger again. Now it is far more legible than it was.

Share this post


Link to post
Share on other sites

That explains how the weapons are grouped for the vehicle's control scheme, but what parameters does it use to determine whether a particular cfgWeapons class (or maybe it's the cfgMagazines class) belongs in WEAPONGROUP_CANNONS or WEAPONGROUP_MGUNS etc.?

Ah, yes!

So, the engine itself actually does all the heavy lifting and will automatically determine the weapon type based on the ammo simulation. However, there may be instances where this simply isn't enough, and so we added an override, which can be applied to the ammunition (CfgAmmo) using the config parameter weaponType:

class CfgAmmo
{
    class B_19mm_HE;
    class B_30mm_HE : B_19mm_HE     { weaponType = "cannon"; };

    class BulletBase;
    class B_30mm_AP : BulletBase     { weaponType = "cannon"; };
};

The weapon category strings are:

  • "cannon"
  • "mGun"
  • "rocket"
  • "missileAA"
  • "missileAT"
  • "missileAAAT"
  • "bomb"
  • "special"

Note: If the string is empty, the weapon category will be determined automatically by the engine.

Hope that helps!

4 people like this

Share this post


Link to post
Share on other sites

Yep. That clears it up very well. Thank you. Was confused when looking at the vanilla assets. I found the "weapontype", but it was always set to default.

 

Thanks a lot.

 

Best regards

Share this post


Link to post
Share on other sites

Hope that helps!

Massively. Thank you.

I really appreciate that there's a parameter to set it manually with weaponType, in addition to detecting it from the ammunition's simulation. Should provide a lot of flexibility.

Share this post


Link to post
Share on other sites

Hi there!
 
I'm having a few issues with modules on RC branch : I'm currently working on overhauling some of the modules from my Ravage mod, and noticed that one of them refuses to work with the 3d Editor (it's the vehicles module, if anyone wants to test).
Once placed on the map, default values aren't applied when checking the attributes - they are all set to "yes". Opening the attributes window a second time will set them to "no" and the module fails to register user-defined values.
No matter what, the module function won't initiate.
It is configured the same way as the other Ravage modules (wich seem to work with Eden); the odd thing is that it works without any problem on the 2d editor...
 
Is that a known issue?

EDIT : Not sure it's related, but it looks like vanilla modules are affected as well?

Btw, can anyone test out the poster module? I can't get it to work.


EDIT² : After further testing, it appears that module options based on BOOLEAN values (typeName = "BOOL" in the vehicle cfg) don't work with the EDEN editor.

1 person likes this

Share this post


Link to post
Share on other sites

Thanks for the detailed report, It helped me to quickly locate the issue. Fixing it now.

3 people like this

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now