soul_assassin

RHS Escalation (AFRF and USAF)

12696 posts in this topic

1 hour ago, da12thMonkey said:

I think it's one of the new ones from the Laws of War (Orange) DLC:- Gavras (GreekHead_A3_11).

 

@Redphoenix modelled a picatinny-railed dust cover for mounting optics. Those will be in RHS, additional to the original Sa vz. 58V and vz. 58P rifle models supplied by Elena Bolshevykh

Thanks.

Share this post


Link to post
Share on other sites
14 hours ago, reyhard said:

yup, child config would be safest thing here.

as for different crew - you need to to use gunnerType parameter inside turret config - see GREF configs for reference

Sorry, I should clarify - I'm aware I need to use a child config but I'm not sure what variable I need to change in order to hide the ATGMs.

 

For the gunnerType parameter - in the GREF configs I found gunnerType in rhsgref_cdf_t72ba_tv/Turrets/MainTurret/Turrets/ under CommanderMG and CommanderOptics, however under MainTurrets itself it appears to be empty. I'm unsure what to do because in my case I'm specifically trying to change the gunner unit in a BMP. Would I need to change the gunnerType variable of [BMP]/Turrets/MainTurret?

 

(edit)

I tried doing so and it seems that it just breaks the turret configuration because the other variables from the MainTurret class aren't preserved when I make a redefine it with the gunnerType I want.

Edited by Commie Pinko
More information

Share this post


Link to post
Share on other sites

Hi Folks,

 

The team on the RHS helpdesk stated they are having trouble seeing the problem I reported a few posts up - would someone be willing to try a couple of simple missions and see if you see the issue... We can start with the perpetually climbing Sea Cobra's and Apache's as that's the quickest and easiest to see... Just hop in and start the mission... The scripts build the waypoints (Move, Careless, flyinHeight 50)...

 

Make sure you don't have ACE or anything running...

 

The 3CB guys stated they fixed the issue on their Apache but didn't post what was fixed...

 

(3) Test Missions (Vanilla) ( RHS US Army) (RHS US Marines)

https://www.dropbox.com/s/zvte7go4mzwuagg/SCOHeloTestAltis.zip?dl=0

 

Radio Trigger India launches the gunships.

Radio Trigger Juliet issues an RTB for the gunships.

Radio Trigger Alpha launches the slicks on insertion mission.

 

The missions are identical except for the assets and you should see Vanilla is the only one that behaves properly...

 

Thanks...

 

Regards,

Scott

Share this post


Link to post
Share on other sites

HI Scott,

 

Could I ask, how are you observing the helis?  I ask because I have noticed an issue with my own mod (which doesn't include RHS assets); where if you go into spectator on a locally hosted server and view a heli with the "3PP Camera", then it climbs forever.  If you change it to free-view or use the splendid camera, then the heli stops climbing and resumes it's waypoints (Heisenberg in motion)!

 

It doesn't occur if you are client on dedi viewing helis with 3rd person spectator cam.

 

Anyway, it may be related/unrelated but I thought I'd mention it just in case.

 

Ta

Share this post


Link to post
Share on other sites
2 hours ago, das attorney said:

HI Scott,

 

Could I ask, how are you observing the helis?  I ask because I have noticed an issue with my own mod (which doesn't include RHS assets); where if you go into spectator on a locally hosted server and view a heli with the "3PP Camera", then it climbs forever.  If you change it to free-view or use the splendid camera, then the heli stops climbing and resumes it's waypoints (Heisenberg in motion)!

 

It doesn't occur if you are client on dedi viewing helis with 3rd person spectator cam.

 

Anyway, it may be related/unrelated but I thought I'd mention it just in case.

 

Ta

 

Hi...

 

Thanks for the interest - yeah - nothing fancy - I'm just sitting in the gunner positions on the gunships and letting the AI fly it... Usually in the external view while testing it but I switch back and forth - not using any spectator mode though...

 

Regards,
Scott

Share this post


Link to post
Share on other sites

Hi Scott,

 

I tried the ScriptTestVAN mission and the Blackfoot travelled to the waypoints at a height of approx 50m

 

I did try your ScriptTestRHSM mission and the AH1Z did fly to the waypoints but was gaining altitude all the time (up to 1000m by the third waypoint north of the combat zone).  The it circled seemingly endlessly while slowly losing height.  I presume the pilot knows that the heli is too high but cannot for whatever reason lose the height.

1 person likes this

Share this post


Link to post
Share on other sites
15 minutes ago, das attorney said:

Hi Scott,

 

I tried the ScriptTestVAN mission and the Blackfoot travelled to the waypoints at a height of approx 50m

 

I did try your ScriptTestRHSM mission and the AH1Z did fly to the waypoints but was gaining altitude all the time (up to 1000m by the third waypoint north of the combat zone).  The it circled seemingly endlessly while slowly losing height.  I presume the pilot knows that the heli is too high but cannot for whatever reason lose the height.

should be fixed in next patch then, maxSpeed affects that (it's ai only param - doesn't affect actual max speed for helis)

5 people like this

Share this post


Link to post
Share on other sites
33 minutes ago, reyhard said:

should be fixed in next patch then, maxSpeed affects that (it's ai only param - doesn't affect actual max speed for helis)

 

Scott mentioned that our 3CB Apache had the same issue which is true. He also said we had fixed it, but quite the opposite, we said we hadn't and had added it to our bug tracker.

However, I've just tried reyhard's suggestion and increased maxSpeed, and that does indeed fix it for us, thanks! So, I imagine it will for you guys too.

5 people like this

Share this post


Link to post
Share on other sites

Hi...

 

Sorry for any misunderstanding - I thought I had read someone in the Vehicles post stating they thought they had the solution... Appreciate the interest - one and all...

:thumb:

 

Not sure if the speed thing is causing this bit of strangeness ?

Quote

In addition - the slicks (MH-60's, and UH-1Y) seem to have a different issue... They seem easily confused at MOVE waypoints - randomly circle - arbitrarily  - bounce up and down when landing - attempt to drop off troops kilometers from any UNLOAD or TRANSPORT UNLOAD waypoints - although they do maintain proper altitude... Again tested the same assets against Vanilla MH-80, 3CB Merlin, 3CB, Wildcat, CUP SH-60 - which all behave normally without the issues...

 

Regards,

Scott

2 people like this

Share this post


Link to post
Share on other sites

TBH Scott, I think you went the right way about it :)

 

You made repros for RHS tracker and also contacted 3CB, and they all have noted what's going on and responded.  So job well done dude - nice catch .

 

Hope you guys at RHS/3CB don't mind me speaking out on this - I think it's nice when someone follows your bug-reporting procedures and it's proven to work.  <please pay attention random people who post in ADDONS COMPLETE saying "Your mod is broken.  I tried the T-90 and it would not kill the Abrams.  It's a showstopper/gamebreaker/breaks the immuuurrshun.  I will unsubscribe/sue you/ddos you/kill you in your sleep etc">

5 people like this

Share this post


Link to post
Share on other sites
9 hours ago, kilo-bravo said:

what does the svc drive do? 

 

Share this post


Link to post
Share on other sites

This option could use renaming to something like "running lights". Right now, it's hardly self-explanatory and there's no entry for it in the docs.

Share this post


Link to post
Share on other sites
3 hours ago, dragon01 said:

This option could use renaming to something like "running lights". Right now, it's hardly self-explanatory and there's no entry for it in the docs.

If you step into a HMMWV or LMTV right now and reach to turn on the lights, you'll find it marked "service drive." Service drive is the proper way to describe the headlights, at least for those US vehicles previously mentioned. It may not be readily apparent, but it is certainly accurate.

Share this post


Link to post
Share on other sites

Fine, but it's not something an average player will know. Not every RHS player rode a military truck at some point. It would have worked if this was placed on an obvious light switch in the interior (so that anyone who ever driven a car could make the connection, assuming it's set up in a similar way), but when using the action menu, this isn't exactly obvious.

Share this post


Link to post
Share on other sites
43 minutes ago, dragon01 said:

Fine, but it's not something an average player will know. Not every RHS player rode a military truck at some point. It would have worked if this was placed on an obvious light switch in the interior (so that anyone who ever driven a car could make the connection, assuming it's set up in a similar way), but when using the action menu, this isn't exactly obvious.

I already acknowledged that it isn't readily apparent. Given RHS is a mod, not the vanilla game, with an aim towards realistically representing the US and RusFed forces, however, I think it's perfectly acceptable. Additionally, the lights are still bound to the L key by default, no? Frankly it seems like a non issue, but to each his own I suppose.

1 person likes this

Share this post


Link to post
Share on other sites

Are they? I thought that "svc drive" (not "service"!) was a separate function. "Lights" in ArmA are usually the low beam headlights, I would expect running lights (when they're controllable at all) to be toggled separately. Given that the action menu doesn't actually "simulate" anything, as far as individual controls go, I think that a more descriptive name is in order. Following that philosophy, you could have Russian vehicles display their menu options in Russian when they correspond to a control.

Share this post


Link to post
Share on other sites

So, I don't knw if this has been brought up already, but I've been having a very bizarre issue with the S-8 rocket pods. When I fire them, the rockets will just fly off in random directions, to the point where they will exit the tube and turn 90 degrees away from the aircraft.

Share this post


Link to post
Share on other sites
47 minutes ago, Polyus said:

So, I don't knw if this has been brought up already, but I've been having a very bizarre issue with the S-8 rocket pods. When I fire them, the rockets will just fly off in random directions, to the point where they will exit the tube and turn 90 degrees away from the aircraft.

dev branch thing - dispersion was added in engine recently and we had some test values in configs included. it's fixed internally

1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, dragon01 said:

 Following that philosophy, you could have Russian vehicles display their menu options in Russian when they correspond to a control.

 

 

Must think in Russian!

 

 

6 people like this

Share this post


Link to post
Share on other sites
12 hours ago, da12thMonkey said:

 

 

Spent about about 15 minutes  turn it off and on again thinking it had something to do with  transmission or engine function and seen the lights as a bug or something. 

Share this post


Link to post
Share on other sites

Does the Duke system on the Mrap actually work? How does it work? Ive tried lowering it but every IED + Mine explodes

Share this post


Link to post
Share on other sites

Mirror from twitter; gif showing Dynamic Loadouts on the Mig-29:

 

8BuPoRS.gif

27 people like this

Share this post


Link to post
Share on other sites

Wow, wonderful. :) I'm really looking forward to the next release. Since Jets DLC I stopped using RHS due to multiple things being broken by the update, I can't wait to start using it again. :) 

1 person likes this

Share this post


Link to post
Share on other sites
16 hours ago, kerozen said:

Does the Duke system on the Mrap actually work? How does it work? Ive tried lowering it but every IED + Mine explodes

 

Imho it is not functional. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now