Jump to content

Recommended Posts

Hey Neo and Scruffy, how would you guys feel about me releasing some functional but not pretty versions of your Escapes to use the AGM and ACE medical systems? Because I know a lot of people love using those and that it was a bitch enough for us to try and stick it in, because it was so different to the vanilla system, and I'd hate for other people to do it if we've already done it.

Also, we've been toying around with a variant of the Takistan escape that we've dubbed "Darude" that might interest some people.

Share this post


Link to post
Share on other sites

Also we played this mission on friday, great fun, cant play today. Every killed soldier sinks into the ground and we see artillery markers on the ground where its gonna drop. Unplayable. We didnt change anything so I am wondering what is wrong since it was fine yesterday.

EDIT: it seems the problem was caused by that AISS2 AI mod, removing solved it.

Edited by main_cz
SOLVED

Share this post


Link to post
Share on other sites

So I have a new fun scripting problem for you Neo and Scruffy.

So I'm making an Iron Front version of Escape, and I've come across a fairly game breaking bit. So in Iron Front, Americans are Independent, Ruskies are Opfor, and Germans are Blufor, but we want to be 'Muricans fighting Germans, which introduces some problems.

There seems to be something in the guard script (it's probably in other scripts, but I don't know) that makes them hostile to Blufor, leading to them just shooting each other on mission startup. Do you know where I could find in the scripts whatever does this and change it from Blufor to independent?

Share this post


Link to post
Share on other sites
Hey Neo and Scruffy, how would you guys feel about me releasing some functional but not pretty versions of your Escapes to use the AGM and ACE medical systems? Because I know a lot of people love using those and that it was a bitch enough for us to try and stick it in, because it was so different to the vanilla system, and I'd hate for other people to do it if we've already done it.

Sounds good. Maybe sending the changes to me to be integrated into the next release will also be an acceptable solution for you? (Of course with proper credits).

So I have a new fun scripting problem for you Neo and Scruffy.

So I'm making an Iron Front version of Escape, and I've come across a fairly game breaking bit. So in Iron Front, Americans are Independent, Ruskies are Opfor, and Germans are Blufor, but we want to be 'Muricans fighting Germans, which introduces some problems.

There seems to be something in the guard script (it's probably in other scripts, but I don't know) that makes them hostile to Blufor, leading to them just shooting each other on mission startup. Do you know where I could find in the scripts whatever does this and change it from Blufor to independent?

The side is strongly tied to all of the scripts (a relic from the originalö A2 mission). Changing player side is not an easy task and nearly all scripts/functions has to be edited for that. I will see what I can do.

Share this post


Link to post
Share on other sites
Sounds good. Maybe sending the changes to me to be integrated into the next release will also be an acceptable solution for you? (Of course with proper credits).

It's a rather messy solution, so I'll try first to write up something more sophisticated and set it as a parameter so that it doesn't have to be a separate mission file like it currently is.

The side is strongly tied to all of the scripts (a relic from the originalö A2 mission). Changing player side is not an easy task and nearly all scripts/functions has to be edited for that. I will see what I can do.

Don't worry about it then, it'll be far easier for us to just write a gear swap script and have our GIs speak German.

Share this post


Link to post
Share on other sites

I'm having a problem where the mission adds crosshairs no matter what difficulty setting I am on or if I change the value server side - any thoughts on why this happens? Only on the escape missions.

Share this post


Link to post
Share on other sites
I'm having a problem where the mission adds crosshairs no matter what difficulty setting I am on or if I change the value server side - any thoughts on why this happens? Only on the escape missions.

I am quite sure that this is not a bug in the mission as me and my squad never play with crosshairs and such a problem would be the first thing we would fix.

Check your servers difficulty settings, remove crosshairs from every setting and make sure the mission is not started in Cadet.

Share this post


Link to post
Share on other sites

NeoArmageddon

Escape Altis RHS 1.7.3

Units\UnitClasses.sqf

245:if(!a3e_var_noNV) then {

must be

if(Param_NoNightvision==0) then {

And there is an error in 340:

3e_arr_InitGuardedLocations_Inf_INS = a3e_arr_Escape_InfantryTypes;

(the 1st letter "a" is missed).

RHS weapons (almost all) can't have all a3e_arr_Scopes. This code helps attach scope in most cases:

Scripts\Escape\Functions.sqf, instead of 107:

_scopes = A3E_arr_Scopes;
if(Param_NoNightvision==0) then {
_scopes = _scopes + A3E_arr_TWSScopes;
};
if(_nighttime) then {
_scopes = _scopes + A3E_arr_NightScopes;
};
_scope = _scopes select floor(random(count(_scopes)));
_this addPrimaryWeaponItem _scope;

this:

private["_i","_scope","_scopes"];
_scopes = A3E_arr_Scopes;
if(Param_NoNightvision==0) then {
_scopes = _scopes + A3E_arr_TWSScopes;
};
if(_nighttime) then {
_scopes = _scopes + A3E_arr_NightScopes;
};
_i=0;
while {_i < 10} do {
_scope = _scopes select floor(random(count(_scopes)));
_this addPrimaryWeaponItem _scope;
if(_scope in (primaryWeaponItems _this)) then {
	_i = 10;
};
_i=_i+1;
};

It could be better (e.g. check weapon item class before attach), but this was the 1st in my head. Also the other attachments code can be edited.

Almost a half of RHS weapons can't have a scope at all. That's why I recommend to increase the scope probablity (106: "if((random 100 < 60))" instead of "30").

  • Like 1

Share this post


Link to post
Share on other sites

With the most recent Arma 3 patch earlier this month my friends and myself have been having a crash issue.

If any of us host the map, and then start the game up. Everybody excluding the host will crash to desktop, and it ONLY Does it with the escape maps. Any map, whether it's altis, or sahrani, will crash to desktop as soon as the game starts.

Is anybody else having this issue???

Share this post


Link to post
Share on other sites
With the most recent Arma 3 patch earlier this month my friends and myself have been having a crash issue.

If any of us host the map, and then start the game up. Everybody excluding the host will crash to desktop, and it ONLY Does it with the escape maps. Any map, whether it's altis, or sahrani, will crash to desktop as soon as the game starts.

Is anybody else having this issue???

More infos please: RPT and used mods for example.

Share this post


Link to post
Share on other sites

Me and four friends in the +35 category play this mission. We absolutely love it. But the AI skill thing is bit of a game breaker for us.

We do have our own rented server and are playing on that one. Is there a way that we can decrease the skill on the AI?

We are not as quick as we used to be. :)

Share this post


Link to post
Share on other sites
Me and four friends in the +35 category play this mission. We absolutely love it. But the AI skill thing is bit of a game breaker for us.

We do have our own rented server and are playing on that one. Is there a way that we can decrease the skill on the AI?

We are not as quick as we used to be. :)

Maybe you could try Robalo's ASR AI3 mod?

Share this post


Link to post
Share on other sites
Me and four friends in the +35 category play this mission. We absolutely love it. But the AI skill thing is bit of a game breaker for us.

We do have our own rented server and are playing on that one. Is there a way that we can decrease the skill on the AI?

We are not as quick as we used to be. :)

It will just default to the servers AI difficulty, change AI skill in difficulty on host client if using listed server, or if dedicated add aiLevelPreset=X; (X can be 0, 1, 2 or 3. 0 easier ai and 3 lets you add more commands to customize your AI, more info: http://forums.bistudio.com/showthread.php?169122-AI-Configuration-feedback&p=2639166&viewfull=1#post2639166 ) to your server config.

Also I highly recommend using ASR AI, it micromanages the AI in firefight and movements without messing with escapes "commander script". Giving you more interesting engagements.

What we use:

class Regular

{

class Flags

{

3rdPersonView=0;

armor=0;

autoAim=0;

autoGuideAT=0;

autoSpot=0;

cameraShake=1;

clockIndicator=0;

deathMessages=1;

enemyTag=0;

friendlyTag=1;

hud=1;

hudGroupInfo=1;

hudPerm=1;

hudWp=0;

hudWpPerm=0;

map=0;

netStats=1;

tracers=0;

ultraAI=0;

unlimitedSaves=1;

vonID=1;

weaponCursor=1;

ExtendetInfoType=1;

MineTag=1;

};

aiLevelPreset=0;

};

Share this post


Link to post
Share on other sites
More infos please: RPT and used mods for example.

Vanilla version of escape. We've done it with mods enabled, and also no mods enabled. It still crashes.

Has nobody else had this issue?

We've tried it with 3 different people hosting and still have had this crash issue.

Share this post


Link to post
Share on other sites
Vanilla version of escape. We've done it with mods enabled, and also no mods enabled. It still crashes.

Has nobody else had this issue?

We've tried it with 3 different people hosting and still have had this crash issue.

With RPT he means https://community.bistudio.com/wiki/arma.RPT a log file that lets him read what went wrong(hopefully). He suffers from being to familiar with arma stuffs and isn't used to ppl not knowing the lingo. :)

Share this post


Link to post
Share on other sites

how can i disable the new inconscious camera? I much prefered the old way. The idea is nice, but the execution is really lacking.

I don't like the top-down view, it makes me nauseous, and it really limits what you can see. Not to mention that when playing in nighttime the black text has no contrast so you can't see what's written on the screen. Also there's no night vision, so it's basically just a black screen. Which honestly is HUGELY annoying.

But whatever all of these I could just ignore by alt tabbing. But there is one huge thing that I can not ignore. I CAN NOT USE SPLENDIT CAMERA. infact, I can hardly use the menu at all. I need to repeatedly press esc hoping it would work, and it mostly doesn't.

And did I mention it makes me queasy? No idea why. But it does.

Share this post


Link to post
Share on other sites

Has anyone had success running the mission with v0.3.8 of RHS?

I continuously get mission uses deleted content rhsusf_c_troops. When I switch the server to v0.3.7 it appears to work correctly, even if the clients are using v0.3.8.

Share this post


Link to post
Share on other sites

Hey.

So I don't know if this is possible, or if you can be bothered to help me with this, but we''re struggling with the way enemies are spawned. Right now it's just a continuous stream of enemies, and if we stay in one point for a while (like capturing an objective) and even if we clear the surrounding area new units just spawn behind our backs. Because enemy AI units keep spawning indefinitely it is impossible to lock an area down and properly prepare for an assault.

The only way right now to assault a big objective way is to try and sneak up to it, hoping the enemies will not spot you, because clearing the immediate area is not possible. (new units just spawn in and start patroling the area, so it's just a question of 5-10 minutes before a new patrol will come and get alerted)

A real example of this happened to us recently: we cleared a big area in stratis, around a comms base and a ammo depot (they were fairly close) and were going to assault the comms base, and then we actually saw the enemy units spawn. We were on a hill overlooking a comms outpost, and we literally saw units spawning behind our backs, obviously they started running towards us. Tons of them. So they forced our hand into attacking ill prepared and we died.

So I've been thinking. I don't know arma code enough, but if there are if statements, could I somehow make the enemy AI not spawn if we are stationary? I know it's not a really good solution, but it would be a "good enough" workaround. I've posted about my idea for a more complete solution, but that'd obviously require more work.

What I'd like to do would be something like this in pseudo code: if player units do not move from a 1kmx1km area do not spawn new ai units.

(even better would be if player units do not move from a 1kmx1km area for 30 minutes stop spawning units for 20 minutes, that way the enemy units would have a "response time")

I am hoping this might be easy enough. Or another way I've thought it might work, but much worse, if the first one is not possible, would be: run script for ai spawning only every 20 minutes

Thanks for your reply in advance!

Share this post


Link to post
Share on other sites

I was wondering if you would be able to tell me how to turn off the mission from handling the weather AT ALL. I am attempting to implement my own weather and sound and the mission keeps overriding it. I'm sure this is much more of a complicated answer than you want to give as I have dived into all of the files and have found multiple areas pertaining to weather and what not.

Essentially - I adding some sound files, a few functions, and some lines to the init and description.

Any thoughts you might have that would help me do this would be great.

Share this post


Link to post
Share on other sites
I was wondering if you would be able to tell me how to turn off the mission from handling the weather AT ALL. I am attempting to implement my own weather and sound and the mission keeps overriding it. I'm sure this is much more of a complicated answer than you want to give as I have dived into all of the files and have found multiple areas pertaining to weather and what not.

Essentially - I adding some sound files, a few functions, and some lines to the init and description.

Any thoughts you might have that would help me do this would be great.

That's also a good question, that I'd love to know the answer to. We are having some serious weather desync issues. Out of like 5 players on our dedi server not 2 had the same weather conditions. I've tried just deleting tort's script but that broke everything.

Another thing I am struggling with is adding backpacks. It doesn't seem to work as expected. Firstly there's 4 fieldpacks (fieldbag?) backpacks in 3 ammoboxes, but there is NO mention of it's classname ANYWHERE in the mission .pbo file. So they get added without being called. I've no idea why. Maybe something to do with this table:

https://community.bistudio.com/wiki/Arma_3_CfgVehicles_EMPTY

fieldpacks are somehow bound to the ammoboxes or something. I've no idea what that means though.

So anyway, I've tried adding custom backpacks into the big ammobox, but it does not work. this is the code I used:

a3e_arr_AmmoDepotVehicleBackpacks = ["B_HMG_01_support_F"];

a3e_arr_AmmoDepotVehicleBackpacks = ["B_Static_Designator_01_weapon_F"];

a3e_arr_AmmoDepotVehicleBackpacks = ["B_HMG_01_A_weapon_F"];

But instead, what gets added is 4 dissasembled HMG packs. Not 1 tripod, 1 designator and 1 dissasembled HMG.

Edited by iZver

Share this post


Link to post
Share on other sites

iZer - check out the Units section of the mission files. Without looking at my machine, I believe the folder says "Units" and then there is a classnames sqf. I am pretty sure that within that contains the parameters for all the ammo crates and such: I was in there yesterday changing out all the units and adding Arctic Warfare units for a winter map that I adapted the escape mission to.

Share this post


Link to post
Share on other sites
this is the code I used:

a3e_arr_AmmoDepotVehicleBackpacks = ["B_HMG_01_support_F"];
a3e_arr_AmmoDepotVehicleBackpacks = ["B_Static_Designator_01_weapon_F"];
a3e_arr_AmmoDepotVehicleBackpacks = ["B_HMG_01_A_weapon_F"];

But instead, what gets added is 4 dissasembled HMG packs. Not 1 tripod, 1 designator and 1 dissasembled HMG.

Use this code:

a3e_arr_AmmoDepotVehicleBackpacks = ["B_HMG_01_support_F","B_Static_Designator_01_weapon_F","B_HMG_01_A_weapon_F"];

Share this post


Link to post
Share on other sites
Use this code:

a3e_arr_AmmoDepotVehicleBackpacks = ["B_HMG_01_support_F","B_Static_Designator_01_weapon_F","B_HMG_01_A_weapon_F"];

muchas gracias works like a charm. I still get 4 each though, but whatever this will do. :)

Edited by iZver

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×