Robalo

ASR AI 3

2460 posts in this topic

^ does the same problem happen for the setCustomAimCoef ?

 

One thing I would try is to add some small time delay into your EH code, to try and counter any other event that might be overwriting it.

player addEventHandler ["Respawn", {TEST = [] spawn {sleep 2; player enableStamina false}}];

Not tested for syntax error, example only :)

 

Share this post


Link to post
Share on other sites

It's because ACE uses an advanced stamina system to determine stamina and all that.  If you don't want any of ACE's stamina features, you can either delete ace_advanced_fatigue.pbo, or set fatigue disabled in the advanced stamina module.

 

also

51 minutes ago, dmarkwick said:

Quote fail. Now I can't get rid of the quote field :(

Click on the gray bar at the top of the quote and hit the delete key.

 

/offtopic

1 person likes this

Share this post


Link to post
Share on other sites
On 4/5/2017 at 8:36 AM, Savage_Donkey said:

It's because ACE uses an advanced stamina system to determine stamina and all that.  If you don't want any of ACE's stamina features, you can either delete ace_advanced_fatigue.pbo, or set fatigue disabled in the advanced stamina module.

 

also

Click on the gray bar at the top of the quote and hit the delete key.

 

/offtopic

Hey thank you, I will try this! 

Share this post


Link to post
Share on other sites

my community is running Asr ai  we don't run rhs saf but we do run the rest of the rhs mods. the rhs config seemingly requires saf. I was wondering what exactly the config files do for each of these factions.

Share this post


Link to post
Share on other sites

@Robalo - we've found out that once unit goes to combat mode basically it becomes uncontrollable by Zeus and ASR AI takes complete control of it from now until it dies. People have tried switching combat stance to aware, but that doesn't help. This makes Zeus hosted missions very problematic. Is there a way to say to ASR AI to stop controlling a unit when danger.fsm starts running?

1 person likes this

Share this post


Link to post
Share on other sites
23 hours ago, tomhighway said:

@Robalo - we've found out that once unit goes to combat mode basically it becomes uncontrollable by Zeus and ASR AI takes complete control of it from now until it dies. People have tried switching combat stance to aware, but that doesn't help. This makes Zeus hosted missions very problematic. Is there a way to say to ASR AI to stop controlling a unit when danger.fsm starts running?

 

I don't know what you mean by "takes control". Units in combat are generally harder to puppeteer regardless of mods AFAIK, Might be just side effect of enhanced awareness that this state lasts longer. If you want to disable scripted actions for certain units search thread for the exclude variable.

Share this post


Link to post
Share on other sites
On 4/9/2017 at 10:37 PM, halveridian said:

my community is running Asr ai  we don't run rhs saf but we do run the rest of the rhs mods. the rhs config seemingly requires saf. I was wondering what exactly the config files do for each of these factions.

 

Same as the mod does for vanilla units and weapons. Easy fix, remove the saf pbo.

1 person likes this

Share this post


Link to post
Share on other sites

Unfortunately disabling the stamina in ace mod has no effect on the  the stamina. @Robalo How can I disable stamina while using ASR AI 3? I have stamina disabled in my script, however asr ai3 overrides it. Appreciate a remedy! 

 

1 person likes this

Share this post


Link to post
Share on other sites
17 hours ago, Ryan.szx said:

Unfortunately disabling the stamina in ace mod has no effect on the  the stamina. @Robalo How can I disable stamina while using ASR AI 3? I have stamina disabled in my script, however asr ai3 overrides it. Appreciate a remedy! 

 

 

You should try as dmarkwick already suggested few posts back, add a delay. Stamina is enabled on player on init and on teamswitch while it gets disabled for AI in player's group.

Share this post


Link to post
Share on other sites
5 hours ago, Robalo said:

 

You should try as dmarkwick already suggested few posts back, add a delay. Stamina is enabled on player on init and on teamswitch while it gets disabled for AI in player's group.

Thank you for your reply, I did not try his suggestion as he stated it was a test, meaning not tested. I already have a stamina disable in my init~ 

waitUntil {!isnull player};
player enableStamina false;
player setCustomAimCoef 0;
player addEventHandler ["Respawn", {player enableStamina  false}];
player addEventHandler ["Respawn", {player setCustomAimCoef  0}];
};

His suggestion is the only remedy? 

Again thank you for the reply, unfortunately I have had to remove the mod from my servers until I can find a work around, as my players like the way stamin is at the moment. 

 

Cheers.

Share this post


Link to post
Share on other sites

Posted (edited)

Any CUP Config yet? or is it even required?

Edited by Jinef

Share this post


Link to post
Share on other sites

Is there any way to disable ASR ai from a certain mission / certain unit

Share this post


Link to post
Share on other sites

It looks like the last update patch 1.7 might have broken Asrai3 settings?

Getting the AI 1 shot kills again, enemy acting like vanilla settings have taken over, anyone else noticed this?

Share this post


Link to post
Share on other sites
On 5/20/2017 at 9:50 PM, jgaz-uk said:

It look like the last update patch 1.7 might have broken Asrai3 settings?

Getting the AI 1 shot kills again, enemy acting like vanilla settings have taken over, anyone else noticed this?

Cant say i have noticed that. I have noticed that ai are spamming grenades like they are in COD4 :D When an ai squad comes across enemies within about 50 mtrs, they will just start lobbing grenades, then switch to 40mm ugl or even use NLAW launchers before they actually fire a round from a rifle..Is there any way to disable/reduce that? I thought asr_ai used to have a much larger config file, but when i checked it there is nothing really that is changeable.

Share this post


Link to post
Share on other sites
2 hours ago, ineptaphid said:

Cant say i have noticed that. I have noticed that ai are spamming grenades like they are in COD4 :D When an ai squad comes across enemies within about 50 mtrs, they will just start lobbing grenades, then switch to 40mm ugl or even use NLAW launchers before they actually fire a round from a rifle..Is there any way to disable/reduce that? I thought asr_ai used to have a much larger config file, but when i checked it there is nothing really that is changeable.

Apart from using the NLAW I'd be spamming nades and the 40mm too!

Share this post


Link to post
Share on other sites
22 hours ago, kremator said:

Apart from using the NLAW I'd be spamming nades and the 40mm too!

i know-it is good that they use them, but they use them to a huge degree-it means cqb fighting is just grenades everywhere.

Share this post


Link to post
Share on other sites
45 minutes ago, ineptaphid said:

i know-it is good that they use them, but they use them to a huge degree-it means cqb fighting is just grenades everywhere.

 

I'm not seeing this. Could be maybe they ran out of ammo or they have some incorrect loadout (mags not compatible with primary weapon) ?

Or maybe it's fixed somehow in my current build, it's been a while since 1.0.

Share this post


Link to post
Share on other sites

Definitely not out of ammo-happens with my ai squad at the start of a  mission. Would it be possible to give a more tweakable config? So we could decide the frequency ai use grenades, and also we could choose the ai's hearing range? They seem to hear gunfire from much, much further away than vanilla-it can really break stealthy missions. Or is that due to the ai radio ability? In which case, we can already change that.

2 people like this

Share this post


Link to post
Share on other sites

The mod used to have both AI hearing range and AI radio range. Hearing range disappeared in some update.

Share this post


Link to post
Share on other sites

My situation is this:

Enemy keeps reinforcing current firefights. Normally this is great. But there are several groups I want to stay in defensive positions and not engage in the fighting. I read that ai with radio have increased detection range. If I remove radios from the groups that I need to stay in a position will this eliminate the problem? Or is there some type of waypoint like "hold" I can use to tell the ai, "Hey I know there is a firefight going on 300m away but our orders are to stay here."

Share this post


Link to post
Share on other sites

having possibility to set groups in defence position (limited radius of movement) would be really nice. I am having same issue where all groups are rushing to fight area and leaving some strategic positions defenseless and players are abusing this AI behavior to wipe them out :(

1 person likes this

Share this post


Link to post
Share on other sites

Issue that doesn't happen in vanilla. AI leader goes hundred(s) of meter(s) in front of other soldiers in his group. Why?

 

YfRwer4m.jpg

 

inHkdXcm.jpg

 

Share this post


Link to post
Share on other sites

It's been too long since last one so here we go: v1.1.0 is up.

 

[config]
- (mod) slight decrease in ammo hit/pass detection range
- (mod) minor decrease of camo penalty for backpacks (lower coefficient)
- (mod) reduce use of handguns in favor of primary weapon use
- (mod) tweaks for full/burst rate of fire, weapon/mode selection, engagement ranges
- (mod) reduce default AI aiming speed
- (rem) remove all unit cost tweaks
[scripting]
- (new) integrated Incognito by Rydygier (single player only for now). Big thanks for allowing me to add this in !
- (new) wounded AI patch themselves once they think it's clear
- (rem) no longer take away eyewear at night
- (mod) don't try to equip NVG if already wearing NV helmet
- (mod) improve times for unequipping/reusing NVGs by AI
- (mod) prevent AI from jumping into vehicle person turrets
- (mod) prevent teammate AI from going prone with no weapons when using copy my stance (they'd get stuck)
- (mod) remove hints from "fire on my shot" commands
- (mod) prevent sending units to cover or searching buildings when they have HOLD type waypoint
- (mod) carrying a big launcher affects camouflage (bigger stick more visible to AI)
[settings]
- (new) in-game option to disable stamina handling completely
- (new) in-game settings for Incognito
- (mod) tweak userconfig defaults

 

Enjoy !

17 people like this

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now