Jump to content
Riouken

cTab - Commander's Tablet - FBCB2, Bluforce Tracker, UAV, and Helmetcam Interface

Recommended Posts

I'm very casual when it comes to Arma 3, and I mostly use it as a sandbox. Only recently reinstalled the game and gotten past the very first campaign misson (finally!, only had the game since Alpha....)
 

I've tried via ArmaHolic and via Steam Workshop, I can get cTab working, I figured out how to add the required items via the character properties (adding to inventory via virtual arsenal doesn't seem to work), but the main feature I wanted was the pop-out camera view.
 

I absolutley love the PC Ghost Recon games, the Advanced Warrior series specifically, so with my reinstall I added the Crosscom Mod (which is cool), which also adds 3 eras of GR as a faction, via the use of third party items (all on the Steam Workshop). With the ShackTac UI it is a great little HUD.
 

So building that kind of game experience in Arma 3 is my goal. The tablet works, the cameras work in the tablet view. But I cannot fully Fullscreen any view, it just fullscreens on the tablet. Also, I cannot unpin a view and have it floating on my screen somewhere.
 

Is that functionality missing in 2.2.1, or am I doing something wrong?

Share this post


Link to post
Share on other sites

It probably was asked before, but will it be compatible with the new MFD coming with the jets DLC ?

Share this post


Link to post
Share on other sites

I don’t know if this is a recent issue, or an ongoing one, but altitude is not reporting correctly above 1000m on some maps, on both the cTab devices and the =ATM= Altimeter.

 

On Takistan and Takistan Mountains, the cTab devices and the =ATM= Altimeter displays altitude without the thousands digit, so 2229m reports as 229m.

 

On Clafghan the thousands digits work, but the height is reporting exactly 640m less than actual height, so 1700m reports as 1060m.

 

At first I thought the issue would be with the maps, however the ACE3 MicroDAGR GPS reports the height 100% correctly on all these maps, which would suggest it’s not the map.

 

Curiously, the new Lythium map – which has a high point of 1330m or so – every device displays correctly.

  • Like 1

Share this post


Link to post
Share on other sites

Anyone know if its possible to add the new datalink functionality to the commander's tablet?, essentially creating a JTAC tablet 

  • Like 2

Share this post


Link to post
Share on other sites

Hey, I'm not sure if this is the best spot to put this, but I'm currently having a problem with my live feeds for cTab. All of my live feeds, whether it be UAV or helmet cam, show a completely gray box instead of the actual live feed. Does anyone know the fix for this? I've searched the web to no avail. Any help would be much appreciated. Nevermind, the fix is that you cannot have PIP disabled, though I'm sure this was already figured out.

Share this post


Link to post
Share on other sites

I'm trying to see find the text message function, I'd like to send global text messages to everyone with details as part of a mission.

Is anyone familiar with this function?

Share this post


Link to post
Share on other sites
17 hours ago, nelo_riot said:

I'm trying to see find the text message function, I'd like to send global text messages to everyone with details as part of a mission.

Is anyone familiar with this function?

//Adding the new EVH instead of the deprecated function cTab uses. Execute only once on client (for example in initPlayerLocal.sqf):
["cTab_msg_receive", 
 { 
  _msgRecipient = _this select 0; 
  _msgTitle = _this select 1; 
  _msgBody = _this select 2; 
  _msgEncryptionKey = _this select 3; 
  _sender = _this select 4; 
  _playerEncryptionKey = call cTab_fnc_getPlayerEncryptionKey; 
  _msgArray = _msgRecipient getVariable [format ["cTab_messages_%1",_msgEncryptionKey],[]]; 
  _msgArray pushBack [_msgTitle,_msgBody,0]; 
   
  _msgRecipient setVariable [format ["cTab_messages_%1",_msgEncryptionKey],_msgArray]; 
   
  if (_msgRecipient == cTab_player && _sender != cTab_player && {_playerEncryptionKey == _msgEncryptionKey} && {[cTab_player,["ItemcTab","ItemAndroid"]] call cTab_fnc_checkGear}) then { 
   playSound "cTab_phoneVibrate"; 
    
   if (!isNil "cTabIfOpen" && {[cTabIfOpen select 1,"mode"] call cTab_fnc_getSettings == "MESSAGE"}) then { 
    _nop = [] call cTab_msg_gui_load; 
     
    ["MSG",format ["New message from %1",name _sender],6] call cTab_fnc_addNotification; 
   } else { 
    cTabRscLayerMailNotification cutRsc ["cTab_Mail_ico_disp", "PLAIN"]; 
   }; 
  }; 
 } 
] call CBA_fnc_addEventHandler;

//creating and sending the message, execute only locally on the client of the sender:
_title = "Title";
_message = "Look at that message, isn't it nice?";
_encryptionKey = "b";
_sender = player;
{
	_receiver = _x;
    ["cTab_msg_receive", [_receiver, _title, _message, _encryptionKey, _sender], _receiver] call CBA_fnc_targetEvent;
} forEach allPlayers;

 

  • Like 4

Share this post


Link to post
Share on other sites

Is this only me that have an error every time I launch the cTab first time in a given game? I'm running bunch of other mods (RHS, ACE and some other minors that shouldn't interfere with cTab), also this looks like poiting to cTab itself.

 

SzAopUL.jpg

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×