Sign in to follow this  
Followers 0
Jaximus

Disabling Force Feedback

5 posts in this topic

I'm attempting to use SimFFB so I can get proper force trimming with my G940 stick, but Take On refuses to give up FFB control to the outside program. Is there a parameter I can change somewhere to completely disable FFB? And if so where exactly is the location? I've searched high and low for FFB control, but the best I've been able to do is turn off vibrations. Thanks for your help, guys.

Share this post


Link to post
Share on other sites

Well in general Take on Helicopters doesn't really give access to other "programs" to interfere with it's elements. Now I can not provide you with anything specific but maybe this will help, if you haven't already checked it out:

http://www.logitech.com/en-us/support/5855?osid=14&bit=64

Also another issue I would like to point out is that certain controllers, such as G940 are designed for airplane-sims. That is why the throttle is as it is. In flying hellos it could be quite difficult to control the aircraft.

Share this post


Link to post
Share on other sites

All mass-produced joysticks are made for airplane sims. Unless you're flying with $1,500 controls you're using something designed for an airplane. I fail to see what that has to do with anything.

The force feedback in Take On Helicopters is not properly modeled. It just acts like a spring. SimFFB emulates a real force-trim system and works beautifully with my G940. My joystick isn't the problem. Not being able to turn off the force feedback in Take On's settings is the problem.

So, again, if anyone knows how to disable the game's output of FFB signals to my joystick I would really like to know. There are ways to bypass it by creating a virtual joystick, but I would rather just disable the game's FFB.

Share this post


Link to post
Share on other sites
I'm attempting to use SimFFB so I can get proper force trimming with my G940 stick, but Take On refuses to give up FFB control to the outside program. Is there a parameter I can change somewhere to completely disable FFB? And if so where exactly is the location? I've searched high and low for FFB control, but the best I've been able to do is turn off vibrations. Thanks for your help, guys.

See these:

_____________________________________

_____________________________________

Try changing IsXInput in the TKOH profile file (not cfg) to 1 for the stick or all. Then initialize directinput in simffb. My G940 is a WIP right now, so I can't try this myself.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0