Jump to content
terox

Tutorial: Installation & Configuration of ArmA3 Dedicated Server

Recommended Posts

I have windows server 2003 as well, when I click the icon the process shows up in task manager for a fraction of a second then closes. But on my local machine(win7) I got it to work fine, so I think I am missing some kind of dependency but it's not telling me. Any ideas?

Share this post


Link to post
Share on other sites
how can i login as admin to my own server?

Updated the initial thread with an answer to this.

basically you simply add "#login SERVERADMINPASSWORD" in any of the chats, global, side, group, command, vehicle etc

The initial post has been updated to answer all the questions that to this point have been raised and also added the advice given by some posters to keep all the information available condensed into the first post

Changelog @ version 1.1

Some questions some of you may already know

Has anybody managed to get a working solution for a firedeamon service?

I have managed to get A3 to start up via a FD service but it starts up the console and wont let me shut the console down via FD

Has anybody managed to use the -profile switch and while doing so managed to load missions in the MPmissions folder in the folder that the -profile points too ?

Edited by Terox

Share this post


Link to post
Share on other sites
At the moment the arma3.exe requires a account with ArmA 3 to start, so use your own account in offline mode or buy a second copy.

how about copying & rename the exe, and start that one too?

Share this post


Link to post
Share on other sites

Somehow my -server dies right after starting, while the game runs fine from steam

I see the server console window very briefly, and it then dies. The .rpt only put this:

Is this different from any of you, just after starting the server?

=====================================================================
== C:\Program Files (x86)\Steam\steamapps\common\Arma 3\arma3.exe
== "C:\Program Files (x86)\Steam\steamapps\common\Arma 3\arma3.exe"  -server -config=A3TestServer.cfg 

Exe timestamp: 2013/03/05 23:35:37
Current time:  2013/03/07 00:23:21

Type: Public Alpha
Branch: Stable
Version: 0.5.102571
=====================================================================

Item STR_DISP_OPT_DISABLED listed twice
Item STR_WORD_DIST100 listed twice
Item STR_WORD_DIST1000 listed twice
Item STR_WORD_DIST200 listed twice
Item STR_WORD_DIST500 listed twice
Item STR_WORD_DIST2000 listed twice
Item str_disp_hintc_continue listed twice
Updating base class Default->GdtAsphalt, by a3\map_data\config.bin/CfgSurfaces/carpet/
Updating base class Default->GdtStratisDirt, by a3\map_data\config.bin/CfgSurfaces/mud/
Updating base class RscControlsGroup->RscControlsGroupNoScrollbars, by a3\ui_f\config.bin/RscDisplayMain/controls/ModIcons/
Updating base class RscPicture->RscPictureKeepAspect, by a3\ui_f\config.bin/RscDisplayMain/IconPicture/
Updating base class RscListBox->RscCombo, by a3\ui_f\config.bin/RscDisplayCustomizeController/Steepness/
PhysX3 SDK Init started ...
... PhysX3 SDK Init ended
String STR_DN_STONE not found
String STR_DN_STONE not found

If I put a console logging file I see that it puts "Host Identity created", and then nothing more. Any ideas?

Share this post


Link to post
Share on other sites

Has anyone else noticed an alarmingly high amount of data usage on their a3 servers?

Mine (when only running 10 players) seemed to be pushing out 4-5x more MB of traffic than my a2oa wasteland server (with 40-60 players) :eek:

Rough estimate I think I was seeing in the region of 2GB an hour.

Also, I am obviously missing something (probably because I normally run linux dedi) but where is the RPT file getting created?? I don't seem to get one :confused:

Share this post


Link to post
Share on other sites

Also, I am obviously missing something (probably because I normally run linux dedi) but where is the RPT file getting created?? I don't seem to get one :confused:

Ref the .rpt.

I am using a -profile switch at the moment. My .RPT is being created in the folder it points too

Share this post


Link to post
Share on other sites
Hey guys, just a quick question. Are you required to create a new steam account, and purchase another copy of the the A3 alpha for your dedicated server? Or can you just use your own steam account on the server?

I'd like to know this as well. I can't run the game and the server at the same time, for obvious reasons (same .exe).

Share this post


Link to post
Share on other sites

I guys...

My server is running following the exact instruction listed here, but im unable to get it listed in the server list.

Do you need to use reportingip="something.gamespy"; ?

When i start the server without any config file, only the -server argument. I see it in the server list.

tnx

Hugo

Share this post


Link to post
Share on other sites

Has anybody managed to get a working solution for a firedeamon service?

I have managed to get A3 to start up via a FD service but it starts up the console and wont let me shut the console down via FD

Having a similar problem to this with TCAdmin - Server starts, TCA doesn't see it so tries to start another copy, Steam throws up an error window that it can't run two copies, TCA still can't see it, so tries to start another copy, steam throws up another window etc etc.

TCA also won't shut down the server since it never gets the process id which stays as 0

Share this post


Link to post
Share on other sites
Having a similar problem to this with TCAdmin - Server starts, TCA doesn't see it so tries to start another copy, Steam throws up an error window that it can't run two copies, TCA still can't see it, so tries to start another copy, steam throws up another window etc etc.

TCA also won't shut down the server since it never gets the process id which stays as 0

That is the same issue I have when I try to use FD and a batch file. If anybody comes up with a solution I/we would love to see it!

Share this post


Link to post
Share on other sites
Hey guys, just a quick question. Are you required to create a new steam account, and purchase another copy of the the A3 alpha for your dedicated server? Or can you just use your own steam account on the server?

Nope, just go offline on steam

Share this post


Link to post
Share on other sites

This is probably a very obvious question but I'd like to hear what people have to say.

What are the pros/cons to hosting from a dedicated server rather than just hosting it from your client?

Share this post


Link to post
Share on other sites

Most people's dedicated servers have a very good connection to the Internet which obviously helps reduce lag. Having a server process running on its own helps performance over hosting a session and playing in the same client. A dedicated server can be left running indefinitely too.

Sent from my HTC One X using Tapatalk 2

Share this post


Link to post
Share on other sites

Just set up and played with dedicated server+Headless client+my game on the same machine! with steam off line! Performance was very good but needs more test and a better mission. But my 6 cpu cores were working for 40-90%. I used TDLN_co80_stratis_slaughter mission. All working good like i was doing on arma 2 and mso missions!

Share this post


Link to post
Share on other sites

hmm ... I have steam in offline mode.. all the correct data in my .cmd to launch the server.

I still cannot launch both server and client in offline mode..

Share this post


Link to post
Share on other sites
Anyone else missing alot of DLL's when trying to run the server on Windows 2008 R2?

Negative, the ping shows up as 2500 on my side, any idea how to solve this ?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×