Sign in to follow this  
Followers 0
TRuBi

Arma 2 Operation Arrowhead - Invalid serial for authenthification

5 posts in this topic

That's my problem. Long ago I bought Arma 2 and Arma 2 OA Retail versions.

Arma 2 works fine, even at multiplayer. But then, after installing Arma 2 OA, when I have to validate the game after the first launch, it says invalid serial.

Who do I have to write to to check if my serial isnt valid?

Thanks.

Share this post


Link to post
Share on other sites

Hello,

I'm having a problem with my Operation Arrowhead game.

After installing it, it will let me pass SecuRom authenthification. But then, when I try to patch the game, it says Wrong Key.

Also, if I try to host a multiplayer game, it says that my Key is disabled.

I have already contacted customer support, and I've been told that my key is OK...

My game is a Retail copy, not steam.

Any help, please? I've already tried to reinstall many times, removing all the registry entries with RegCleaner, and I cant fix it.

Thanks.

Edited by TRuBi

Share this post


Link to post
Share on other sites

You could manually check for registry entry leftovers in the registry (win+r > regedit > F3 = search for 'arma' > delete all). You could also verify if you’re not making a mistake while entering the key in the first place. Also disable virus scanners, defenders and security suits etc that could interfere with the installation process. And if that fails you could try to install arma on another system to verify the problem is local or not.

Share this post


Link to post
Share on other sites

Boxed version? I thought the CDkey was requiredd before the game install starts?

Share this post


Link to post
Share on other sites
You could manually check for registry entry leftovers in the registry (win+r > regedit > F3 = search for 'arma' > delete all). You could also verify if you’re not making a mistake while entering the key in the first place. Also disable virus scanners, defenders and security suits etc that could interfere with the installation process. And if that fails you could try to install arma on another system to verify the problem is local or not.

It is weird. Now, when reinstalling, the game never asks for my key, not even when launching the game. I think it is that SecuRom saved the key somewhere, and it just takes it automatically. I've tried removing the game and SecuRom (with it's removing tool, and even deleting files/registry entries), and it still does it. I'll just format my computer and install it again.

I've already been told by the customer support that my key is OK, so the problem must be mine.

Thanks for answering.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0