Sign in to follow this  
Followers 0
daddog

error creating direct3d 9 graphical engine arma 2

27 posts in this topic

Windows 7 Home Premium

64bit SP1

Intel 2 Duo E8500

4 Gigs memory

Nvidia GeForce GTX 260

I have been trying to play ARMAIIOA with a friend, but keep getting the following error.

error creating direct3d 9 graphical engine

It seems to be a rather common problem and after reading up on it I gather changing the string of the .exe file is the fix. Problem is I can't find a way to do that. I recall in XP I was able to edit the string of .exe files, but can't seem to do that with Win 7. I uninstalled ARMAIIOA and redownloaded it again via Steam, but the same thing happened. I then removed the mods I had installed and deleted the game again and downloaded it for a 3rd time. Still no joy. :( Any help would be greatly appreciated. :)

Thanks in advance.

Share this post


Link to post
Share on other sites

Windows 7 Home Premium

64bit SP1

Intel i7 2600 @3.4Ghz

16Gb memory

2x ATI Radeon HD6800 in Crossfire.

DX11

I'd like to attach DxDiag but don't know how to do it and putting the whole thing in quotes exceeds post maximum letter count.

Did a recovery to last install of DirectX, which did not help.

ArmaII vanilla works, but OA gives error. PMC and BAF gives same error.

Funny thing is last night it worked fine as I started the SP Campaign.

AFAIK the last update was 23 May.

I've read re-installing OA does not help, so I am loathed to re-download the whole kit-and-kaboodle (steam purchase, Arma II Anniversary Ed).

EDIT: Just ran Combined Ops from right-click context OA in my Steam Library. Weird. I suppose I could use this, but it's still annoying that I have all those shortcuts on my desktop that I can't use....

Edited by astrospud

Share this post


Link to post
Share on other sites

I have the same problem

ATi Firepro v5800 graphics, with latest drivers

DirectX 11

I have installed the game, the expansion, the patch, and now I get the same error.

I felt like pulling my hair out and punching my own face, during the whole process, and now this.

...seriously, they need to make this game more accessable to the general public. Awkward install, awkward player control and slow frame rate do not make for funtimes

Share this post


Link to post
Share on other sites

ATi Firepro v5800 graphics, with latest drivers

DirectX 11

What about DirectX 9?

Share this post


Link to post
Share on other sites

I have manually installed directx 9.0c and tried other things like turning off hyperthreading, and removing all extra commands in the shortcut. still does the same thing....will try installing just directx 9.0 tommorrow, and see if it works.

Share this post


Link to post
Share on other sites

so im sry to post his here, but ive been just trying to get arma 2 updated for FOUR WEEKS and at every turn i just run into problem after problem, and apperently you cant make your own forum post even after going through several other steps of nonsense ive never had to suffer through on any other forum ive ever been to including secure systems.

Now i find out i need dx9 (and some specific version of it), and ive tried to dl this 6 times, gotten 2 virus's and still have no clue where to find a real company that still uploads this. Ive sifted through page after page here and find bad info, conflicting info, or virus's.

can someone help me to find this? pretty please with a little red blasted cherry on top?

words can not describe my frustration at this unprofessionalism of product update/support. please help me with this one issue, and you'll never see or hear from me again.

Share this post


Link to post
Share on other sites

words can not describe my frustration at this unprofessionalism of product update/support.

Under which email address did you open a ticket on our support system?

Share this post


Link to post
Share on other sites

error creating direct3d 9 graphical engine

as mentioned before this problem is mostly related to f...ed up shortcuts,

just go to your ArmA2 directory and use the ones included :)

Share this post


Link to post
Share on other sites

when trying to install that dx9 it tells me i have a more recent version already. lil help?

and why is none of this information on the faq or better yet on the update page itself. You could make tons of room if you just got rid of all the patches that dont have working links to them anymore.

edit: and im sry about all the frustration, its not your guys fault. just ya this could be presented better.

Edited by Obliteratii

Share this post


Link to post
Share on other sites
Myke;2183597']@Oslomadon

do you run the game as Administrator?

yes' date='

and it seems that the [b']"DirectX End-User Runtime Web Installer"[/b] for DirectX9.0c IS the installer/update for directx 9.0 and all those before it.

So I still have a problem,

my last attempt will be to uninstall the entire game and try again... but I will wait a few days, I'm rather busy.

thanks

Share this post


Link to post
Share on other sites

Do not bump threads, please. If someone knows a solution or has a idea, he will post it anyway.

Share this post


Link to post
Share on other sites

its been a day and im just trying patch the game. Are you seriously telling me in all this time no ones came along that knows anything about that?

---------- Post added at 04:23 PM ---------- Previous post was at 04:20 PM ----------

does oa use dx9? cause i have that for steam and it has been working fine, ive gotten the first patch to take once or twice, but it defaults back to 1.01 as soon as it gets reset. I have tried downloading multiple dx9's but it says i already have dx.

please fellas, lil help, im begging here.

Share this post


Link to post
Share on other sites

You know, people tend to have a real life, jobs family...you know, the usual boring stuff that distracts them from visiting our forum. Besides that, i've checked your posts in this thread and i just realized that some more info might attract some people...you know, the usual stuff like used hardware, driver versions, game versions...just anything that could help to get the complete picture. Either that or you pack up your PC and move to my place so i could look at it directly. ;)

Share this post


Link to post
Share on other sites

i guess im on windows 7 on a radeon 6470m? the original game is on a disk and keeps defaulting back to 1.01 if i can even get the first patch to take at all, its on a asus laptop/mom, i think i gave you everything else...

but ya, i had it previously too, not sure how long ago i had last patched it, but i had previously been up to date. I had just been doing single player campaign stuff tho so not sure how long ago the last patch was.

EDIT: oh and im trying to use the 1.01 to 1.09 patch, is there a better one i should be using?

and for the first time doing this my antivirus just flashed something (and yes ive been checking my antivirus, but it shows no logs or problems up until now), so im going to assume its been sand bagging me the whole time. Im not able to shut this program off either :( guess i need to get with bitdefender tho.

Edited by Obliteratii

Share this post


Link to post
Share on other sites
i guess im on windows 7 on a radeon 6470m?

If you do guesswork, i'm affraid we're not able to help. Make a proper report containing detailed hardware specs, OS version, driver versions. Also a proper dxdiag.txt and maybe a .rpt would be helpful. Or we have to start guessing aswell: i guess something is wrong.

Share this post


Link to post
Share on other sites

lol ive simply never seen a site that required a dxdiag.txt or they wouldnt talk to you. Much less over a patch issue.

Im totally saving this quote...

Share this post


Link to post
Share on other sites

OK

I have tried running the .exe launch from program folder, and same thing,

It would be good if Arma2 would supply an "Install repairer/checker" that checks the integrity of folders, and makes sure that nothing is out of place...

I can send you my DxDiag.txt, however I am unsure how to attach a file using his forum.

I can email the file to a Genuine support member.

Share this post


Link to post
Share on other sites

You have the Steam version? So why are you manually trying to patch it? That will certainly mess your game up, Steam auto patches. Not to mention it looks like you're trying to patch Arma2 which is irrelevant when you have OA installed.

---------- Post added at 10:39 ---------- Previous post was at 10:37 ----------

OK

It would be good if Arma2 would supply an "Install repairer/checker" that checks the integrity of folders, and makes sure that nothing is out of place...

Errr you said you have the Steam version? Steam has an "Install repairer/checker", it's called "verify the cache integrity", for someone who's making snide remarks at Myke above who's wasting his free time trying to help an ungrateful petulant person I'd suggest you focus more on the steps you're taking to try to help yourself rather than the steps you're taking to try to ensure nobody wants to help you.

Share this post


Link to post
Share on other sites

Thanks for the help guys......

Edited by cujoe

Share this post


Link to post
Share on other sites
You have the Steam version? So why are you manually trying to patch it? That will certainly mess your game up, Steam auto patches. Not to mention it looks like you're trying to patch Arma2 which is irrelevant when you have OA installed.

---------- Post added at 10:39 ---------- Previous post was at 10:37 ----------

Errr you said you have the Steam version? Steam has an "Install repairer/checker", it's called "verify the cache integrity", for someone who's making snide remarks at Myke above who's wasting his free time trying to help an ungrateful petulant person I'd suggest you focus more on the steps you're taking to try to help yourself rather than the steps you're taking to try to ensure nobody wants to help you.

---Please get your facts right. Those comments were not made by ME

---and no I am not running Steam version

very unprofessional I might add.

Share this post


Link to post
Share on other sites
---Please get your facts right. Those comments were not made by ME

---and no I am not running Steam version

very unprofessional I might add.

Then why on earth have you hijacked the thread of someone using the Steam version? You brought the incorrect replies on yourself. I'd suggest you start your own troubleshooting thread then and not hijack someone else's :)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0