Sign in to follow this  
Followers 0
33BO11OF00

Sound Problems in OFP

17 posts in this topic

Help! I have sound problems in OFP game. When I start mission music and all sound stop.

My other games work just fine but this game locks up every time.

My hardware config is:

Ram :2048MB (2GB)

Display card :ATI Radeon HD 4600 Series

Sound card : Creative SB Live! (CT4620) Sound card

Motherboard :ASUS P4S533-MX

Chipset :SiS 651

I hope this info helps for solving this problem.

---------- Post added at 06:18 PM ---------- Previous post was at 06:08 PM ----------

Sorry for double posting but in some other sound threads contain this advice:

If you install new sound card or display card you have to re-install OFP.

Dang! Is this ONLY hope here?

Share this post


Link to post
Share on other sites

33B0

It could be related to directX. Click the start button and select run. Then type in the box "dxdiag". This will run the diagnostic tool, when it finishes click the sound tab and see if it shows any errors.

Share this post


Link to post
Share on other sites

Zulu1:

Dixdiag test runned. No errors there.

Edited by 33BO11OF00
word added

Share this post


Link to post
Share on other sites

Did you change any hardware in your pc and/or did you install new drivers for the hardware? If so, have you tried the "Autodetect" button in the preferences executable?

Share this post


Link to post
Share on other sites

New errors on screen. OPF won't run only showing this text:

Bas_o\config.cpp/CfgVehicles/BasAgs_Whouse2.ladders : "," encountered instead of ";"

What does this means?

---------- Post added at 09:42 PM ---------- Previous post was at 09:23 PM ----------

What is difference between these four .EXE files

OperationFlashpoint.EXE

OPFlashPreferences.EXE

and

FlahpointPreferences.EXE (With this EXE all sound problems corrected.)

FLASHPOINTRESISTANCE.EXE

Question:

Does OFP run on windows 7? Because I'm getting a new computer soon.

Edited by 33BO11OF00
Crap! Typo!

Share this post


Link to post
Share on other sites
New errors on screen. OPF won't run only showing this text:

Bas_o\config.cpp/CfgVehicles/BasAgs_Whouse2.ladders : "," encountered instead of ";"

What is difference between these four .EXE files

OperationFlashpoint.EXE <CWC 1.46, pre-Resistance expansion>

OPFlashPreferences.EXE <CWC 1.46 preferences, pre-Resistance expansion>

and

FLASHPOINTRESISTANCE.EXE <1.75 and upwards, Resistance expansion>

FlashpointPreferences.EXE (With this EXE all sound problems corrected.) <1.75 and upwards, Resistance expansion>

BAS_O is related to a BAS addon, BAS_O comes with the Tonal mod if I remember correctly. Either you are missing a required addon, or you tried to edit a file from BAS or a mission and forgot to properly close the syntax (either forgot the ";" or something was added after the ";"). It could also be a bug in that addon, but I have played with BAS addons for years, so I am fairly sure that it's not a bug in the addon itself. Could also be that you're trying to run Resistance-era addons from BAS with just CWC, although you should get a mention about the version before any error message that you are getting.

Edited by JdB

Share this post


Link to post
Share on other sites
Question:

Does OFP run on windows 7? Because I'm getting a new computer soon.

Yes, no problem.

Share this post


Link to post
Share on other sites

I don't want to hijack some elses thread, but I've been battling a sound problem lately.

The problem is internal vehicle sounds are like being underwater and the timming is slowed down (like slow motion). After playing around with drivers I can now get the proper sound if I switch to an external view then back to internal. This could be a problem with 3rd view being disabled in MP play.

What does anyone know about video cards with high definition audio? I recently switched to an ATI HD5670 and it adds an AMD HD Audio driver which I currently have disabled. Would this be related to the problem at all?

Thanks

Share this post


Link to post
Share on other sites
I don't want to hijack some elses thread, but I've been battling a sound problem lately.

The problem is internal vehicle sounds are like being underwater and the timming is slowed down (like slow motion). After playing around with drivers I can now get the proper sound if I switch to an external view then back to internal. This could be a problem with 3rd view being disabled in MP play.

What does anyone know about video cards with high definition audio? I recently switched to an ATI HD5670 and it adds an AMD HD Audio driver which I currently have disabled. Would this be related to the problem at all?

I've had a similar problem for years, ever since I switched to a surround sound capable card (I have the relevant settings disabled ingame, they don't sound any different). Single fire mode on any weapon in the primary slot is soft, then I switch to another firing mode, hit the fire button at least once and then my sound is the volume it should be from then on until I restart or retry. Sound in OFP is just weird sometimes ...

Share this post


Link to post
Share on other sites

Well at long last after many hours of frustration it seems I have narrowed down the problem. Something in my Zulu1 profile was affecting the sound. I tried playing using a different profile and the sounds all worked correctly. I could not spot anything in the user.cfg file that looked odd, so I just deleted it for Zulu1 and made a new .cfg file now it seems to be OK.

:yay:

edit: Ok now I have pin pointed the souce of the problem, the only question now is why? With sound/hardware acceleration enabled the sounds get muted and go into slow motion. With it disabled it's fine.

I used to be able to run with this enabled and I just can't figure out what has changed so that I have to disabled it now.

Edited by Zulu1
more info

Share this post


Link to post
Share on other sites

I also have Soundblaster LIVE! installed in my computer. It causes prorblems in OFP. Is there ANY way to get it working with this game? Because I use that card for making music.A

Share this post


Link to post
Share on other sites

If you have problems with sound cards try to delete your user profiles and config them again. This fixes some problems.

Question:

Does any "specialist" sound card work well in OFP or ARMAS?

I mean like: Sound blaster Xifi, Sound blaster Fatality and external USB cards.

Info:

If you want different gaming experience try those Ukranian S.T.A.L.K.E.R game series.

If you want totally strange gaming experience try that Fallout series made by Interplay.

Edited by 33BO11OF00
Some info

Share this post


Link to post
Share on other sites

Update about my problem:

When I shoot tank and it explodes after that all sounds go quiet and computer re-boots. After that I see this message in Windows XP: Windows has recovered from serious system error. What is going on here :mad::16_6_8::computer::rage:

This problem usually occurs then there are lot of tanks on map.

Edited by 33BO11OF00
info

Share this post


Link to post
Share on other sites

This has little to do with OFP and a lot to do with the shitty Creative drivers.

Disable hardware acceleration and disable EAX.

Share this post


Link to post
Share on other sites
This has little to do with OFP and a lot to do with the shitty Creative drivers.

Disable hardware acceleration and disable EAX.

I don't know about how shitty the drivers are, but I agree with metalcraze. Disable hardware acceleration.

Share this post


Link to post
Share on other sites

Question:

Hardware Acceleration? What is that? How does that affect sound?

About this Hardware Acceleration. Where do I disable it?

Question to Zulu1:

What operating system you are using now?

Edited by 33BO11OF00
question.

Share this post


Link to post
Share on other sites
Question:

Hardware Acceleration? What is that? How does that affect sound?

About this Hardware Acceleration. Where do I disable it?

Question to Zulu1:

What operating system you are using now?

From OFP's main menu go to Options\Sound to disable hardware acceleration.

I've run OFP with Win98, WinXP and Win7.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0