Jump to content
Sign in to follow this  
Woodzy

Arma Graphics Bug

Recommended Posts

I'm running ArmA on win 7 64 bit. I run Arma 2 free fine, but when i run ArmA the buildings and land have no textures, and units either have low res textures, or none at all. Also it is Arma gold if that matters.

ArmA

http://s849.photobucket.com/albums/ab58/woodzyk/?action=view¤t=arma2011-10-2917-56-41-38.jpg

ArmA 2 Free

http://s849.photobucket.com/albums/ab58/woodzyk/?action=view¤t=arma2free2011-10-2918-01-36-49.jpg

Please Help. Also i am running an intergrated Intel HD graphics card, which i dont think the card is the problem, since i run Fallout: New Vegas at highest settings fine. Ive tried -winxp and it didnt help, and my ram is 4.00 Gb

Share this post


Link to post
Share on other sites

Im having the same problem sorta... When I start up the game all of the Logos and what not are all blurry and then when it gets to the main menue everything is white and when I try to change the resolution everything goes black or it just shows a picture of my desktop. I'm using windows 7 64 bit

Share this post


Link to post
Share on other sites

First of all, thank you for using search rather than creating a new thread and thank you for posting a screenshot of the problem. I'm assuming you are using either Windows Vista or Windows 7, which ArmA seemed to have a problem with, but only if you are on an early version. If you update ArmA to the latest version, this glitch should go away.

Share this post


Link to post
Share on other sites

ARMA: Gold Changelog

Aug 23 2011, 1:30am - VERSION: 1.18.5281

FULL

Gold Client

I just downloaded Monday so I'm assuming Desura is offering the latest.

Not sure its really an issue since the demo works but

Processor Manufacturer Intel

Processor Type Core i3

Processor Model i3-2120

Processor Core Dual-core (2 Core)

Processor Speed 3.30 GHz

Standard Memory 6 GB

Memory Technology DDR3 SDRAM

Windows 7 Home Premium 64-bit

Yes I'm running as administrator

Share this post


Link to post
Share on other sites

Ok, have you installed DirectX 9? I remember the same exact thing happening to me, but I cannot seem to remember what the hell I did to fix it. I believe I just updated it, but maybe I did something else.

What kind of graphics card do you have? AMD or NVIDIA?

Share this post


Link to post
Share on other sites

Nothing fancy actually its the POS onboard card the computer came factory with Intel®HD graphics 2000 I believe it was 256mb with a max of 1696mb. That's probably my problem I just assumed that if the demo ran ok......

And yes Dx is fully updated

Share this post


Link to post
Share on other sites
Nothing fancy actually its the POS onboard card the computer came factory with Intel®HD graphics 2000 I believe it was 256mb with a max of 1696mb. That's probably my problem I just assumed that if the demo ran ok......

And yes Dx is fully updated

The graphics card might be the problem. The demo version is actually quite outdated compared to the 1.18 version of the game, which may be why you were able to play the demo, but not the full game.

Could I have you install Speccy? Once installed open it and copy everything that is on the "Summary" tab, then paste it here please.

2hd4e34.jpg

Share this post


Link to post
Share on other sites

Operating System

MS Windows 7 Home Premium 64-bit SP1

CPU

Intel Core i3 2120 @ 3.30GHz 34 °C

Sandy Bridge 32nm Technology

RAM

6.00 GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)

Motherboard

Gateway IPISB-VR (CPU 1) 38 °C

Graphics

HP 2009 (1600x900@60Hz)

Intel® HD Graphics Family

Hard Drives

977GB Western Digital WDC WD10EADX-22TDHB0 (SATA) 40 °C

Optical Drives

HL-DT-ST DVDRAM GH70N

Audio

Realtek High Definition Audio

Actually a really nifty tool =D

Share this post


Link to post
Share on other sites

It may be your graphics card. Are you launching it through Desura? Try going right into the ArmA directory and launch it by clicking on the .exe.

Share this post


Link to post
Share on other sites

Tried it both ways and launching windowed both ways always the same result

---------- Post added at 19:22 ---------- Previous post was at 19:17 ----------

Yeah done it through the main .exe before as well as window mode through both Desura and the .exe

Share this post


Link to post
Share on other sites

Ok. I have one last idea.

Go to the directory for ArmA. Right click on the .exe and click "Create Shortcut". Then right click on the shortcut and click "Properties". At the very end of the target line with a space before you type it, type in "-maxmem=2048".

It should look like this:

25ga0dj.jpg

Share this post


Link to post
Share on other sites
Tried that approach already didn't work. Reason number 128 to upgrade my video system....

Indeed.

I'm currently in the process of downloading ArmA and installing it so I can take a closer look and see if it happens to me as well.

---------- Post added at 19:31 ---------- Previous post was at 18:37 ----------

I am able to run ArmA 1.18 perfectly fine. I'm going to assume that the issue is with your graphics card being incapable of properly playing ArmA.

Share this post


Link to post
Share on other sites

It is your graphics card bro. In fact simply because you don't have a graphics card.

Trying to play anything but very old games or looking at your desktop with an integrated "videocard" is futile.

That and intel drivers are usually really bad.

You'd do well by buying a proper one.

Share this post


Link to post
Share on other sites

Operating System

MS Windows 7 Home Premium 64-bit SP1

CPU

Intel Core i3 @ 3.40GHz

Sandy Bridge 32nm Technology

RAM

6.00 GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)

Motherboard

PEGATRON CORPORATION 2AC2 (CPU 1)

Graphics

Generic Non-PnP Monitor (1366x768@60Hz)

Intel® HD Graphics Family

Hard Drives

977GB Hitachi Hitachi HDS721010DLE630 (SATA)

Optical Drives

hp DVD A DH16ABSH

Audio

Realtek High Definition Audio

Arma Version 1.18.0.5281 Steam

same problem. and considering buying a graphics card to get it to work. even though a roll back to a previous version WOULD fix my problem. it worked on my laptop.....vista 32bit. non updated version.

idk if its possible to rollback a steam game, id like to know. and id like to know if i could get a blessing on downloading a older version. im just way too frustrated to mess with this anymore.

so, theres 3 options

A) fix it.

b) allow me to get a earlier version

C) refund. (idk if i have to go through you or steam)

this update BROKE the game, in my humble opinion.

it worked in earlier versions, and it worked on my low powered laptop? WHY not my desktop.

i am aware it may be the video card, and i am looking into purchasing one. any suggestions to one thats GUARANTEED to work?

Share this post


Link to post
Share on other sites

theres 3 options

A) fix it.

b) allow me to get a earlier version

C) refund. (idk if i have to go through you or steam)

A) It works for many people, it's an issue with your hardware.

B) You must redownload from Steam and disable automatic updates if you wish to have an earlier version. Although Steam may automatically download the newest version, I'm not sure,

C) The place you purchased from would have to give you a refund. To my knowledge, Steam does not give refunds.

Share this post


Link to post
Share on other sites
Im having the same problem sorta... When I start up the game all of the Logos and what not are all blurry and then when it gets to the main menue everything is white and when I try to change the resolution everything goes black or it just shows a picture of my desktop. I'm using windows 7 64 bit

i have the same problem and when i finally get in the game (by pressing random buttons ) the textures are the same as the ones the first guy said

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×