Sign in to follow this  
Followers 0
abel

ARMA 2:OA beta patch 75445

109 posts in this topic

Nice to see major bugs getting fixed now! Didnt test the rocks yet.

Hope to see the AI gettin stuck with Pistol Bug getting fixed[Chechz and German Forces] and for sure the chopper nicking bug. If those are done i will happily buy the PMC DLC:)

Share this post


Link to post
Share on other sites

Before anyone asks, it updates to 1.55 as the beta before this did. So don't use if you want to play on servers not using this beta.

I'll continue to test this one though, last one didn't cause any problems as I rarely play MP anymore. Just remember to rename old beta folder in case you need to revert to older version (74630).

Share this post


Link to post
Share on other sites

How is performance and stability with this beta?

I had very bad experience with last beta 74858 so I want to wait for some reports since the changelog does not mention anything.

btw. We need a 1.55 compatible server to test multiplayer.

Share this post


Link to post
Share on other sites

Interested to hear the feedback of those of you who are public beta testing, in finding out about the 'rock' collision bug:

[75230] Fixed: Character collisions with stones often resulted in flying or being stuck. (http://dev-heaven.net/issues/12043)

That's been my #1 most annoying bug, and am happy to see that this could now be resolved :)

Share this post


Link to post
Share on other sites

Guys, the whole point of the public betas is to test for yourself. Every PC is different and in turn gives different results.

Share this post


Link to post
Share on other sites

I am getting much vegetation blinking on Chernarus. Grass, bushes and trees change their lods (?) much and sometimes there is very small parts of vegetation missing for very small piece of second. There is also much more low quality models shown in small distances. Also I have more shuttering when zooming (in cutscene at least).

My computer: Q6600 (3,4Ghz), 4Gb memory, HD4890, Vista 64bit (SP2), X-fi Audio. All with new drivers. Settings 1920x1200, 2006m visibility, textures medium, video high, AF high, AA off, terrain&objects normal, shadows high, HDR normal (havent seen that option before ingame :S), postprocess very low and vsync on.

Share this post


Link to post
Share on other sites
Guys, the whole point of the public betas is to test for yourself. Every PC is different and in turn gives different results.
The performance drop in 74584 was very common regardless of system specs or OS.

Share this post


Link to post
Share on other sites

Hi there,

tested it shortly and first of all thx BIS, performance seems to be much better for me than in the last beta.

That said I still managed to get myself stuck on the rocks in takistan pos. 080061.

Nothing a quick tab ov V couldn't fix, but not sure about the AI navigating these rocks, but I will test this.

Cheers

Crusader

EDIT:

Just tested with AI, they seem to mostly circumvent the rocks, and if they step on them, they seem to not fully interact with them (sinking a bit into the rocks). Looks a bit weird, but as log as it does its job (which it seems to do), I'm more than happy!

Edited by TheCrusader

Share this post


Link to post
Share on other sites

ok i suggest everyone even these who claim they don't want to test ... to test and report

what we need to know is if this build is stable (compared to previous beta)

so let it run in background or play something or so ...

Share this post


Link to post
Share on other sites

BIS : "Excuse me, could you test this for me?"

USER: "Ok, is it stable?"

BIS: "Well you need to test it for me to work on this"

USER: "Well, if its not stable I wont install it"

BIS: "Thanks"

USER: "No Problem, Goodbye"

BIS: "Bye"

USER: "oooh, umm hello? Are you still there?"

BIS: "Umm, yes"

USER: "When's the next stable patch out?"

...... (distant facepalm)

*goes blank, credits roll, Benny Hill theme plays*

:)

I will test this with some editing and try the alt-tab issue that I had, work this baby until it hurts.

Edited by mrcash2009

Share this post


Link to post
Share on other sites
btw. We need a 1.55 compatible server to test multiplayer.

The beta includes a 1.55xxx server exe. ;)

Share this post


Link to post
Share on other sites

As of patch 75445 I am having an issue with our MP server. This is a dedicated server in my local LAN. Never had issues so far including all recent betas.

Each time I run a mission now server and client load fine until the mission is about to begin (map mode). As soon as I click "Continue" I am being kicked from the server.

I started a clean beta server like this:

"C:\ArmA 2\Expansion\beta\arma2oaserver.exe" -config=sample.cfg -mod=Expansion\beta;Expansion\beta\Expansion

This is the error log from arma2oaserver.RPT when I run "01: War Welcome"

=====================================================================

== C:\ArmA 2\Expansion\beta\arma2oaserver.exe

== "C:\ArmA 2\Expansion\beta\arma2oaserver.exe" -config=sample.cfg -mod=Expansion\beta;Expansion\beta\Expansion

=====================================================================

Exe timestamp: 2010/11/09 23:12:09

Current time: 2010/11/10 00:07:48

Version 1.55.75446

Item str_disp_server_control listed twice

Updating base class ->ReammoBox, by ca\weapons\config.bin/CfgVehicles/WeaponHolder/

String STR_BAF_CFGMAGAZINES_BAF_PUTIED_V10 not found

String STR_BAF_CFGMAGAZINES_BAF_PUTIED_V20 not found

String STR_BAF_CFGMAGAZINES_BAF_PUTIED_V30 not found

String STR_BAF_CFGMAGAZINES_BAF_PUTIED_V40 not found

ca\missions\MPScenarios\MP_Deathmatch.chernarus: string @str_mpdeathmatch_subname cannot be localized client-side - move to global stringtable

ca\missions\MPScenarios\MP_Deathmatch.chernarus: string @str_mpdeathmatch_subname cannot be localized client-side - move to global stringtable

Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 0)! MoveName: kia_uaz_cargo02

Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 1)! MoveName: uaz_cargo02

Unit not created: Subgroup 0:0 not found

Cannot create object 3:1

Received 82, expected bool

Unexpected message data (message struct NetworkMessageWaypoint, item visible)

Before (0x0000003e): 75 65 00 00 00 00 00 74 72 75 65 00 24 4e 4f 4e 45 24 00 00 00 00 24 4e 4f 4e 45 24 00 00 00 00

Current (0x0000005e): 52

Received 48, expected bool

Unexpected message data (message struct NetworkMessageWaypoint, item visible)

Before (0x0000007c): 75 65 00 00 00 00 00 74 72 75 65 00 24 4e 4f 4e 45 24 00 00 00 00 24 4e 4f 4e 45 24 00 00 00 00

Current (0x0000009c): 30

Received 58, expected bool

Unexpected message data (message struct NetworkMessageWaypoint, item visible)

Before (0x0000003e): 75 65 00 00 00 00 00 74 72 75 65 00 24 4e 4f 4e 45 24 00 00 00 00 24 4e 4f 4e 45 24 00 00 00 00

Current (0x0000005e): 3a

Creation of object L 1-1-G:32 failed, state LOGGED IN

Ref to nonnetwork object L 1-1-G:32

Creation of object L 1-1-G:33 failed, state LOGGED IN

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:33

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:33

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Creation of object L 1-1-G:34 failed, state LOGGED IN

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:33

Ref to nonnetwork object L 1-1-G:34

Ref to nonnetwork object L 1-1-G:34

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:34

Ref to nonnetwork object L 1-1-G:34

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Creation of object L 1-1-K failed, state LOGGED IN

Creation of object L 1-1-K:<Empty main subgroup> failed, state LOGGED IN

Client: Nonnetwork object f960090.

Client: Nonnetwork object 11485100.

Ref to nonnetwork object <No group>:0

Creation of object L 1-1-K:1 failed, state LOGGED IN

Client: Nonnetwork object 11485100.

Creation of object L 1-1-L failed, state LOGGED IN

Creation of object L 1-1-L:<Empty main subgroup> failed, state LOGGED IN

Client: Nonnetwork object fec60c0.

Client: Nonnetwork object 11485700.

Ref to nonnetwork object <No group>:0

Creation of object L 1-1-L:1 failed, state LOGGED IN

Client: Nonnetwork object 11485700.

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

Ref to nonnetwork object L 1-1-G:32

There's a second file in that folder called "mpStatistics.log". I am just adding this here, no idea if this is a cumulative log of all games or just the recent one:

AddInitAndRemoveOverridden statistics ... total messages = 2640

243 ... Type_10

573 ... Type_46

130 ... Type_142

110 ... Type_213

129 ... Type_214

1413 ... Type_231

33 ... Type_233

9 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 147

42 ... Type_10

2 ... Type_46

95 ... Type_142

2 ... Type_213

2 ... Type_214

4 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 3227

242 ... Type_10

2 ... Type_40

2 ... Type_41

7 ... Type_42

15 ... Type_45

689 ... Type_46

211 ... Type_142

5 ... Type_204

140 ... Type_213

167 ... Type_214

1686 ... Type_231

52 ... Type_233

9 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 3157

250 ... Type_10

665 ... Type_46

274 ... Type_142

3 ... Type_204

123 ... Type_213

146 ... Type_214

1595 ... Type_231

71 ... Type_233

30 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 1309

228 ... Type_10

104 ... Type_46

105 ... Type_142

870 ... Type_231

2 ... Type_233

AddInitAndRemoveOverridden statistics ... total messages = 1

1 ... Type_10

AddInitAndRemoveOverridden statistics ... total messages = 2641

244 ... Type_10

8 ... Type_40

16 ... Type_42

401 ... Type_46

165 ... Type_142

2 ... Type_204

62 ... Type_213

72 ... Type_214

1645 ... Type_231

21 ... Type_233

5 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 60

42 ... Type_10

12 ... Type_46

6 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 1

1 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 3382

239 ... Type_10

294 ... Type_46

137 ... Type_142

1 ... Type_204

1 ... Type_213

1 ... Type_214

2702 ... Type_231

7 ... Type_233

AddInitAndRemoveOverridden statistics ... total messages = 2206

240 ... Type_10

214 ... Type_46

162 ... Type_142

1 ... Type_213

1 ... Type_214

1573 ... Type_231

11 ... Type_233

4 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 3516

242 ... Type_10

1 ... Type_40

476 ... Type_46

332 ... Type_142

2 ... Type_204

53 ... Type_213

63 ... Type_214

2294 ... Type_231

47 ... Type_233

6 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 3271

239 ... Type_10

3 ... Type_40

1 ... Type_41

9 ... Type_42

11 ... Type_45

463 ... Type_46

203 ... Type_142

3 ... Type_204

97 ... Type_213

115 ... Type_214

2095 ... Type_231

24 ... Type_233

8 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 84

40 ... Type_10

40 ... Type_142

4 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 3020

244 ... Type_10

1 ... Type_40

484 ... Type_46

257 ... Type_142

2 ... Type_204

79 ... Type_213

95 ... Type_214

1792 ... Type_231

45 ... Type_233

21 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 819

56 ... Type_10

21 ... Type_46

742 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 3781

246 ... Type_10

1 ... Type_40

681 ... Type_46

268 ... Type_142

1 ... Type_204

161 ... Type_213

193 ... Type_214

2183 ... Type_231

38 ... Type_233

9 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 52

42 ... Type_10

1 ... Type_46

9 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 2672

240 ... Type_10

2 ... Type_40

1 ... Type_41

7 ... Type_42

7 ... Type_45

453 ... Type_46

240 ... Type_142

1 ... Type_204

78 ... Type_213

90 ... Type_214

1512 ... Type_231

29 ... Type_233

12 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 2373

247 ... Type_10

4 ... Type_40

1 ... Type_41

13 ... Type_42

7 ... Type_45

467 ... Type_46

223 ... Type_142

43 ... Type_213

51 ... Type_214

1279 ... Type_231

29 ... Type_233

9 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 43

40 ... Type_10

3 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 4

4 ... Type_10

AddInitAndRemoveOverridden statistics ... total messages = 3211

238 ... Type_10

8 ... Type_40

4 ... Type_41

34 ... Type_42

28 ... Type_45

512 ... Type_46

274 ... Type_142

43 ... Type_213

50 ... Type_214

1976 ... Type_231

29 ... Type_233

15 ... Type_234

AddInitAndRemoveOverridden statistics ... total messages = 819

56 ... Type_10

21 ... Type_46

742 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 85

10 ... Type_10

21 ... Type_46

54 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 96

10 ... Type_10

21 ... Type_46

65 ... Type_231

AddInitAndRemoveOverridden statistics ... total messages = 716

86 ... Type_10

18 ... Type_46

1 ... Type_215

529 ... Type_231

82 ... Type_235

AddInitAndRemoveOverridden statistics ... total messages = 819

56 ... Type_10

21 ... Type_46

742 ... Type_231

I have tried with and without my addons galore; logged in as user or admin; tried different missions - always being kicked back to the MP server screen right after mission start. Hmm...

Cheers,

VictorFarbau

Edited by VictorFarbau

Share this post


Link to post
Share on other sites

Just tested, FPS isnt seeming different but need to test further (IE same is good).

ALT-Tab is back to normal, no more crash on every other alt-tab like last beta, settings in graphics is now not causing odd CTD like last patch.

I tried a mission using a lot of modules in chernarus that im working on to give it a through test, I did get 1 PC lockup (no rpt could be written too had to reset/cold boot PC) ... I cant say this is the beta at the moment will test more.

Although the most obvious thing right away was the tree LOD loading on Chernarus (via OA CO) ... I have been making a mission on Chernarus and have been on that map for some hours over the past few evenings, and so I noticed it right away. The LOD for trees are "flickering" rapidly and randomly in the distance as if they are not sure what LOD level to load a flicks through stages very fast, its very odd too look at.

I quickly knocked up this fraps grab, Im not talking about LOD loading as that can be as usual, notice all the trees around that "quickly flicker", this stood out like a saw thumb on chernarus as I tested this via the beta:

wMuFXi6V2B4

EDIT: 0.33 in watch the clump of trees on the far right, 3 or so of them (for example)

(when I reach the sunny area as brightness isn't great at first.. check the fast flicking trees that's what im referring too). You may have to study it a few times, its all around and small bushes too, basicly whole sections of trees will flicker, not the usual "switch" LOD I expect.

GTX260 OC 216 896MB ... 260.99 NVIDIA driver.

Again, this quick flicker of trees is not in previous betas, never so obvious.

Edited by mrcash2009

Share this post


Link to post
Share on other sites

Been playing off and on since this beta was released, haven't shut client down nor have I noticed anything different. If I get it to crash I'll send a report.

Share this post


Link to post
Share on other sites

Version is stable performance is good again.

I noticed that most cars don't have destructable glass anymore.

It is impossible to shoot out a window on most cars with small arms or even MGs, especially unarmored HMMWV.

The windows also dont show any damage textures until shot with HE rounds.

Checked with last 1.54 patch and it's the same there.

Checked back with ArmA II 1.07 and all vehicles have Windows destructible by small arms, takes a mag of 5.56 there.

This is a step back like with the since OA missing blast effect on tanks.

I remeber that before 1.54 patch vehicle windows could be destroyed before the car began to burn in OA.

Edited by Ulanthorn

Share this post


Link to post
Share on other sites

Thanks to introduction of VSYNC in options i managed to optimize performance easier and found new playable higher settings thanks to it. Thanks a lot for that BIS.

Didnt notice much LOD swapping during my rather brief tests, but i did notice weird behaviour from the AI when leading them. Might been a fluke so will have to get back on that. They followed me badly even circling around instead of staying still in formation.

Big improvement was VSYNC and whatever else was done in the background as the performance seems great. Fiddling with VSYNC and Mouse Smooth while upping settings can get you to a nice feeling of boosted FPS.

BTW: Does the line in ARMA2OA.CFG "3D_Performance=93750;" have any meaning? With previous patch activated it's 100000 on my machine. And the patch before that it was lower. Seems this changes up and down from patch to patch, but if it has any significant meaning i dont know.

Edited by Alex72

Share this post


Link to post
Share on other sites
BTW: Does the line in ARMA2OA.CFG "3D_Performance=93750;" have any meaning?

Apparently no. From the BI wiki:

"3D_Performance=93750 - written by engine each start, changing it manually has no effect!"

Bumped into that while fixing a related start-up error message.

Share this post


Link to post
Share on other sites
Version is stable performance is good again.

I noticed that most cars don't have destructable glass anymore.

It is impossible to shoot out a window on most cars with small arms or even MGs, especially unarmored HMMWV.

The windows also dont show any damage textures until shot with HE rounds.

Checked with last 1.54 patch and it's the same there.

Checked back with ArmA II 1.07 and all vehicles have Windows destructible by small arms, takes a mag of 5.56 there.

This is a step back like with the since OA missing blast effect on tanks.

I remeber that before 1.54 patch vehicle windows could be destroyed before the car began to burn in OA.

Maybe it's a step towards bullet-proof glass for all those pilots; I know they've been wanting this for a while ;)

Probably needs some tweaking.

Beta seems stable so far; although only tested a little. Will mess around some more and give feedback

Share this post


Link to post
Share on other sites

thanks for the feeedback everyone, keep it coming ...

we considering it release candidate for 1.55

and thus it would be welcome if someone report any crashes etc., in case you get crashes ...

to my email which is myforumnickname at bistudio.com ,

i would need the arma2oa.bidmp arma2oa.mdmp arma2oa.rpt, thanks in advance

Share this post


Link to post
Share on other sites

Stability seems good for me so far, but the issue with the choppers bouncing up and down is still present.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0