Sign in to follow this  
Followers 0
KingPwnChow

Contructing bases in warfare as other factions

3 posts in this topic

Hi,

I have a warfare mission with 2 sides, US and Takistani Army, I want the US HQ to build US buildngs (not USMC) and the Takistani to build Takistani barracks, light factory ect (not russian as it keeps doing) is there a way I could do this? If possible I want to build the bases in the editor and be able to recruit units from them without having to build through the HQ/ingame.

Also when I start the mission Im randomly spawned on the map with a different HQ, any help PLEAAAAASEEE?

Thanks

Edited by KingPwnChow

Share this post


Link to post
Share on other sites

KinkPwnChow

I've had success changing the default buildings etc. with the warfare module in vanilla Arma2.

The way I did it involves the InitMission.sqf calling a custom Init_Common.sqf.

The Config_Structures.sqf will need to be edited with all the class names of all the structures that you want to use.

Also the configs of all the depots, loadouts etc.

It's not difficult, but tedious, and I have yet to figure out a quicker way to do it.

Share this post


Link to post
Share on other sites

I am trying to get the warfare module to function with the normal warfare buildings, pre-placed in the editor. The windows to buy units come up, but nothing happens when you double click to buy something, besides the name of whatever you bought appearing in the right-side pane of the window. It never actually deducts funds or anything.

In my mission, I currently have everything working fine as long as I build the base using the mobile HQ. I have Lucik's Warfare scripts (Common_SetAlliance.sqf, init_common.sqf, and initmission.sqf), Description.ext, briefing.sqf, and init.sqf. All these files were provided in Lucik's Warfare package, with the exception of the briefing, which I wrote myself. Everything works flawlessly, UNLESS I place the warfare buildings in the editor rather than building the base.

I have tried numerous ways of sychronizing the buildings, and I have tried placing the "Functions" module, not grouped or sychronized.

Do I need copies of all the warfare scripts in my mission folder? Do I need to add something to the init line of the buildings I place? What does happens besides placing the building in the game world to make those buildings function with the warfare module that I am missing?

Any help would be greatly appreciated!!!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0