Sign in to follow this  
Followers 0
Naf-Cop-

"BattlEye Initialization Failed"

26 posts in this topic

Everytime i try and join a server this message will appear, i havent played on this game in about 5 months. And now i come back to this, i have read some threads and updated my version from 1.04 to 1.07. Try and join a server and it dumps me back to the server browser. Tried running as admin but it says my password is bad, so i dont know how else i can do this! Somebody help me please! :pray:

Share this post


Link to post
Share on other sites

Password? Are you trying to join passworded servers? In that case you need password to login. Try to login on non passworded servers.

Your BattlEye will automatically update when you joining a server with the newest BattlEye server.

Share this post


Link to post
Share on other sites

ought today OA. and I realized that the game was done by people whose hands are growing out of ass. you'd better have saved us from errors in Arma 2. although I am sure that the henna is in your power to 8 /

---------- Post added at 07:03 PM ---------- Previous post was at 07:01 PM ----------

I'm not confident in your professionalism. very sad gentlemen

Share this post


Link to post
Share on other sites

No i just tried to join any servers that are normal with no password but it dumps me back to the server browser saying: BattlEye Initialization Failed. WHY?!?! Sorry it makes me mad, i was up all night looking for solutions.

Share this post


Link to post
Share on other sites

Ummm i dont have one, do i make it? All i have is:

Missions

Keys

MPMissions

Addons

Dta

Share this post


Link to post
Share on other sites

Hmm... well yes,, make one folder with name BattlEye

Then copy those two files i gave you link to.

Share this post


Link to post
Share on other sites

Thanks so much for your help! IT WORKS!!!!!! YEAAAA! Thanks alot man, much appreiciated!

Share this post


Link to post
Share on other sites

Formated computer and installed Arma2 for the first time and had the same problem, thanks that fixed it!!

Share this post


Link to post
Share on other sites

the reason you have this problem is because one of the last patches 1.07 i think) and possibly 1.54 for ao/ co) doesnt force you to install battleye so you dont have it.

most servers would run battleye purely for Rcon access and or maxping kickers so that would be why nearly all servers kick you when you join because , as it says, battleye failed to start (cos its not there)

if you have the steam version of arma2 / arrowhead you can open up the steam app right click on arma and select isntall battleye .

or as already has been said make a folder install the files and away you go

just thought i'd let everyone know what and why.... carry on

Share this post


Link to post
Share on other sites

I have this problem and can't get it working. I tried the BEsetup in steam apps and also creating a battleye folder. I tried to download battleye from their site but they only have 32 bit for download and I have C:\Program Files (x86) which means not 32 bit right? So what do I do?

Share this post


Link to post
Share on other sites
I have this problem and can't get it working. I tried the BEsetup in steam apps and also creating a battleye folder. I tried to download battleye from their site but they only have 32 bit for download and I have C:\Program Files (x86) which means not 32 bit right? So what do I do?

Do what Dwarden said.

And yes, x86 is 32-bit. But regardless which system you are playing on, ArmA2/OA is a 32-bit application and thus you also need a 32-bit BE Client.

Share this post


Link to post
Share on other sites

What about when a Linux server fails to initialize ?

Share this post


Link to post
Share on other sites
Hmm... well yes,, make one folder with name BattlEye

Then copy those two files i gave you link to.

I just bought Arma 2 for my self and one of my friends and my copy of Arma 2 will not let me play multiplayer I can download the missions and I can see all of the servers, but the second I try to join a server it will download the mission information then boot me right back to the server browser. the same thing happened to my friend. I gave him my old one I bought both of them on the same day. I gave him my old copy because I was getting an invalid CD key error on every server I would try to join. even if I would try to host my own, But I purchased the game. please help me fix this problem..

Share this post


Link to post
Share on other sites
You're welcome! :)
I have the same problem, but I also cannot find my arma2 install game directory. Could somebody please tell me how?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0