Page 36 of 41 FirstFirst ... 26323334353637383940 ... LastLast
Results 351 to 360 of 408

Thread: [Alpha] RTE for ArmA II

  1. #351
    Did you try to report it at the bug tracker of RTE or contact the author?

    Community Funded Modding - Become a patreon!

    (104 of 1000$ per month reached for first tier)

  2. #352
    Why is it that when I load my missions, my objects are floating? I made them clip with the map. Is it a problem?

  3. #353

    RTE Capture does not work

    I have been trying to get the RTEditor to work for the last couple of days, and I have almost reached the point of pulling my hair out in frustration.

    If I launch ArmA with the RTEditor mod folder, it works fine. I can access the 3D editor, place objects, etc. etc. I can't, however, export anything I make because RTECapture is not running, and RTECapture is not running because it doesn't work!

    It launches fine, but when I click 'Profiles' it stops responding and I have to manually end the process through task manager, so it is impossible for me to set it up for my game. When I select 'Launch ArmA (II)', I get this error:

    "Access violation at address 0057BC0B in module 'RTECapture.exe'. Read of address 00000000.'

    As I'm sure you can guess, this is extremely annoying.

    I'm running Windows 7 64bit and the latest version of RT Editor. I have tried running Capture in XP compatibility mode and as Administrator, UAC is disabled and so on. I've tried everything I can think of, and it is still not working.

    Can anyone help?

  4. #354
    Master Sergeant Phantom Six's Avatar
    Join Date
    Nov 28 2010
    Location
    California, United States
    Posts
    658
    Trying out RTE. At first I couldn't get it working with the couldn't connect to pipe issue until I used RTECapture. It seems pretty cool at first but there was one problem, I couldn't get the units I place to hold still and they keep moving around. I eventually got them to hold still until suddenly, everything blew up and then the unit I place as me died. The mission restarted and then I can't get back to the editor and the couldn't connect to pipe issue came back. Is RTEditor still too buggy to use? Is there any alternative 3D mission editor or will it get fix soon? Will MCC Sandbox be a good substitute? I'm a bit confuse on what's wrong.
    Portfolio Site
    Join CiA Coop Nights
    Spoiler:

  5. #355
    Have no fear, I am here to help

    RTE is great, i'm worried about the creator not making it it for Arma 3 but we'll see.

    I've had issues with getting this to work before so I can help you guys. Sometimes it can be tricky because of other addons or load times or CBA or whatever. Either way, you should get it to work.

    I have not had any luck getting it to work with Jayarma at all. I haven't tried it lately so you can try my way if you want.

    BTW I don't have RTE on this computer so I have to remember this"

    First of all, I check the boxes on the profile that say "use rtecapture dll" and i check the "do not use Jayarma...". I don't remember the exact wording for those boxes but you should be able to see whaat I mean.

    Second, make sure that after you bis expansion boxes checked off, put CBA then RTE (might not be important exactly where but put rte after cba.

    Third make sure RTE is named correctly. Sometimes the instructrions say "RTEditor" and sometimes "RTE". make sure the name of the folder under your arma directory matches all references to it. a.ka. where it says "execute in" somewhere under the profile details. ALSO MAKE SURE it is referred under the "settings" option.

    Fourth, using rtecapture dll instead of jayarma, start the game. Go into the editor and preview.

    Fifth, WAIT! wait!!! You need to wait for CBA to kick in. It doesn't kick in right away, and if you start RTE right after joining the game, you will not get pipes open. I have an error message that comes up when CBA starts. I think it's caused by a bad addon that I got a long time ago. The more you have in the mission, the longer it takes to load. If i preview Shapur or something small like that, I can get on rte right away, but for safety i wait like 5 seconds. The more you put in the mission the longer it takes. You are likely going to add parts then go back to the editor, then back to preview so you will constantly be exporting. While you are creating your mission remember that time is still going on in the game. So if you take a while it may get dark so you may have to start the mission again.

    TIP** When you are creating mission in rte, set the time of day early, or it will get dark. Also weather is important. Desert maps tend to blind you when looking toward the sun,so you may want to make the weather bad to make it easier to see best. You should also lower your video settings and adjust your distance view. That will cause CBA to start quicker and you won't have many skips while moving the mouse around. If you use Chernarus, rendering all those trees slows down the rte cursor arrow and will do the same to objects you are placing. It's not a bug it's you graphics card. Then when you are done you can reset your settings.

    If you have a big map or a map with alot of objects/ vehicles, etc... it may take up to a minute for cba to load. if you don't have the error i do, you might see certain addons suddenly work. FOr example i might be in a super hornet on the nimitz and my options to open canopy etc... won't show up until cba turns on. the normal functions bis has will, but not the ones from the hornet.

    TIP****Start of as a soldier not in a vehicle, unless it's a boat. being inside a vehicle will take a looooonng time for rte to be ready.

    Sixth, now to check if you are truly connected to the pipes after you get into the editor, push alt+tab to exit the game. Look at the RTE capture and see if it says "connected" in red. If not, exit, the rte and restart the mission. ***if it is connected you can exit RTE and then start RTE again without restarting game.

    Seveth, do what you gotta do and export.... successful

    Now for the guy having trouble with his units moving and blowing up etc... The game is live. THe RTE keeps everyone from actively moving with waypoints until you push play, but if you put a soldier down in danger he will move. If you put units down in a squad, they will move into formation. but there are many options.
    -RTE automatically puts a "dostop this" in every single item you place, ONLY if you move it. So if you don't want a unit to move you need to move him. don't just double click and leave him in the place you created him or he will move. Move him. A few inches or feet or whatever, that will put the dostop this in his init.

    If you have an object or empty vehicle that moves (gravity, etc. some objects move like small ones like canisters or pictures, or crates etc. ) Put "EnableSimulation false". that makes anything static and it won't move.

    Remember if you put enemies in front of each other they will fight. You can't move things through things. don't try to move a vehicle through a wall or building. It will blow up. Like I said the game is live and everything you do is happening in game.

    Last couple tips.
    - you can move through walls if you use "enablesimulation false". Then in the 2d editor delete the enable....
    -same thing with all the "dostop this" if yu moved it in the rte it will have that. so if you want something to move then delete that in 2d editor. Especially group leaders. You don't have to clear the rest of squad.
    - You may also want "this set vectorup...."(i forgot the code at the moment) but it will hlep you place things as they will appear in game. Whenyou place things in rte they will adjust to the ground they are on. so if you place something at an angle then move it to flat, it will still have the angle. so when you get it where you want it just replace it there and it will adjust. But the 2d editor will place everything usually flat. so knowing that will help you place objects how they will be in game.
    -"this setcaptive true" If you have enemies within range, that will make them not shoot at the one you place.
    -check the 2d editor for fuel wasted. rte might turn some vehicles on and you might use it for hours. those hours you have those cars placed have been using gas.
    -You have to have at least one blufor or opfor down when you start preview. If you start of civilian, the rte will be blank.
    -Also it's a good idea to place at least one unit of each military you will be using on the map to start. Opfor has a tendency to kill any opfor friendly independents who are not already on the map. not so much the soldiers but opfor hates independent vehicles. if you put a PLA (ind) truck in front of a group of russians, the russians will kill it, even though independents are friendly to opfor. Setting one pla o the map first will solve that issue.

    AND THE FINAL TIP is most IMPORTANT, if you set yours up like mine, you can't edit weapons. well you can edit them but when you go to export it will crash and waste all your work. It will disconnect the pipe for some reason. I put units where i want them, then I export them then add to mission. Then i will edit their weapons. then I double click on them and I copy the weapon change in the units init and alt-tab and save all weapon loadouts onto notepad. Then once you have those saved in notepad, you can delete the units in the rte and keep going. you already saved the units and exported them so now you can go back to placing units. Then in 2d editor paste all the weapon changes in the units.

    Hope this helped. If you have any other questions pm me or ask here.

  6. #356
    Hi all,

    First of all congratulations for this great addon. Now I have a question: I made this to work but I´m unable to see building objects in the editor. I can see units and empty vehicles such are cars, tanks, etc, but things like sandbags and those things do not appear in the combos. I would like to create a small firebase for a mission using this. Could someone please clarify what I´m missing?

    Cheers

    EDIT: solved. They are available under "empty" side and "other" faction
    Last edited by geloxo; May 25 2012 at 19:46.
    Unidad de Simulación Táctica 101
    www.ust101.com

  7. #357
    Hey guys,
    a few problems here.
    I got CBA, CBA_A2, CBA_OA and JayArma2Lib installed, i start the game with these and few other mods without any error. But when im in the editor and placing a unit and goin for preview then i get "Script not found" Message, before updating CBA and JayArma2Lib it was "Script BIS.url not found".

    Another Msg appears when i start RTE, "ION_LIB_CLOSE - DLL NOT INJECTED", No connection to rte capture etc.
    what am i doing wrong here.

    Pls advise.

  8. #358
    Ive got it working using the latest OA beta (95248.)

    Key Points:

    1) The beta exe must be renamed to arma2.exe
    2) Open RTE capture, click options and then settings. Make sure the Arma2 path is pointing towards your OA installation. click ok.
    3) Click options and then profiles and click the arma 2 tab. Set the "Armed Assault executable" to point at the renamed beta exe (the one you renamed arma2.exe in step 1)
    4) Click the -nojayarma2lib and use RTE Capture DLL options, click ok.
    5) You can launch Arma2 using any launch program PROVIDING

    A) The OA beta patch renamed to ARMA2.exe is used.
    B) Correct CBA folders, @RTE and -nojayarma2lib is added to the command line.
    C) RTE Capture is open.

    6) Go to the editor, load what ever you want to edit and click preview.
    7) Wait a few seconds
    8) ALT TAB back to RTE Capture, notice the button no longer reads launch but Activate monitoring. Click it.
    9) Switch back to Arma 2
    10) Press escape and click on Real Time Editor, It will take a few seconds to load.
    11) ALT TAB back to RTE Capture and it will say Status Connected.

    Notes:
    If you are not actually at the RTE screen in game RTE Capture will not show a connection. You can go in and out of the editor and it will reconnect.
    Last edited by Mack.; Jul 23 2012 at 16:57. Reason: Fixed a typo

  9. #359
    Hello,
    I can't work out quite how to get CO/reinforcements to work. Using RTE I can only open AO or A2 to open but never combined ops. I saw a mention in this thread of a .cmd (by dwarden?) specifically tailored to launch RTE with CO but I can't seem to find it. Any help would be appreciated.

  10. #360
    Private First Class Etex's Avatar
    Join Date
    Sep 1 2009
    Location
    Rio de Janeiro, Brazil
    Posts
    19
    Hi,

    After the last game update (1.62), my RTE doesn't work anymore. When I open the editor, an error message shows up on the screen like "script not found" and I can't get RTECapture syncronized no more.

    Edit: When I open the RTE ingame I get these warnings:

    1 - "No connection to RTE Capture established, export won't work ! To fix this establish a connection and reload the mission." (When I open RTE)

    2 - "Script.0.ionclose|Ion_rte.ion not found" (When I close RTE)


    Note that I use ACE/ACRE mods.

    Any ideas ? Thanks in advance.
    Last edited by Etex; Jul 28 2012 at 20:09.
    http://www.armapoint.com/
    Esquadrão ArmaPoint

Page 36 of 41 FirstFirst ... 26323334353637383940 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •