Page 1 of 3 123 LastLast
Results 1 to 10 of 29

  Click here to go to the first Developer post in this thread.  

Thread: Semi-transparent textures

  1. #1
    I guess this is the closest place for this.

    I'm trying to make some semi-transparent textures, but my efforts have failed. I make a simple model, and apply what I think should be a semi-transparent .paa texture but it's solid. I'm pretty certain it's the texture as if I borrow a semi-transparent texture from another model it works.

    Even when I take this working texture & do something simple like change the colour, it stops being semi-transparent. This is without me touching it's alpha channel, just leaving it as it is & changing the colour channels.

    I make the textures using Kegetys' paa plugin for Photoshop. Is there any issue involved with Kegetys' pluging regarding alpha?
    Fire And Smoke for ArmA2: JTD_FireAndSmoke v0.2

    For better future effects addons, please vote for this ticket.

  2. #2
    Master Gunnery Sergeant DaSquade's Avatar
    Join Date
    Jul 24 2003
    Location
    Belgium
    Posts
    1,113
    If you didn't changed the alpha and the name, then it is the convertion type imho. Save it as paa with the DXT5 convertion.

  3. #3
    Major DMarkwick's Avatar
    Join Date
    Mar 19 2006
    Location
    Lincolnshire, UK.
    Posts
    7,256
    Author of the Thread
    Yup that's what I do.

  4. #4
    try to open the saved textures into TexView2, and choose to see Alpha channel... if there's one, not white, then the Alpha should work...
    in PS, did you save it in the default setting as the plugin told you to do? because fro what I know, in case of an Alpha channel that has fading effects, you must save it as RGB444

  5. #5
    Major DMarkwick's Avatar
    Join Date
    Mar 19 2006
    Location
    Lincolnshire, UK.
    Posts
    7,256
    Author of the Thread
    Quote Originally Posted by (Linker Split @ Nov. 04 2007,22:57)
    try to open the saved textures into TexView2, and choose to see Alpha channel... if there's one, not white, then the Alpha should work...
    in PS, did you save it in the default setting as the plugin told you to do? because fro what I know, in case of an Alpha channel that has fading effects, you must save it as RGB444
    Yep all looks good in Texview 2. Back in PS, I saved the texture as RGB444 as you said. I got a cannot load texture message ingame, but I saw the object's texture anyway. It appeared OK even though there was an error.

  6. #6
    Quote Originally Posted by (DMarkwick @ Nov. 04 2007,23:32)
    Quote Originally Posted by (Linker Split @ Nov. 04 2007,22:57)
    try to open the saved textures into TexView2, and choose to see Alpha channel... if there's one, not white, then the Alpha should work...
    in PS, did you save it in the default setting as the plugin told you to do? because fro what I know, in case of an Alpha channel that has fading effects, you must save it as RGB444
    Yep all looks good in Texview 2. Back in PS, I saved the texture as RGB444 as you said. I got a cannot load texture message ingame, but I saw the object's texture anyway. It appeared OK even though there was an error.
    can you post here the image? (as a Jpeg of course) then the Alpha channel too

  7. #7
    Major DMarkwick's Avatar
    Join Date
    Mar 19 2006
    Location
    Lincolnshire, UK.
    Posts
    7,256
    Author of the Thread
    No need - it's a pure block of olive green, 8x8 pixels with a mid-grey alpha. It's small because I only need a block colour not texture detail.

  8.   This is the last Developer post in this thread.   #8
    Name the texture ***_CA.* Open it in TexView and than save as paa. If you have correctly installed TexView with TexConvert.cfg it should work automaticaly. Sign _CA means colortexture with alpha.

  9. #9

  10. #10
    Major DMarkwick's Avatar
    Join Date
    Mar 19 2006
    Location
    Lincolnshire, UK.
    Posts
    7,256
    Author of the Thread
    Simply opening the texture in Texview2 and saving it fixes it. I guess there's a problem with the .paa PS plugin.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •