Results 1 to 5 of 5

  Click here to go to the first Developer post in this thread.  

Thread: MultiMaterial on Vehicle problem

  1. #1
    First Sergeant Aplion's Avatar
    Join Date
    Nov 28 2006
    Location
    Athens - Greece
    Posts
    869

    MultiMaterial on Vehicle problem

    Well ... I'm working on a vehicle (armored car) and I decided to use multimaterial shader for better texture results ... so far so good ...

    Now the problem ... as far as I'm looking the vehicle from external view (3rd person view) or when I'm dismounted, everything is fine ... but when I'm in driver, cargo or gunner position, the only texture is visible is the base texture and not the MC as on the rest views.

    My paths are triple checked and I did also another check copying the lod 0 as View Gunner and Cargo lods ... nothing changed.

    For your reference, I'm using the RVMAT from Mondkalb's MultiMaterial Tutorial with my textures in MC map and just one color in Mask map.

    Also I did the same as described above, to the inner compartment of the vehicle and there is no problem from any view on that ...

    Any help will be much appreciated.


    Aplion

  2. #2
    First Sergeant Aplion's Avatar
    Join Date
    Nov 28 2006
    Location
    Athens - Greece
    Posts
    869
    Author of the Thread
    As there is no reply so far to my issue above (I'm not complaining) I'll put another question regarding MultiMaterial RVMAT ...

    My model needs to replace its textures upon destruction ... MultiMaterial RVMAts are not using any _CO.paa so there is no way through this to define a replacement (destruction) texture for my model.

    Any thoughts about it also ?

    Please ... in case MultiMaterial RVMATs are not appropriate for vehicles ... let me know ...

    Thanks in advance.

    Aplion

  3.   This is the last Developer post in this thread.   #3
    Quote Originally Posted by Aplion View Post
    Please ... in case MultiMaterial RVMATs are not appropriate for vehicles ... let me know ...
    The multi material is not intended for vehicles.
    It is safely usable for structures, for everything else it can/will cause massive problems and incompatibilities like the very ones you are experiencing now.

    Use multiple super shaders if you need to use multiple detail (_DT) textures on vehicles to increase the close-up quality of your textures.

  4. #4
    First Sergeant Aplion's Avatar
    Join Date
    Nov 28 2006
    Location
    Athens - Greece
    Posts
    869
    Author of the Thread
    Quote Originally Posted by Mondkalb View Post
    The multi material is not intended for vehicles.
    It is safely usable for structures, for everything else it can/will cause massive problems and incompatibilities like the very ones you are experiencing now.

    Use multiple super shaders if you need to use multiple detail (_DT) textures on vehicles to increase the close-up quality of your textures.

    Mondkalb thanks for your reply ... to be honest I don't know how to use these _DT textures (or even what are these kind of textures) in order to increase the quality of my basic textures as you proposed ... (sorry for that) ... is there any relative tutorial you may point me for that (if I'm not asking too much).

    Thanks again.

  5. #5
    First Sergeant Aplion's Avatar
    Join Date
    Nov 28 2006
    Location
    Athens - Greece
    Posts
    869
    Author of the Thread
    UPDATE ... Mondkalb forget my question regarding _DT textures ...

    Thanks again for help.

    Aplion

Similar Threads

  1. Tutorial on how to use Multimaterial ?
    By Beton in forum ARMA 2 & OA : MODELLING - (O2)
    Replies: 14
    Last Post: May 29 2011, 04:08
  2. RVMAT basics (SuperShader,MultiMaterial,SkinShader,Procedural etc)
    By Dwarden in forum ARMA 2 & OA : MODELLING - (O2)
    Replies: 17
    Last Post: Oct 26 2010, 18:55
  3. It's posible to use multimaterial SOMEHOW
    By Bartchie in forum ARMA 2 & OA : MODELLING - (O2)
    Replies: 0
    Last Post: Mar 24 2010, 08:06
  4. Vehicle respawn problem
    By BlackDeath in forum OFP : MISSION EDITING & SCRIPTING
    Replies: 5
    Last Post: Apr 11 2002, 00:49
  5. Vehicle/M2 entry problem
    By DynaBlue in forum TROUBLESHOOTING
    Replies: 1
    Last Post: Dec 10 2001, 21:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •