Results 1 to 4 of 4

  Click here to go to the first Developer post in this thread.  

Thread: Bad FPS

  1. #1

    Bad FPS

    Hi all I have been working on Belfast for 3 weeks now and all has been good near a beta release but i ran some fps checks and now I get 9 fps when i look south on the island all other directions are fine as fps goes

    1 I am using mbg buildings3 as my main houses for this island fps was good when i only had a couple of hundred houses but now I have put down more its dropped only when i look south could the number of models be the problem ?

    2 Or could it may be a couple of bad models from other building packs i have used to get the city feel, and where there placed when looking at them drops frame rates ?

    I have had this on sangin before when i had some heavy fps models on i had to remove them to get fps back, this island has no where near the amount of plants and buildings on as sangin but getting similar low fps , Its only 2kmx2km but a heavily built up area of Belfast Ardoyne tight streets and back allies makes for a good street battle

    Cheers if any 1 can help I was going to release it yesterday when i noticed the low fps so thought i would fix it and release Seeria Leon and belfast together once its corrected

  2. #2
    Sergeant Major OldBear's Avatar
    Join Date
    Nov 3 2006
    Location
    Marseille, France
    Posts
    1,818
    What can get your FPS down
    - small terrain grid size,
    - Size and number of clutters
    - dense vegetation
    - high ratio of open houses and buildings
    If the FPS rate is modified when you look on different directions : you can get a direct look of the culprit

    As an example: on initial Alpha Brik release, I was getting an extra low FPS rate when looking West ... and looking West there where nothing ... some marshes and some trees ... but I had populated the marshes with a realistic amount of "phragmites" and those where the culprits once the number was divided by 10 ... FPS was good.

    On your map, the culprit is probably the high ratio of open houses and buildings. Test this by cutting some parts (export-delete wise).

  3.   This is the last Developer post in this thread.   #3
    What other building packs were you using? Maybe it's bad / not existing LODs...

    Also you can adjust the default Clutter draw distance in the config. It should be at least a way to dampen the effects of clutter.

  4. #4
    Quote Originally Posted by SmokeDog3PARA View Post
    ...and now I get 9 fps when i look south on the island all other...
    Predominently, what are the models when you look south from the position you experienced the fps drops. Perhaps use Kju's DevCon and make a hand written list of models that you're 'seeing' from that position.
    Alternativley, pop open in V3. Place the cursor approximately where you were standing when you got poor fps and take a screenshot. Then drag-select all the buildings south of your cursor and export these to a text file using the 'ExportObjects' script. Post this text file somewhere (not here as it's probably too big) so we can get an idea of what you are 'seeing' when you face south.

    Also, bare in mind that while Mondkalb's models are pretty good they are a bit what I'd term resource hungry or 'heavy'. Individually, in itself this wouldn't be an issue but if you have 1000's then it may be an issue for your map. This could equally be true of the other building model packs you're using.
    Remember, a map is the sum of it's parts...
    Hibernating (indefinitely/permanently/intermittently)... may respond to , possibly.

Similar Threads

  1. Bad FPS, with no apparent bottleneck.
    By Mayrhofen in forum ARMA 2 & OA - TROUBLESHOOTING
    Replies: 3
    Last Post: Feb 19 2012, 14:12
  2. very bad fps
    By dannyboy in forum ARMA 2 & OA - TROUBLESHOOTING
    Replies: 25
    Last Post: Feb 11 2010, 00:44
  3. Fast PC, but Bad FPS Regardless of What I Do - HELP!?
    By Brew Crew in forum ARMA 2 & OA - TROUBLESHOOTING
    Replies: 74
    Last Post: Aug 28 2009, 07:23
  4. Good FPS, Bad Stutter. Why?
    By choC in forum ARMA 2 & OA - TROUBLESHOOTING
    Replies: 4
    Last Post: Jul 11 2009, 07:47
  5. bad fps in multiplayer
    By wezke in forum ARMA 2 & OA - GENERAL
    Replies: 3
    Last Post: Jun 24 2009, 18:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •