Page 5 of 10 FirstFirst 123456789 ... LastLast
Results 41 to 50 of 100

  Click here to go to the first Developer post in this thread.  

Thread: Dedicated server performance

  1. #41
    For years, the dev's never answered any questions regarding the configuring the server network settings.

    Information is power.

    MadDog, still not sure how I came with that number either, since i was using the calculator too. But it doesn't matter now. And, if you assume anyone can type condescending, and you don't like it, Tuff-titty, I don't care what you assume.

    ...Syn...

  2.   Click here to go to the next Developer post in this thread.   #42
    so
    128 players with 128 maxMSgSend and 1300 bytes = 21 299 200 bytes / s = 20MB/s = 162.5 mbit /s

    256 maxMsgSend = 40.625 MB/s = 325 mbit/s

    ofcourse this should be throttled by values set in maxBandwith if lower

    this is per frame (fps) on server and gets throttled by bandwith optimizations

  3. #43
    Quote Originally Posted by Dwarden View Post
    so
    128 players with 128 maxMSgSend and 1300 bytes = 21 299 200 bytes / s = 20MB/s = 162.5 mbit /s

    256 maxMsgSend = 40.625 MB/s = 325 mbit/s

    ofcourse this should be throttled by values set in maxBandwith if lower

    i'm i right or missed something else?
    You missed the server fps.

    It seems that MaxMsgSend is "packets per player per simulation cycle", so your examples above would be 20/40 MB per frame. Multiply with the server fps for MB per second. Quite high numbers there, which will never be reached due to bandwidth optimization.

    So it seems that the MaxMsgSend value is mostly irrelevant in the grand scheme of things, unless you set it incredibly low for some odd reason. This is at least my current understanding.

    Gigabyte P67X-UD3-B3 Motherboard | Intel Core i7 2600k @ 4.0GHz | NVidia GeForce GTX770 4GB
    16GB Corsair XMS3 1600Mhz RAM | Kingston HyperX SSD | ASUS Xonar D2X
    sound | be Quiet! 700W PSU | Windows 7 x64

  4.   Click here to go to the next Developer post in this thread.   #44
    ou yes, forgot per frame ... silly me ... {where is emotion for dig into sand}

  5. #45
    Quote Originally Posted by PvPscene View Post
    Don't forget that AI means additional traffic AND CPU use - BOTH for the server AND the clients.

    Please put this in a new locked topic,in capital letters and make it sticky !!!

    Some server admins have problems understanding it.

  6. #46
    Quote Originally Posted by MadDogX View Post

    So it seems that the MaxMsgSend value is mostly irrelevant in the grand scheme of things, unless you set it incredibly low for some odd reason. This is at least my current understanding.

    Actually, old titles like Descent used fairly low packets-per-second/client, like values as low as 6 to 14.

    So I ran a test, dropped maxmsgsend to 64, loaded mountain warfare, dropped in 2 clients, left the AI in. Server fps dropped to mid to upper 30's. CPU usage was fairly high, 70% to 90%, but not as high as before.

    Now running maxmsgsend at 32, server fps is now mid to upper 40's. CPU usage is stayin in the 60% to 80% range now.

    ...Syn...

  7. #47
    Second Lieutenant GossamerSolid's Avatar
    Join Date
    Feb 3 2006
    Location
    Ontario, Canada
    Posts
    4,312
    Quote Originally Posted by Qazdar View Post
    Please put this in a new locked topic,in capital letters and make it sticky !!!

    Some server admins have problems understanding it.
    Yep, people often forget that... it's really annoying.

    Also when people say "Oh the unit is local to this client, means it only affects them"... WRONG!

    ArmA 3 - GWAR3
    ArmA 2 - PCDF | Gossamer's Warfare
    PC - i5 3570K | EVGA GTX 780 ACX | 16GB DDR3


  8. #48
    Quote Originally Posted by VisceralSyn View Post
    Actually, old titles like Descent used fairly low packets-per-second/client, like values as low as 6 to 14.

    So I ran a test, dropped maxmsgsend to 64, loaded mountain warfare, dropped in 2 clients, left the AI in. Server fps dropped to mid to upper 30's. CPU usage was fairly high, 70% to 90%, but not as high as before.

    Now running maxmsgsend at 32, server fps is now mid to upper 40's. CPU usage is stayin in the 60% to 80% range now.

    ...Syn...
    I'm testing MaxMsgSend=8 at the moment. Looking good so far.

    Even "1" worked in small missions.

  9. #49
    I've been running MaxMsgSend=32; for a little bit into the mission. I am seeing a little desync, like 1 to 8, randomly, once i spotted 200 something. but has gone away just as quickly as i saw it.

    Are you seeing any desync, other than in the player-tab?

    what I really like, is the CPU usage isn't pegged at 100% anymore, and the server FPS staying above 30, is just plain nice...

    ...Syn...
    Last edited by VisceralSyn; Jan 30 2012 at 17:34. Reason: typos and other grammatical errors, as usual...

  10.   Click here to go to the next Developer post in this thread.   #50
    tweak more to find the perfect balance (it again may shift depending on the mission script load, AI load, player load, connection quality, hardware quality and so on)

Page 5 of 10 FirstFirst 123456789 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •