Page 2 of 10 FirstFirst 123456 ... LastLast
Results 11 to 20 of 100

  Click here to go to the first Developer post in this thread.  

Thread: Dedicated server performance

  1. #11
    Quote Originally Posted by Sickboy View Post
    Wasn't the regularCheck issues supposed to be resolved/improved with v1.60?
    Is this is not the case?
    It was supposed to be, but in my testing with the current 1.60 Linux DS, things have only improved slightly. It still randomly kicks legitimate players and causes a significant amount of desync.

    I haven't created a CIT ticket because I don't have any actual information on it - no logs or anything that could indicate the source of the problem.

  2. #12
    Do you have -netlog running (does that work in linux machines even)?

    If you enjoy my work and want to my support efforts doing this for a living,
    please consider to become a patreon - Community Funded Modding!


    (305 of 1000$ per month by 36 patrons reached for first tier)


    Current projects: CUP, AiA TP, AiA SA, AiA HQ, IFA3


    Help: Got a crash? Report it! What is the RPT log file?

  3. #13
    I'm also having a performance problem with my server running RP missions..

    I start a mission and everything seems fine...checking with monitor and server fps stays at 48 steady all the time, the it suddenly goes to 0-5fps like "freezing" and dsyncing players, and it comes back, sometimes really quick, sometimes not (2-15sec).

    Cpu load stays under 50% all the time, then it drops to zero during that "freeze" period, and comes back again..I've checked rpt files and it all seems fine.

    Has anyone seen this?

    Spoiler:


    It's annoying and happens every couple minutes..
    Last edited by ArmaholicBR; Jan 17 2012 at 07:45.

  4. #14
    Quote Originally Posted by PvPscene View Post
    Do you have -netlog running (does that work in linux machines even)?
    It works on the Linux DS.

    Quote Originally Posted by ArmaholicBR View Post
    I'm also having a performance problem with my server running RP missions..
    Use the Linux DS if you're running ZL.

  5. #15
    Private First Class Sibolo's Avatar
    Join Date
    Mar 25 2011
    Posts
    22
    Author of the Thread

    regulaCheck

    I've read all your posts paying a lot of attention to all the matters.

    One thing that really interested me, following your suggestion about the regularCheck command is this:

    From the BIS WIKI:

    If you do not include the regularCheck option or set regularCheck=""; it will be activated. This means the server checks files from time to time by hashing them and comparing the hash to the hash values of the clients. Since newer server versions this has lead to some lag spikes on certain systems, because the whole file is hashed in one burst. (The heavy I/O operation essentially blocking the whole server application for 1-5 secs, depending on the file size)
    regularCheck is also known to cause sporadic (10 mins - 2 hrs) disconnects, terminating the client with "You were kicked off the game." on the client side and "Player Test disconnected." in the console log. To turn this function off, write regularCheck="{}";. But beware, this will also make the server more prone to cheating (even though most cheats are averted when connecting)


    The description of the effects of the regularCheck on "some" systems is amazingly similar to what I've come up with in fact my own description of the problem in the first post was:
    "we have higher FPS which actually stays in the 30-40 zone....but suddenly it goes down to around zero, than after a second it comes back up to high values. This gives smooth game for about 30 secs and than a big lag to everybody: unplayable.
    Further investigating showed that maybe those lags can be due to sudden big I/O operations so I thought of a disk bottleneck and started looking at the possibility of using a ramdisk and tried the Fancycache program, but we are still having these problems."


    How can I disable regularCheck?
    Is it the regularCheck="{}"; that Das Attorney suggested?



    Thank you.

  6. #16
    Quote Originally Posted by eddieck View Post
    Use the Linux DS if you're running ZL.
    No way to fix the "freezing" under Win2003? I can't format the server

    I have an aplicaion running there that needs windows..

  7. #17
    Server.cfg

    persistent=1; // If 1, missions still run on even after the last player disconnected.

    This option impacts high performances.
    Clan FSF : www.clan-fsf.fr


  8. #18
    Quote Originally Posted by ArmaholicBR View Post
    No way to fix the "freezing" under Win2003? I can't format the server
    I wasn't able to fix it. The only thing I can suggest is to try changing -cpucount and -exthreads, but that may not work.

  9. #19
    Quote Originally Posted by FSF_TargetZero View Post
    Server.cfg

    persistent=1; // If 1, missions still run on even after the last player disconnected.

    This option impacts high performances.
    Yes, persistent is turned on. The problem with performance could happen, but i think it isnt whats causing it.. As you can see, cpu doesnt even reach 50% load. Even with noone playing, i can see that the freeze still occurs, coming back to Life in a few seconds..

  10. #20
    I get this problem also (server)... after awhile it looks like the game migrates to one cpu... I have had cpu 1 go to max after a while and then re-run the same mission I have had cpu 4 go to max... very strange and I am interested in a tweak to get around this...
    Intel Core i7 980X EXTREME, 24 Gig RAM, 240 Gig Revo x 2 SSD, 2 X EVGA (SC) 680GTX's, Win 7 64 Pro,
    Single 27 inch Monitor, Oculus Rift V 1.0, Track IR 5, HOTAS Warthog, SIMPEDS Pedals..Arma3 Ready... not....

Page 2 of 10 FirstFirst 123456 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •